Solved: grub_is_lockdown

Forum Forums Official Releases antiX-21/22 “Grup Yorum” Solved: grub_is_lockdown

Tagged: , ,

  • This topic has 1 reply, 2 voices, and was last updated Jan 24-9:23 am by Anonymous.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #75956
    Member
    bdtc

      I installed antix 21 over a system which had antix16. On reboot I kept getting the error ‘grub_is_lockdown’ and grub would enter rescue mode.

      (I could still boot using the install USB stick and selecting the boot image, then the USB stick could be unmounted and removed until the next boot.)

      For reference, the Debian bug for this is:
      http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=984760
      (This critical bug is still unsolved after almost a year!)

      One solution, which worked for me, is mentioned in the thread:
      http://forums.debian.net/viewtopic.php?t=149855

      Essentially, the antix16 EFI file was still installed alongside the antix21 EFI file, and the boot order tried antix16 first.

      To fix this, per the second link above:
      – Reboot with the install USB stick using the antix21 image to get the system going.
      – Install efibootmgr
      – List the EFI files with efibootmgr -v
      – Disable the older EFI files with
      efibootmgr -A -b XXXX
      leaving the antix21 version as the first to try.
      – Instead of disabling some of the choices, it may be possible to simply change the order:
      efibootmgr -o 0001,0000,0004
      for example.

      Other solutions are mentioned in the first thread above, but those installing many versions over the years may come across this boot order problem.

      • This topic was modified 2 years, 4 months ago by bdtc. Reason: Formatting
      #75960
      Anonymous

        Thanks for posting to share these tips!

      Viewing 2 posts - 1 through 2 (of 2 total)
      • You must be logged in to reply to this topic.