(solved)Keyboard layout not saved after reboot

Forum Forums Official Releases antiX-19 “Marielle Franco” (solved)Keyboard layout not saved after reboot

This topic contains 1 reply, has 2 voices, and was last updated by anticapitalista Nov 6-5:20 am.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #28850
    Member
    Avatar
    Riki

    Hello!

    I have a frugal-static install of antix 19 with persist root enabled.
    My keyboard layout was not saved in between reboots and it always reverted back to “gb”. I used the Control Centre -> System -> Set System Keyboard Layout command and it was only changed for the current session. However, the settings in /etc/default/keyboard where correctly changed but reverted after a reboot.

    Then I tried this command: setxkbmap -model pc105 -layout at which changes the keyboard layout in a cli-way, but the settings were still not saved after a reboot.

    I added a line in .bash_profile that executes the above command. According to the bash man page, the .bash_profile file is executed every time I log in, so it should work, right? It did not :'(

    I tried creating a new cronjob with @reboot setxkbmap -model pc105 -layout at but still no luck.
    I looked through the old forum archives and someone created a init-script that apparently fixes this issue. So I tried creating a script in the /etc/init.d/ directory which executes the above command but alas, the settings were still overwritten.

    It even says in the /var/log/Xorg.0.log that the keyboard was initialized with the “gb” keyboard layout, but how is that possible?

    [    16.679] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input11/event7"
    [    16.679] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
    [    16.679] (**) Option "xkb_model" "pc105"
    [    16.679] (**) Option "xkb_layout" "gb"
    [    16.679] (**) Option "xkb_options" "grp:alt_shift_toggle,terminate:ctrl_alt_bksp,grp_led:scroll"

    I finally found a solution on reddit that worked for me (It’s for antix-13 but if it works it works!):
    Reddit post

    I’m sorry if I’m spamming here to much but I thought this could help someone else out.

    But I really would like to know why this keeps happening! Did I forget to configure some magic variable?
    The bug (if it is a bug) must happen sometime late into the boot process, otherwise the init-script or the cronjob would have worked.
    Also, why didn’t the command in the .bash_profile work? Can someone pls tell me what I did wrong?

    Note: Strangely, with the reddit solution the settings in the /etc/default/keyboard file are not modified but the keyboard is setup correctly.

    #29035
    Forum Admin
    anticapitalista
    anticapitalista

    Since you are running frugal, you could add kbd=at to the boot menu.
    That gives AT keyboard with English localisation.
    If you want AT throughout, use F2 Deutch (AT) option.

    Philosophers have interpreted the world in many ways; the point is to change it.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.