Some application names do not display in the Desktop Menu when using RDP to XRDP

Forum Forums New users New Users and General Questions Some application names do not display in the Desktop Menu when using RDP to XRDP

  • This topic has 24 replies, 3 voices, and was last updated Jun 11-7:34 am by abc-nix.
Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #144841
    Member
    intel

      When i RDP to xrdp on my antiX with zzz-icewm,
      Some application names do not display in the Desktop Menu .

      i clicked “refresh menu,” it didn’t solve the problem

      I tried
      “sudo desktop-menu –write-out-global” it cannot get the true user .

      I also tried

      export USER=intel
      export LOGNAME=intel
      sudo -E desktop-menu –write-out-global

      it cannot get the true user either.

      #144849
      Forum Admin
      anticapitalista

        Which locale are you using?
        Which version of antiX – full,base, other?

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #144856
        Member
        intel

          locale en_US
          antiX-full

          #144857
          Member
          intel

            before the xrdp zzz-icewm display problem was fixed by abc-nix #144764, there was no problem in Desktop Menu . that time I use locale zh_CN .

            after the zzz-icewm can display when RDP to xrdp then this new problem came . them i switched to en_US, but nothing better.

            #144877
            Member
            abc-nix

              EDIT: Below is not needed. Changing the locale fixed the menus.

              Let’s test if desktop-session is related to the issue.

              Backup the .xsession file to be able to restore later
              cp ~/.xsession ~/.xsession_backup
              And change the .xsession to only start icewm. Open the file and replace the content with only
              icewm

              Reboot and xrdp into the system again to see if the menus are OK or not. If they are OK, then desktop-session does something strange when setting up the user env variables or something else interferes with rendering the text. But I will explore this once the bug is confirmed.

              • This reply was modified 1 month ago by abc-nix.
              #144884
              Member
              intel

                Hi abc-nix nice to hear from you again . today when i set the locale back to zh_CN , the menu issue fixed .
                But every time when i install or uninstall some apps , the terminal will pop up that cannot find ture user error at the end .
                I will try your advice later and let you know

                #144887
                Member
                abc-nix

                  Good to know it is locale related, as anticapitalista suspected. Don’t try the recommendation I wrote before.

                  I will be testing this myself once I have time. I think something is wrong with authentication on xrdp. Maybe elogind is needed to pick up on the user login with xrdp.

                  #144889
                  Member
                  abc-nix

                    When you open a terminal, run this command
                    xhost + local:
                    or
                    xhost +
                    and during that session you will be able to run sudo without the “Authorization required, but no authorization protocol specified” error, based on this answer.

                    It isn’t a permanent fix, but it should help for now.

                    #144891
                    Member
                    intel

                      Ok , I tried to run
                      xhost + local:
                      or
                      xhost
                      same problem ,
                      look at the last 3 lines
                      cannot get ture user . is there any ways to close this error messages , I don’t want to see if anymore .

                      #144897
                      Member
                      abc-nix

                        You use one or another, not both at the same time. I could run
                        sudo -E desktop-menu --write-out-global
                        after running the xhost + local: command using xrdb. I will try again with adding it in .desktop-session/startup to see if it also works on GUI tools like package installer.

                        I found this topic that explains the same issue you are experiencing with xrdp, that I also experienced myself this morning. Once I have a permanent solution for GUI apps I will share it with you.

                        • This reply was modified 1 month ago by abc-nix.
                        #144905
                        Member
                        abc-nix

                          I think I found an improvement for desktop-menu to find the username using env variables.

                          I observed the same sudo message
                          Authorization required, but no authorization protocol specified
                          on my antiX-with-testing-repos system when I run without the -E option on wayland. It is possible that it is also present with any of the default antiX Window Managers.

                          I will experiment on a live antiX23 with xrdp to see if the issue can be fixed without the xhost hack by replacing the os.getlogin with a different function. But it will still require using sudo -E to load the env variables.

                          #145070
                          Member
                          intel

                            The same problem persists: When I enter the command line xhost + local: and sudo -E desktop-menu –write-out-global using xrdp, the following error occurs:
                            Traceback (most recent call last):
                            File “/usr/local/bin/desktop-menu”, line 367, in <module>
                            username = get_true_user()
                            ^^^^^^^^^^^^^^^
                            File “/usr/local/bin/desktop-menu”, line 128, in get_true_user
                            return os.getlogin() # maybe some more checking needed here
                            ^^^^^^^^^^^^^
                            OSError: [Errno 6] No such device or address

                            #145072
                            Member
                            intel

                              Another interesting issue arises when I try to use xrdp to access the antiX forum on a remote device running antiX system to reply to your message. The forum shows the error message: ***Forbidden, Sender blacklisted. Anti-Spam by CleanTalk.*** I suspect that the antiX forum is mistakenly identifying its own antiX system as a spam device because I can reply to messages on the antiX forum normally using my Windows computer and phone.

                              #145083
                              Member
                              abc-nix

                                I spoke to one of the antiX developers, and he has found a way to get desktop-menu to work with env. variables.

                                I initially tested on my customized system, and it worked properly for me with the xhost hack. But when I tried to remote desktop into a Live antiX 23 system, I encountered your same issue.

                                There is a merge request waiting on the antiX git repos, but meanwhile please try replacing the contents of /usr/local/bin/desktop-menu with this source.

                                You can edit the file with
                                sudo -E geany /usr/local/bin/desktop-menu
                                replace the contents, save and close the window. Then try again with
                                sudo -E desktop-menu --write-out-global

                                It should also now work from the packageinstaller app.

                                If you can confirm that this works, then we can get the fix added to the desktop-menu package.

                                About the forum issue, I have no idea why. I briefly tested antiX through xrdp and all I tested seemed to work (except for the desktop-menu issue and using sudo without the -E option.

                                • This reply was modified 1 month ago by abc-nix.
                                #145087
                                Member
                                intel

                                  This morning, I reinstalled the system, changing it to antiX_23.1 base sysVinit, en_US. Everything was normal at first until I installed xrdp and encountered this issue while remotely installing other software:
                                  File “/usr/local/bin/desktop-menu”, line 367, in <module>
                                  username = get_true_user()
                                  ^^^^^^^^^^^^^^^
                                  File “/usr/local/bin/desktop-menu”, line 128, in get_true_user
                                  return os.getlogin() # maybe some more checking needed here
                                  ^^^^^^^^^^^^^
                                  OSError: [Errno 6] No such device or address

                                  I just entered sudo -E geany /usr/local/bin/desktop-menu in the terminal, and the error shown in the picture appeared:
                                  Then I used the command sudo nano /usr/local/bin/desktop-menu, and after completing the subsequent steps, it threw an error:

                                Viewing 15 posts - 1 through 15 (of 25 total)
                                • You must be logged in to reply to this topic.