Some application names do not display in the Desktop Menu when using RDP to XRDP

Forum Forums New users New Users and General Questions Some application names do not display in the Desktop Menu when using RDP to XRDP

  • This topic has 24 replies, 3 voices, and was last updated Jun 11-7:34 am by abc-nix.
Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
    Posts
  • #145090
    Member
    intel

      Here are the steps I followed to install xrdp. I’m guessing some steps might have caused this error.

      sudo apt install xrdp
      sudo apt install xorgxrdp
      sudo adduser xrdp ssl-cert
      sudo ufw allow 3389
      sudo ufw enable
      sudo service xrdp start
      sudo nano .xsession
      and add “/usr/local/bin/desktop-session zzz-icewm” then save .

      #145091
      Member
      abc-nix

        I have it similar to you, but I was running antiX 23 runit live and headless. Later today I will try again with only the changes you provided, nothing else.

        Does this command also output the same error message?
        gksudo geany /usr/local/bin/desktop-menu
        If this one works, use it instead of nano to replace the file contents. I may also build a testing package when I have time to make it easier to update the desktop-menu file if gksudo also doesn’t work.

        EDIT: package of desktop-menu patched
        download it, in the zzzfm file manager, open the folder containing the .deb file. Right-click on the file and click on the deb-installer option.

        If that doesn’t work, press the F4 key and a terminal will open with the current path. You can then run
        sudo apt install ./desktop-menu-antix_0.1.12.1_all.deb
        and it will install for you. You can then try the desktop-menu command I wrote in my previous comment and see if it works.

        • This reply was modified 1 week, 1 day ago by abc-nix.
        #145093
        Member
        intel

          gksudo geany /usr/local/bin/desktop-menu
          this command can open the desktop-menu , and i add replace the content with this source
          But when i try to intall im-config , i got this error:
          Authorization required, but no authorization protocol specified

          Authorization required, but no authorization protocol specified

          (desktop-menu:9109): Gtk-CRITICAL **: 04:47:29.937: gtk_icon_theme_get_for_screen: assertion ‘GDK_IS_SCREEN (screen)’ failed
          Writing Menu: icewm
          Traceback (most recent call last):
          File “/usr/local/bin/desktop-menu”, line 486, in <module>
          build_menu()
          File “/usr/local/bin/desktop-menu”, line 322, in build_menu
          process_menu(menu)
          File “/usr/local/bin/desktop-menu”, line 228, in process_menu
          icon = find_icon(entry) or default_folder_icon
          ^^^^^^^^^^^^^^^^
          File “/usr/local/bin/desktop-menu”, line 157, in find_icon
          if icon_theme.lookup_icon(appicon, icon_size, 0) and not no_gtk:
          ^^^^^^^^^^^^^^^^^^^^^^
          AttributeError: ‘NoneType’ object has no attribute ‘lookup_icon’

          Attachments:
          #145096
          Member
          abc-nix

            Ok. At least the desktop-menu fix works with sudo -E.

            Does the packageinstaller work properly or does it also have the same error message as your last screenshot? And if you install using gksudo apt install … instead of sudo, does it also have the same error?

            I will have to look into it. Maybe with elogind (which manages the login session) this could be fixed, but I will have to test this later.

            #145097
            Member
            intel

              i used
              sudo dpkg -i desktop-menu-antix_0.1.12.1_all.deb
              to install it .
              because this command didnt work sudo apt install ./desktop-menu-antix_0.1.12.1_all.deb
              now im testing to install some other apps

              #145106
              Member
              intel

                Packageinstaller work properly

                #145108
                Member
                intel

                  use gksudo apt install … it works properly . thank you abc-nix
                  I’ll use gksudo for now and look forward to your perfect fix so I can use sudo later.

                  Attachments:
                  #145111
                  Member
                  abc-nix

                    I don’t think there will be a perfect fix for sudo, but will try with elogind later. Not much hope though, as there are 3 issues:
                    1. Running things as sudo should only be done for doing things as root. With wayland on the horizon, even using gtksudo for GUI applications will be blocked, so many programs like packageinstaller will need to be reworked.
                    2. For the menu to update with a sudo command, it is possible that desktop-session itself would need to be reworked to suport PAM. Alternatively, reworking the desktop-menu-apt-update script when apt installs/removes packages to somehow detect the active/loged-in user could also be an option.
                    3. Remote desktop isn’t a priority for the antiX Linux team.

                    At least this issue lead to a better desktop-menu script. Now we need time for the proposed changes be revised, approved, accepted and for a new update to hit the repos.

                    #145114
                    Member
                    intel

                      after doing the test above . found two new errors .

                      This prompt always pops up after every reboot:”Window Manager not found to be …”
                      and Applicatoin Menu is missing now ….
                      (can you send me the source for Application Menu ?)

                      #145120
                      Member
                      abc-nix

                        For the second issue (empty menus), you can recreate the menus with the well-know command we have been doing recently
                        sudo -E desktop-menu --write-out-global

                        For the first issue, you can disable the check by editing the .desktop-session/desktop-session.conf file (no sudo, nromal user)
                        geany ~/.desktop-session/desktop-session.conf

                        and change the FORCE_LOAD variable from false to true
                        FORCE_LOAD="true"

                      Viewing 10 posts - 16 through 25 (of 25 total)
                      • You must be logged in to reply to this topic.