Some programs only work with root

Forum Forums General Software Some programs only work with root

  • This topic has 7 replies, 2 voices, and was last updated Jan 28-8:03 pm by seaken64.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #31375
    Member
    Avatarseaken64

    So I have noticed that a few of the programs I am using on this new install of antiX-19.1 will not launch from the IceWM menu. But if I open the terminal and type “sudo program_name” they launch. Synaptic, gdebi are two examples. And I also can’t access some files or partitions in spaceFM unless I first start the root terminal to launch spaceFM.

    This may all be normal. Perhaps I have been spending too much time in MX and I have forgot that I need to work around more permission issues.

    But why am I able to install synaptic or gdebi, for example, and have them entered on my menu when logged in as my regular user, but then I can’t launch these programs from this menu? Maybe I need to be doing something to these menu entries to grant permission?

    I am wondering now if that was the problem I was having with SeaMonkey 2.49.5. When I would click on the menu item to launch it it would not launch. I did try using the terminal to launch but I don’t remember if I prefaced with “sudo”. Hmm.

    Seaken64

    #31385
    Forum Admin
    anticapitalistaanticapitalista

    I assume you are using core or net versions. You will need to edit the /usr/share/applications/desktop files for synaptic, gdebi.

    Exec=gksu synaptic
    Exec=gksu gdebi-gtk %f

    How are the partitions formatted? ntfs partitions have deliberately been set to open only by root.

    You should not open any browser as root or with sudo.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31420
    Member
    Avatarseaken64

    I’m running the Base version. I will look at those desktop files as you suggest. Maybe it’s a bug that the installer does not set the Exec setting in Base?

    Seaken64

    #31424
    Forum Admin
    anticapitalistaanticapitalista

    Ok, I remember now that base doesn’t ship with gdebi or synaptic so only antiX-full gets the correct .desktop entry.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #32187
    Member
    Avatarseaken64

    You will need to edit the /usr/share/applications/desktop files for synaptic, gdebi.

    Exec=gksu synaptic
    Exec=gksu gdebi-gtk %f

    Hi anti,

    I edited the desktop files as you suggest above. It works to start gdebi but synaptic still will not start. The synaptic desktop file had “synaptic-pkexec”. I tried both “gksu synaptic-pkexec” and “gksu synaptic”. But it does not start off the menu. It does start from the command line with “sudo synaptic”.

    Thanks,
    Seaken64

    #32188
    Member
    Avatarseaken64

    Just found out that Synaptic does start off the Control Centre Manage Packages button. It’s only off the Applications menu that it does not start.

    Seaken64

    #32194
    Forum Admin
    anticapitalistaanticapitalista

    Edit the ‘Applications’ file (as root) in ~/.icewm (eg make sure synaptic entry shows gksu synsptic)

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #32206
    Member
    Avatarseaken64

    I looked at the file you pointed me to. It was called menu-applications. It already had the correct command of “gksu synaptic”.

    I retried starting synaptic from the Applications|Programming menu. This time it worked.

    Don’t know why it wouldn’t start last few times I tried it. But as I said it did start from the Control Centre.

    Maybe I was in JWM? and not IceWM? Not sure.

    Anyway, it seems to be fixed.

    Thanks for your help.

    Seaken64

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.