Sound in Firefox and TOR

Forum Forums General Tips and Tricks Sound in Firefox and TOR

This topic contains 0 replies, has 1 voice, and was last updated by ModdIt Sep 8-5:13 am.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #26897
    Member
    Avatar
    ModdIt

    Latest Firefox and TOR Browser version are compiled without ALSA support.

    A lot of posts give info on fixing sound, but not in one place. Nice would be a sound issues thread,
    if the mods agree that is. Thanks to all who helped on these issues. Hope this digest helps.

    I did try with pulse, it made my system sound like a cheap Ghetto Blaster. Alsa sound is clearer, not gritty and trashy. I ditched Pulse very quickly.
    System feeds through an Audigy card to Teufel Stereo and Sub Bass for anyone interested. not High End Fi but good.

    For new users please do not be afraid, linux is not rocket science: but you will have to give a couple of commands in the console :-). You can copy and paste.

    For TOR.
    After reading information on the tor site, downloading and unpacking, only from https://www.torproject.org/,
    Keep TOR in Home, it will auto update there. Do not download from other sites, what you get might be comprimised !!!.
    *NEVER EVER touch tor with super user rights. Installation instructions on other sites than torproject org may be written with intent to comprimise. Do not believe me, go read, check the url, fake sites seen.

    I downloaded Quantum from the mozilla site. It is a bundle, no need to install. Unless you want to that is.

    Directory names are my choice. Do it any way you like.

    Use start prefix apulse: you must have a space then application call following. No Space no music.

    Examples: prog “Quantum” /usr/share/icons/papirus-antix/48×48/apps/firefox-icon.png apulse /home/yourname/.Quantum/firefox
    prog “Private Browse” /usr/share/icons/papirus-antix/48×48/apps/tor-browser-ru.png apulse /home/yourname/.Browser/start-tor-browser
    Use the menu Manager in the control center to add to Personal Menu, then if wished in ICE WM add to toolbar.
    If you are new watch the helpful film from Dolfin first, link in the menu.
    There is also an add to menu script described in the depths of this forum, I read after finishing my installation ;-(. No worry, discover the workings is always useful.

    Lets get to work:

    Install patchelf #: sudo apt update && sudo apt-get install patchelf

    Change to within your firefox packet or installation directory. cd to get there

    Then do: patchelf –set-rpath /usr/lib/apulse /usr/lib/firefox/libxul.so

    If you installed to a root directory, not home (from a reporisotory or a deb file). prefix with
    sudo or your command will fail due to lack of rights.

    Note: Watch out for browser updates, you may have to repeat the steps afterwards.

    You might have to change firefox about config preferences to following. I had to but that might change with new versions.

    security.sandbox.content.syscall_whitelist;16
    security.sandbox.content.write_path_whitelist;/dev/snd/

    WARNING changing sandbox settings might be some kind of security risk if
    you do it, on TOR Bundled Browser. Its your system you decide, I want sound so did it.
    You can by the way just put another Browser Bundle in a renamed directory, one patched with sound one without.

    ALSA settings in /home are ignored by latest firefox versions, add “/home/<username>/.asoundrc” to the “security.sandbox.content.write_path_whitelist” option (about:config). path must be comma separated value

    Following might be useful too

    Current Firefox versions seem to ignore ~/.asound.conf (~/. means hidden file in home, dot before file or folder name =hidden)
    you may need to select the default audio output to a different one. If the system settings do not work for you please try following. I was unable to get my Audigy card working using GUI options, sound always defaulted to Onboard, even with that option switched off in BIOS, this fixed it.
    Put an .asound.conf in your home:

    pcm.!default {
    type hw
    card N
    }

    ctl.!default {
    type hw
    card N
    }

    Substitute N with a small integer, 0 for your first sound card (which is the default), 1 for your second, and so on.

    The ! in !default isn’t negation here! It is an overriding of the previously (system-wide defined) global alsa.conf .

    Thanks once more to all devs. antiX IS more than meets the eye.

    Please only constructive comments. Pulse is crap, it degrades sound.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.