Sound in Web-Browsers without Pulseaudio

Forum Forums General Tips and Tricks Sound in Web-Browsers without Pulseaudio

This topic contains 17 replies, has 8 voices, and was last updated by greyowl Sep 13-3:07 pm.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #9491
    Member
    Xaver
    Xaver

    Pulseaudio is related to systemd and does not reach the sound quality of ALSA. Therefore I have banned it from my system. But then I have noticed, that there was sound in any browser. Videos were only playing as silent movies.
    The solution is very simple: Install apulse and start your browser with the ‘apulse’ command ahead. It works well with Firefox-ESR, Flashpeak Slimjet and Falkon (= Qupzilla).

    I.e. edit xy-browser.desktop in /usr/share/applications/ :
    Exec=apulse /usr/lib/firefox-esr/firefox-esr %u
    Exec=apulse falkon %u
    Exec=apulse /usr/bin/flashpeak-slimjet %U

    On my system it works with these audio packages:
    alsa-utils alsamixer-equalizer-antix alsamixergui volumeicon-alsa-legacy libsox-fmt-alsa libasound2-plugin-equal libasound2-plugins libasound2 libasound2:i386

    p.s.: Sound Quality:
    Try alsaplayer-gtk, if you are looking for better sound. This audio player is low on features, but it has a much clearer sound than Audacious or mpv. I went through all the audio settings of Audacious but could not get near to the clearity of Alsaplayer. I have no idea, why this is the case.

    • This topic was modified 7 months, 3 weeks ago by Xaver.
    #9492
    Forum Admin
    anticapitalista
    anticapitalista

    moc and xmms also have better sound (IMO) than Audacious.
    On my box, mpv sound is good.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #9494
    Member
    Xaver
    Xaver

    On my system Audacious with best settings and mpv sound about the same. I thought the sound was good until I have tried Alsaplayer. Now their sound feels dirty somehow.

    • This reply was modified 7 months, 3 weeks ago by Xaver.
    #10096
    Member
    wildstar84
    wildstar84

    If you love the choice of settings / filters and sound quality of Audacious while playing videos and DVDs, feel free to try this wonderfully-enhanced Audacious fork:

    Fauxdacious Media Player (Fork of Audacious)

    Jim

    #10102
    Member

    736b69646f6f

    “Pulseaudio is related to systemd and does not reach the sound quality of ALSA.”

    pulseaudio doesn’t depend on systemd. What means “related”? Shoes are related to socks. If you ban shoes because your socks are stinky, you are “”solving”” the wrong problem.

    pulseaudio is a SERVER application, handles routing of streams provided by alsa or OSS backend. A claim that pulseaudio is responsible for degraded (or improved) sound quality is a claim based on ignorance. For your enlightenment, here is a link to one of many available “”quantitative analysis”” references http://archimago.blogspot.com/2015/10/measurements-look-at-linux-audio-alsa.html

    #10126
    Member
    Xaver
    Xaver

    @ 736b69646f6f
    It is kind of funny, that you compare ALSA and Pulseaudio with a shoe and a stinking sock. But which one is the stinking sock?

    Thank you for the interesting link. In paragraph ‘conclusions’ it confirms a decline in sound quality:
    “Ubuntu uses PulseAudio as the resampling and mixing layer (I believe JACK is another option on top of ALSA). Just like in Windows, when you’re using the default Windows mixer output, we’re not looking at “bitperfect” output any more. As such, audiophiles would consider this a “compromise” rather than the ideal.”

    So Pulseaudio defenitely does not improve the sound. For good sound quality it is needless. Technically that is unnecassary, that browsers need pulseaudio and do not work with plain ALSA anymore. Apulse, a tiny program of 147 kB can fix that. Concerning the annoyance of no ALSA sound in web browsers pulseaudio solves a problem, which would not exist without pulseaudio.

    Systemd, and Pulseaudio share the same parents: Lennart Poettering and Red Hat. They are kinfolk. They are spread on Linux with a similar overbearing attitude to limit choices and to make them unavoidable.

    • This reply was modified 7 months ago by Xaver.
    #10129
    Member

    736b69646f6f

    is needless, is non ideal, is related in kinfolk. Ok, we agree on these these points

    #11724
    Member

    Koo

    I use mpc & ncmpcpp as the player running as a local host with a link to my music folder which is on a separate drive. Love it too bits

    pulse needs alsa no alsa no pulse..

    you can find lots of dots for ncmpcpp here.

    http://dotshare.it

    Dont know why I can’t add a web page link here. ?

    • This reply was modified 4 months ago by Koo.
    • This reply was modified 4 months ago by Koo.
    • This reply was modified 4 months ago by Koo.
    #11833
    Member
    Xaver
    Xaver

    In Antix sid firefox-esr has been upgraded from version 52.9.0esr-1 to 60.1.0esr-3.
    Apulse must be installed for alsa sound without pulseaudio.

    Open ‘/usr/share/applications/firefox-esr.desktop’ with your editor and add apulse to the exec command:
    Exec=apulse /usr/lib/firefox-esr/firefox-esr %u

    Check, if you have got sound in firefox-esr now.
    If not you have to edit the sandbox:

    Go to ‘about:config’ and set the following values:
    security.sandbox.content.write_path_whitelist – set to – /dev/snd/
    security.sandbox.content.syscall_whitelist – set to – 16
    (compare: https://wiki.archlinux.org/index.php/firefox)

    Now you should have pure alsa sound in firefox-esr.

    • This reply was modified 3 months, 3 weeks ago by Xaver.
    • This reply was modified 3 months, 3 weeks ago by Xaver.
    #12102
    Member
    Fonsis
    Fonsis

    In Antix sid firefox-esr has been upgraded from version 52.9.0esr-1 to 60.1.0esr-3.
    Apulse must be installed for alsa sound without pulseaudio.

    Open ‘/usr/share/applications/firefox-esr.desktop’ with your editor and add apulse to the exec command:
    Exec=apulse /usr/lib/firefox-esr/firefox-esr %u

    Check, if you have got sound in firefox-esr now.
    If not you have to edit the sandbox:

    Go to ‘about:config’ and set the following values:
    security.sandbox.content.write_path_whitelist – set to – /dev/snd/
    security.sandbox.content.syscall_whitelist – set to – 16
    (compare: https://wiki.archlinux.org/index.php/firefox)

    Now you should have pure alsa sound in firefox-esr.

    Confirmed!
    I am running firefox-esr 60.2.0esr 64bit since yesterday and had the issue having no sound at all (youtube and other video sites)
    Installed apulse, did the about:config settings mentioned above, exec apulse /usr/lib/firefox-esr/firefox-esr
    —->>> et voila:
    firefox-esr is running fine with sound in videos. 🙂

    Best regards,
    Fonsis
    🙂

    #12129
    Member

    greyowl

    In Antix sid firefox-esr has been upgraded from version 52.9.0esr-1 to 60.1.0esr-3.
    Apulse must be installed for alsa sound without pulseaudio.

    Open ‘/usr/share/applications/firefox-esr.desktop’ with your editor and add apulse to the exec command:
    Exec=apulse /usr/lib/firefox-esr/firefox-esr %u

    Check, if you have got sound in firefox-esr now.
    If not you have to edit the sandbox:

    Go to ‘about:config’ and set the following values:
    security.sandbox.content.write_path_whitelist – set to – /dev/snd/
    security.sandbox.content.syscall_whitelist – set to – 16
    (compare: https://wiki.archlinux.org/index.php/firefox)

    Now you should have pure alsa sound in firefox-esr.

    I followed these instruction, but I still don’t have sound in Firefox ESR.
    Please help.
    Thanks

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #12133
    Member
    Xaver
    Xaver

    @ greyowl
    Do you have alsa sound with your audio player? If not check alsamixer.
    Is apulse installed?

    Start firefox-esr via terminal: $ apulse firefox-esr
    Open a webpage with sound (i.e. youtube). Check in the terminal, if there are any error messages concerning sound.

    #12138
    Member

    greyowl

    @ greyowl
    Do you have alsa sound with your audio player? If not check alsamixer.
    Is apulse installed?

    Start firefox-esr via terminal: $ apulse firefox-esr
    Open a webpage with sound (i.e. youtube). Check in the terminal, if there are any error messages concerning sound.

    I used synaptic package manager to install apulse and libapulse. I checked synaptic and it shows that they are installed.
    I have sound with everything except FF.
    When looking at alsamixer, I don’t know how to tell if apulse is installed?

    I started FF in the terminal, went to utube, and the sound worked and there were no error messages.

    So, it appears that the problem is when I start FF, apulse does not start with it.
    Below is the firefox-esr.desktop file after I added apulse to exec file:
    [Desktop Entry]
    Name=Firefox ESR
    Name[bg]=Firefox ESR
    Name[ca]=Firefox ESR
    Name[cs]=Firefox ESR
    Name[el]=Firefox ESR
    Name[es]=Firefox ESR
    Name[fa]=Firefox ESR
    Name[fi]=Firefox ESR
    Name[fr]=Firefox ESR
    Name[hu]=Firefox ESR
    Name[it]=Firefox ESR
    Name[ja]=Firefox ESR
    Name[ko]=Firefox ESR
    Name[nb]=Firefox ESR
    Name[nl]=Firefox ESR
    Name[nn]=Firefox ESR
    Name[no]=Firefox ESR
    Name[pl]=Firefox ESR
    Name[pt]=Firefox ESR
    Name[pt_BR]=Firefox ESR
    Name[ru]=Firefox ESR
    Name[sk]=Firefox ESR
    Name[sv]=Firefox ESR
    Comment=Browse the World Wide Web
    Comment[bg]=Сърфиране в Мрежата
    Comment[ca]=Navegueu per el web
    Comment[cs]=Prohlížení stránek World Wide Webu
    Comment[de]=Im Internet surfen
    Comment[el]=Περιηγηθείτε στον παγκόσμιο ιστό
    Comment[es]=Navegue por la web
    Comment[fa]=صفحات شبکه جهانی اینترنت را مرور نمایید
    Comment[fi]=Selaa Internetin WWW-sivuja
    Comment[fr]=Navigue sur Internet
    Comment[hu]=A világháló böngészése
    Comment[it]=Esplora il web
    Comment[ja]=ウェブを閲覧します
    Comment[ko]=웹을 돌아 다닙니다
    Comment[nb]=Surf på nettet
    Comment[nl]=Verken het internet
    Comment[nn]=Surf på nettet
    Comment[no]=Surf på nettet
    Comment[pl]=Przeglądanie stron WWW
    Comment[pt]=Navegue na Internet
    Comment[pt_BR]=Navegue na Internet
    Comment[ru]=Обозреватель Всемирной Паутины
    Comment[sk]=Prehliadanie internetu
    Comment[sv]=Surfa på webben
    GenericName=Web Browser
    GenericName[bg]=Интернет браузър
    GenericName[ca]=Navegador web
    GenericName[cs]=Webový prohlížeč
    GenericName[de]=Webbrowser
    GenericName[el]=Περιηγητής ιστού
    GenericName[es]=Navegador web
    GenericName[fa]=مرورگر اینترنتی
    GenericName[fi]=WWW-selain
    GenericName[fr]=Navigateur Web
    GenericName[hu]=Webböngésző
    GenericName[it]=Browser Web
    GenericName[ja]=ウェブ・ブラウザ
    GenericName[ko]=웹 브라우저
    GenericName[nb]=Nettleser
    GenericName[nl]=Webbrowser
    GenericName[nn]=Nettlesar
    GenericName[no]=Nettleser
    GenericName[pl]=Przeglądarka WWW
    GenericName[pt]=Navegador Web
    GenericName[pt_BR]=Navegador Web
    GenericName[ru]=Интернет-браузер
    GenericName[sk]=Internetový prehliadač
    GenericName[sv]=Webbläsare
    X-GNOME-FullName=Firefox ESR Web Browser
    X-GNOME-FullName[bg]=Интернет браузър (Firefox ESR)
    X-GNOME-FullName[ca]=Navegador web Firefox ESR
    X-GNOME-FullName[cs]=Firefox ESR Webový prohlížeč
    X-GNOME-FullName[el]=Περιηγήτης Ιστού Firefox ESR
    X-GNOME-FullName[es]=Navegador web Firefox ESR
    X-GNOME-FullName[fa]=مرورگر اینترنتی Firefox ESR
    X-GNOME-FullName[fi]=Firefox ESR-selain
    X-GNOME-FullName[fr]=Navigateur Web Firefox ESR
    X-GNOME-FullName[hu]=Firefox ESR webböngésző
    X-GNOME-FullName[it]=Firefox ESR Browser Web
    X-GNOME-FullName[ja]=Firefox ESR ウェブ・ブラウザ
    X-GNOME-FullName[ko]=Firefox ESR 웹 브라우저
    X-GNOME-FullName[nb]=Firefox ESR Nettleser
    X-GNOME-FullName[nl]=Firefox ESR webbrowser
    X-GNOME-FullName[nn]=Firefox ESR Nettlesar
    X-GNOME-FullName[no]=Firefox ESR Nettleser
    X-GNOME-FullName[pl]=Przeglądarka WWW Firefox ESR
    X-GNOME-FullName[pt]=Firefox ESR Navegador Web
    X-GNOME-FullName[pt_BR]=Navegador Web Firefox ESR
    X-GNOME-FullName[ru]=Интернет-браузер Firefox ESR
    X-GNOME-FullName[sk]=Internetový prehliadač Firefox ESR
    X-GNOME-FullName[sv]=Webbläsaren Firefox ESR
    Exec=apulse/usr/lib/firefox-esr/firefox-esr %u
    Terminal=false
    X-MultipleArgs=false
    Type=Application
    Icon=firefox-esr
    Categories=Network;WebBrowser;
    MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/vnd.mozilla.xul+xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;
    StartupWMClass=Firefox-esr
    StartupNotify=true

    Did I add apulse correctly?

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

    #12139
    Moderator
    masinick
    masinick

    Exec=apulse /usr/lib/firefox-esr/firefox-esr %u – with a space between apulse and the firefox location is the key. It appears there is a typographical error in the configuration missing the space.

    Change that and it ought to work, since you confirmed that it works when you type in apulse firefox-esr

    Brian Masinick

    #12140
    Member

    greyowl

    Exec=apulse /usr/lib/firefox-esr/firefox-esr %u – with a space between apulse and the firefox location is the key. It appears there is a typographical error in the configuration missing the space.

    Change that and it ought to work, since you confirmed that it works when you type in apulse firefox-esr

    Thanks for the correction.
    I made the correction, but I still don’t have sound in FF.

    Attached is a screen shot (jpg) of my about:config section with the changes as instructed by Xaver. Are they correct?

    Thanks for the help.

    Attachments:

    Dell Latitude D610 laptop (1.86 GHz, 2G RAM, 32 bit) - antiX 17

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.