Sound issues

Tagged: 

  • This topic has 11 replies, 4 voices, and was last updated Feb 7-3:39 pm by Xecure.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #53949
    Member
    Avatarmustdos

    Hello all!

    I’m having issues in laptop to give me sound over HDMI; it only detects my internal speakers in Alsa. I tried to install PulseAudio but it didn’t help; it just gets stuck in “establishing connection to PulseAudio. Please wait…” window.

    Any help would be appreciated.

    #53951
    Member
    XecureXecure

    Would you mind testing this scrip with Alsa?
    https://www.antixforum.com/wp-content/uploads/2021/02/select-alsa-device.zip

    Select the hdmi device and hit “Test”. If any of them work and a “Front Left – Fron Right” audio plays (and you can hear it), select the device again and click Save.

    Hopefully this time I can get feedback for this script (and hopefully this script helps solve the problem).

    #53952
    Member
    AvatarPPC

    all the help you’ll probably ever need, using antiX: search the forum… I don’t know, maybe, looking for “HDMI”?

    Now, really, try this:

    HDMI e som

    I hope it works for you, if not, let us know…

    EDIT: damm it, Xecure, type slower!!! I’ve beaten me again… 🙂

    P.

    • This reply was modified 2 months ago by PPC.
    #53961
    Member
    AvatarPPC

    @Xecure- I finally have a working sound card on my desktop, and I tested your script-
    One word: brilliant! It works great! I hope it gets picked up by anticapitalista and finds its way to the Control Centre of the next antiX version!

    Suggestion: I did not take a look at your script, but I found something that may confuse users: once the user selects a card and tests it, the window restarts and does not show any selected sound card… Maybe you can make the main window search for the previous tested sound card (on that time the script is run) and make it the default selection?

    P.

    #54010
    Member
    Avatarmustdos

    Tried the script, the aplay -l got my speakers as here
    mustdosPC% aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    But I can’t get sound over HDMI.

    #54011
    Member
    XecureXecure

    EDIT: damm it, Xecure, type slower!!!

    Hahahaha! I just opened the forum and saw this post. No intention to hijack!

    @Xecure- I finally have a working sound card on my desktop, and I tested your script-

    Thanks for testing. I have followed your feedback and removed the Test button and the test (double-click on the device) now doesn’t close the window.

    I find this script useful for when a card has multiple devices, and each has different output (one the Analog HW, the other HDMI, for example). Selecting the card from “Sound Card Chooser” gives me no options (only 1 card available), and I wasn’t able to get hdmi as default sound output until I created a .asoundrc file in $HOME. I decided to try to add these options to the current card chooser script, but it uses a different method to find the cards available (and not the devices, and also outputs the options to a different script that handles the interface, it was too complicated for me to try to fit the new options there), so I created a replacement that lets you test the device first before saving the changes (and now lets you restore the default configuration).

    I need more people to test it (people with multiple devices for one sound card) before I ask anyone to include it in antiX.

    Hopefully mustdos and other can test it so I can improve and fix issues.

    #54013
    Member
    XecureXecure

    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]

    But I can’t get sound over HDMI.

    Can you give us?
    inxi -Fxz

    I needed to upgrade the kernel to at least version 4.19 for one of my devices with HDMI out to work.

    #54017
    Member
    Avatarmustdos

    System:
    Host: mustdosPC Kernel: 4.9.212-antix.1-amd64-smp x86_64 bits: 64
    compiler: gcc v: 8.3.0 Desktop: MATE 1.20.4
    Distro: antiX-19.2_x64-full Hannie Schaft 27 March 2020
    base: Debian GNU/Linux 10 (buster)
    Machine:
    Type: Laptop System: SAMSUNG
    product: 300E5EV/300E4EV/270E5EV/270E4EV/2470EV/2470EE v: 0.1
    serial: <filter>
    Mobo: SAMSUNG model: NP300E4E-A03SA v: FAB1 serial: <filter> UEFI: Phoenix
    v: P08RBD date: 08/28/2014
    Battery:
    ID-1: BAT1 charge: 37.7 Wh condition: 37.7/48.8 Wh (77%)
    model: SAMSUNG Electronics status: Full
    CPU:
    Topology: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP
    arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB
    flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19953
    Speed: 2900 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 2900 2: 2900
    3: 2900 4: 2900
    Graphics:
    Device-1: Intel 3rd Gen Core processor Graphics vendor: Samsung Co
    driver: i915 v: kernel bus ID: 00:02.0
    Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
    resolution: 1366×768~60Hz
    OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.3.6
    direct render: Yes
    Audio:
    Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Samsung Co driver: snd_hda_intel v: kernel bus ID: 00:1b.0
    Sound Server: ALSA v: k4.9.212-antix.1-amd64-smp
    Network:
    Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter
    vendor: Samsung Co driver: ath9k v: kernel port: efa0 bus ID: 01:00.0
    IF: wlan0 state: up mac: <filter>
    Device-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet
    vendor: Samsung Co RTL810xE driver: r8169 v: 2.3LK-NAPI port: 2000
    bus ID: 02:00.0
    IF: eth0 state: down mac: <filter>
    Device-3: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb
    bus ID: 1-1.3:5
    Drives:
    Local Storage: total: 525.24 GiB used: 395.67 GiB (75.3%)
    ID-1: /dev/sda vendor: Toshiba model: MQ01ABD050 size: 465.76 GiB
    ID-2: /dev/sdb type: USB model: Multiple Card Reader size: 59.48 GiB
    Partition:
    ID-1: / size: 17.18 GiB used: 9.66 GiB (56.2%) fs: ext4 dev: /dev/sda4
    Sensors:
    System Temperatures: cpu: 90.0 C mobo: 29.8 C
    Fan Speeds (RPM): N/A
    Info:
    Processes: 289 Uptime: 23h 17m Memory: 7.68 GiB used: 6.59 GiB (85.8%)
    Init: SysVinit runlevel: 5 Compilers: gcc: 8.3.0 Shell: zsh v: 5.7.1
    inxi: 3.0.36

    #54019
    Member
    XecureXecure

    Kernel 4.9 should work for HDMI audio output.

    I tried to install PulseAudio but it didn’t help; it just gets stuck in “establishing connection to PulseAudio. Please wait…” window.

    Desktop: MATE 1.20.4

    If you still have pulseaudio installed, run this on the terminal
    pulseaudio -D &

    And again try to use the device selector in pulse audio volume control app in MATE, and select HDMI as output. I think there should also be a “test sound” button to make sure it works.

    I may be mistaken, but you may have to enable a MATE option to enable pulseaudio on boot, similar to what needs to be done for KDE.
    (see first half of the video https://www.youtube.com/watch?v=9vLK-CEr0vY)
    As you are using a different DE than the default antiX, and antiX doesn’t use systemd, maybe some of these things need to be handdled.

    If this still doesn’t work, try installing a 4.19 kernel from the Package Installer (search for latest_LTS)

    • This reply was modified 2 months ago by Xecure.
    #54069
    Member
    Avatarmustdos

    This is what I got from pulseaudio -D & after I tried that link

    mustdosPC% pulseaudio -D &
    [1] 1217
    mustdosPC% E: [pulseaudio] main.c: Daemon startup failed.

    [1] + exit 1 pulseaudio -D

    I also updated the kernel

    • This reply was modified 2 months ago by mustdos.
    #54087
    Member
    Avatarpepitofer

    Hi mustdos,

    I myself has some time enabling the hdmi audio output with alsa, as I did not knew how it worked when I “arrived” to antiX.

    What made it work for me was the ~/.asoundrc

    In my case this is what I have in the file:

    pcm.!default {
        type plug
        slave.pcm "hdmi"
    }
    
    pcm.softvol {
        type            softvol
        slave {
            pcm         "hdmi"
        }
        control {
            name        "HDMI 0"
            card        0
            device		3
        }
    }
    

    This enables the HDMI sound, that I can see in the alsamixer as S/PDIF.
    This has no volume control with alsa, as it doen’t have a build-in hardware sound control.

    Another possible file for you is this one:

    pcm.!default {
        type hw
        card 0
        device 3
    }

    Give it a try. I still have not been able to fully understand the file sintaxis 🙁

    Also, try searching for “.asoundrc hdmi audio laptop”, it will provide very useful information of users setting up the same.

    #54089
    Member
    XecureXecure

    What made it work for me was the ~/.asoundrc

    The script I shared does (in a very simplified way) what you describe, adding the card and device to ~/.asoundrc
    The audio device testing didn’t seem to work for mustdos, but maybe adding the .asoundrc configuration and then restarting the system may work.
    The problem I had with my laptop is that I needed a kernel upgrade before the .asoundrc file worked (that is whay I later suggested upgrading the kernel), but it is probably related to having a newer system compared to mustdos’ machine.

    As mustdos is not using the default antiX system but is running MATE desktop on it, some things may work differently (like what had to be done in dolphin_oracle’s video I linked where a file needed to be edited to get pulseaudio to autostart on KDE).

    I cannot test a MATE installation right now to check how things need to be done, so if anyone has any idea, they are welcome to share it here.

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.