Sound not working [solved]

Forum Forums New users New Users and General Questions Sound not working [solved]

  • This topic has 29 replies, 7 voices, and was last updated Apr 26-2:30 pm by ohh.
Viewing 15 posts - 1 through 15 (of 30 total)
  • Author
    Posts
  • #9135
    Anonymous

      Hi. I just installed antiX-17 tonight. I’m liking it quite a bit. I have one problem. The sound does not work. I hope somebody can help me with this. I pasted info below on my soundcard that I pulled using the inxi -f command in Peppermint OS. My sound has worked out the box on all Ubuntu based distros I’ve installed. I currently have Q4OS (Debian 9 based distro) installed and the sound is working perfectly. Thanks in advance for the help.

      Audio: Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
      Sound: Advanced Linux Sound Architecture v: k4.4.0-22-generic

      • This topic was modified 6 years, 2 months ago by anticapitalista. Reason: added solved
      #9137
      Member
      ohh

        Right click on the speaker icon on the taskbar and open mixer,
        and check the status of speaker, master etc, and turn auto-mute to disabled
        or go to control-center click on hardware, you will see the options there to set
        the default card, test sound and adjust mixer

        cheers,
        ohh

        • This reply was modified 6 years, 3 months ago by ohh. Reason: add info

        Every matter requires prior knowledge.

        - Du Mu
        The Art of War

        #9140
        Anonymous

          Thanks for the quick response ohh. I don’t see the auto-mute option.

          #9141
          Member
          ohh

            btw, if you take a look at the Help menu and navigate to antiX–>antiX FAQ there is detailed info
            on almost every option in antiX.

            cheers,
            ohh

            Every matter requires prior knowledge.

            - Du Mu
            The Art of War

            #9142
            Anonymous

              I found the shift+M toggle for mute. The sound is not muted. The Alsa Mixer shows my card is HDA Intel PCH and chip is Realtek ALC255.

              #9146
              Moderator
              caprea

                Hi SleepyD,
                from your antiX installation can you please post the output of
                cat /proc/asound/cards

                and
                aplay /usr/share/sounds/alsa/Front_Center.wav

                Also an inxi -Fxz would be nice, so we know what hardware you are using.

                #9169
                Anonymous

                  Hi caprea. I would’ve posted a response sooner but the forum was down. I’m glad it’s back up. I wonder what that was about. I’ve posted the outputs you requested below. Thanks for the help.

                  $ cat /proc/asound/cards
                  0 [PCH
                  ]: HDA-Intel – HDA Intel PCH
                  HDA Intel PCH at 0xdf140000 irq 129

                  $ aplay /usr/share/sounds/alsa/Front_Center.wav
                  Playing WAVE ‘/usr/share/sounds/alsa/Front_Center.wav’ : Signed 16 bit Little
                  Endian, Rate 48000 Hz, Mono

                  $ inxi -Fxz
                  System:
                  Host: antix1 Kernel: 4.9.87-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc v:
                  6.3.0

                  Desktop: IceWM 1.4.2 Distro: antiX-17.1_x64-full Heather Heyer 17 March 2018

                  Machine:
                  Type: Desktop Mobo: GIGABYTE model: MKLP3AP-00 v: 1.x serial: N/A
                  UEFI: American Megatrends v: F3 date: 10/20/2015

                  CPU:
                  Topology: Dual Core model: Intel Core i3-6100U type: MT MCP arch: Skylake

                  rev: 3
                  L2 cache: 3072 KiB
                  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18436
                  Speed: 699 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 769 2: 525 3:
                  960 4: 830

                  Graphics:
                  Card-1: Intel HD Graphics 520 driver: i915 v: kernel bus ID: 00:02.0
                  Display Server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
                  resolution: 1920×1080~60Hz
                  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa
                  17.3.8
                  direct render: Yes

                  Audio:
                  Card-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
                  bus ID: 00:1f.3
                  Sound Server: ALSA v: k4.9.87-antix.1-amd64-smp

                  Network:
                  Card-1: Intel Ethernet Connection I219-V driver: e1000e v: 3.2.6-k port: N/A
                  bus ID: 00:1f.6
                  IF: eth0 state: down mac: <flter>
                  Card-2: Intel Wireless 3165 driver: iwlwif v: kernel bus ID: 01:00.0
                  IF: wlan0 state: up mac: <flter>

                  Drives:
                  HDD Total Size: 465.76 GiB used: 5.09 GiB (1.1%)
                  ID-1: /dev/sda model: HGST_HTS725050A7 size: 465.76 GiB

                  Partition:
                  ID-1: / size: 37.30 GiB used: 4.98 GiB (13.3%) fs: ext4 dev: /dev/sda8
                  ID-2: swap-1 size: 3.82 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2

                  Sensors:System Temperatures: cpu: 38.0 C mobo: 29.8 C
                  Fan Speeds (RPM): N/A

                  Info:
                  Processes: 177 Uptime: 32m Memory: 7.75 GiB used: 936.7 MiB (11.8%) Init:

                  SysVinit
                  runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 inxi: 3.0.00

                  #9172
                  Forum Admin
                  anticapitalista

                    SysVinit
                    runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 inxi: 3.0.00

                    The bold bits looks weird. Where does that come from?
                    Have you installed anything from debian testing or sid repos? Or worse, ppas?

                    • This reply was modified 6 years, 3 months ago by anticapitalista.

                    Philosophers have interpreted the world in many ways; the point is to change it.

                    antiX with runit - leaner and meaner.

                    #9180
                    Moderator
                    caprea

                      If alsa has both, recognized a card and the play command works, most of the mixer is slightly misaligned.
                      We could maybe look if theres something helpful in dmesg.
                      dmesg | grep snd_hda
                      But sure more interesting from where you got bash 4.4.19.

                      • This reply was modified 6 years, 3 months ago by caprea.
                      #9184
                      Anonymous

                        I setup the system for Testing when I installed it. The system had a bunch of updates when it first booted up. No PPAs. I typed in the command caprea and nothing happened.

                        #9192
                        Moderator
                        caprea

                          Did the sound work on the live-session ?

                          There was one member also with a skylake-box, who ended up in a reinstall
                          https://www.antixforum.com/forums/topic/no-sound-on-dell-xps-15-7559/

                          Maybe the easiest way.
                          You could also try to update to a newer antix-kernel.
                          Or maybe someone else has a good idea.

                          #9278
                          Anonymous

                            caprea, the sound does not work in the live-session. I thought I checked that. I’m pretty certain I’ve had some different distros on my PC that have used kernel 4.9 and the sound worked. I recently installed the lastest Raspian for PCs on here and the sound did not work for that. I don’t recall which kernel it used. I did not see an easy way to upgrade the kernel in antiX. Did I miss something? Thanks again everybody for the help.

                            #9322
                            Moderator
                            caprea

                              To install a kernel is quite easy.You can do it with the package-installer from control-centre.
                              Maybe try the newest there,think it should be 4.15.9 or 4.15.14.
                              Do a
                              sudo update-grub

                              afterwards,then reboot.
                              If the new kernel doesn’t work for you,you can easily switch back to the old one by choosing the advanced options in grub-menu.
                              Should a new kernel not help with your sound problems we can try some other things.

                              #9345
                              Anonymous

                                caprea, unfortunately that did not work. I installed the 4.15.9 kernel. I verified with the uname -a command in terminal. The package-installer is pretty sweet. I had used it before you mentioned it but didn’t notice that there was a section for kernels. I don’t understand why this is not working. I will boot into Q4OS 2.4 and see if I can see anything that is different. It is Debian based and worked without any problems. I will have to look at that tomorrow night after work. Thanks again.

                                #9347
                                Member
                                fatmac

                                  Are any modules showing if you run

                                  lsmod | grep snd

                                  • This reply was modified 6 years, 3 months ago by fatmac.

                                  Linux (& BSD) since 1999
                                  Ultra Small Form Factor & thin client computers

                                Viewing 15 posts - 1 through 15 (of 30 total)
                                • You must be logged in to reply to this topic.