Still using antiX-16 in 2020

Forum Forums Orphaned Posts antiX-16 “Berta C├íceres” Still using antiX-16 in 2020

  • This topic has 57 replies, 10 voices, and was last updated May 17-3:57 pm by Brian Masinick.
Viewing 13 posts - 46 through 58 (of 58 total)
  • Author
    Posts
  • #40157
    Moderator
    Brian Masinick
    Helpful
    Up
    0

    I’m using antiX 16 full on USB with persistent state and with the option “toram”.
    Even running Google Chrome is fast and effective.

    Brian Masinick

    #59169
    Member
    seaken64
    Helpful
    Up
    0

    We are coming up on a year since I started this thread on continuing to use antiX-16. For those who are curious about the longevity of antiX it’s interesting to note that I can still use this old P-III 600 system, with 384Gb RAM, even long after the underlying Debian Jessie repos are no longer supported with updates.

    As an experiment I did try my usual update and upgrade. No upgrades were available and I did get a couple of notices about expired signatures. But I was able to add some software today and the results were pretty decent and more than expected.

    Early in this thread I had mentioned that my usual “goto” browser, SeaMonkey, was not working good enough to be useful. It was sluggish and pegged the CPU at 100% far too much. Recently I had been reading about the “Epiphany” browser (which name was changed to Gnome Web) and that it was one of the only browsers that worked without SSE2 and has a low memory footprint. I decided to try it on this old dinasaur to see if I could once again use the old beast to browse around the web.

    I found version 3.14.1 in the Jessie repos and installed it. It works. But it is not any more useful than SeaMonkey. DuckDuckGo and Google both failed to load search results properly and I could not get anything to open when clicking a link. I tried Startpage and it works to get a page of search results and when I clicked I got to the antiX forum page, finally. The RAM used is about 225M with two tabs open and the CPU stablizes at about 85% when on the antiX forum, which for some reason is a very hard site to use with an old computer. The response is sluggish, but barely usable. And weirdly I could not resize the window. I could move it with Alt-leftclick but I could not resize it with the mouse pointer.

    I looked around to see if I could find a newer version for antiX-16 or MX-15 but I could not find anything yet. Fow now, Epiphany will not be a suitable replacement for SeaMonkey.

    Then I started looking around for other options and tried Netsurf again. I was able to find a more recent version on the MX-15 repo and I installed it (version 3.8). It is better than the previous version (v3.2) but still quirky. It does not render fonts well and has a lot of display issues. And it does not like the antiX forum and it is difficult to login and add and edit messages. It does work, kind of. But not good enough to be dubbed my default browser for antiX-16 on this old computer.

    Then I tried Midori. I have never had good success with Midori, it always crashes on me. So I was hesitant to try it again but I did find it the MX-15 testrepo and installed it. I have been using it all afternoon, much to my surprise. I have been expecting it to crash, but I have been using it for hours and it has not crashed yet. The version is 0.5.11 and I am using it now to enter this message. (And backing up to a text file just in case).

    I have browsed also the MX forum and a few sites from the search list that discuss alternative browsers, etc. I have changed preferences and saved bookmarks and tried to use the browser like I usually use SeaMonkey. It all seems to work. The memory footprint at this moment is about 250M. Now, bear in mind that I don’t browse to commercial sites and use banking or stream videos with a browser on this old computer. But for what I do use a browser for this version of Midori will become my new default browser. At least until I either experience it crashing or find another better solution.

    So, as of today, May 10, 2021 I can still use antiX-16 32-bit to browse around the web a little bit and participate in the forum and I can still use Audacious to listen to my jazz and otherwise use the system normally. This computer is nearly 22 years old, so that’s pretty amazing.

    Seaken64

    Here’s the inxi from this old beast:

    $ inxi -Fxzr
    System:
      Host: antix16 Kernel: 4.4.10-antix.1-486-smp i686 bits: 32 compiler: gcc 
      v: 4.9.3 Desktop: IceWM 1.3.8 Distro: Debian GNU/Linux 8 (jessie) 
    Machine:
      Type: Unknown System: Dell product: XPST600 v: N/A serial: <filter> 
      Mobo: Intel model: SE440BX-3 v: AA722394-112 serial: <filter> BIOS: Intel 
      v: 4S4EB2X0.10A.0026.P08 date: 11/05/1999 
    CPU:
      Topology: Single Core model: Pentium III (Katmai) bits: 32 type: MCP 
      arch: P6 III rev: 3 L2 cache: 512 KiB 
      flags: pae sse bogomips: 1197 
      Speed: 599 MHz min/max: N/A Core speed (MHz): 1: 599 
    Graphics:
      Card-1: NVIDIA NV5 [Riva TNT2 Model 64 / Model 64 Pro] driver: nouveau 
      v: kernel bus ID: 01:00.0 
      Display: server: X.Org 1.16.4 driver: nouveau 
      unloaded: fbdev,modesetting,nv,vesa resolution: 1280x1024~85Hz 
      OpenGL: renderer: Mesa DRI nv05 x86/MMX/SSE v: 1.2 Mesa 10.3.2 
      direct render: Yes 
    Audio:
      Card-1: Yamaha YMF-724F [DS-1 Audio ] driver: snd_ymfpci v: kernel 
      bus ID: 00:0c.0 
      Sound Server: ALSA v: k4.4.10-antix.1-486-smp 
    Network:
      Card-1: Intel 82371AB/EB/MB PIIX4 ACPI driver: piix4_smbus v: N/A 
      port: N/A bus ID: 00:07.3 
      Card-2: ADMtek NC100 Network Everywhere Fast Ethernet 10/100 driver: tulip 
      v: 1.1.15-NAPI port: 1000 bus ID: 00:0d.0 
      IF: eth0 state: unknown speed: N/A duplex: N/A mac: <filter> 
    Drives:
      HDD Total Size: 9.32 GiB used: 5.33 GiB (57.2%) 
      ID-1: /dev/sda vendor: Quantum model: FIREBALLlct10 10 size: 9.32 GiB 
    Partition:
      ID-1: / size: 8.03 GiB used: 5.33 GiB (66.4%) fs: ext4 dev: /dev/sda1 
      ID-2: swap-1 size: 1.03 GiB used: 244 KiB (0.0%) fs: swap dev: /dev/sda2 
    Sensors:
      Message: No sensors data was found. Is sensors configured? 
    Repos:
      Active apt repos in: /etc/apt/sources.list.d/antix.list 
      1: deb http://repo.antixlinux.com/jessie/ jessie main nosystemd
      Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
      1: deb http://security.debian.org/ jessie/updates main contrib non-free
      Active apt repos in: /etc/apt/sources.list.d/debian.list 
      1: deb http://deb.debian.org/debian/ jessie main contrib non-free
      No active apt repos in: /etc/apt/sources.list.d/mx.list 
      Active apt repos in: /etc/apt/sources.list.d/various.list 
      1: deb http://download.opensuse.org/repositories/home:/stevepassert/Debian_8.0/ /
    Info:
      Processes: 135 Uptime: 6h 08m Memory: 370.2 MiB used: 265.6 MiB (71.7%) 
      Init: SysVinit runlevel: 5 Compilers: gcc: 4.9.2 Shell: bash v: 4.3.30 
      inxi: 3.0.10 
    
    • This reply was modified 5 months, 1 week ago by seaken64.
    • This reply was modified 5 months, 1 week ago by seaken64.
    • This reply was modified 5 months, 1 week ago by seaken64.
    #59183
    Member
    calciumsodium
    Helpful
    Up
    0

    Hi @seaken64,
    It is cool to hear about what the minimum requirements are to surf the web. I have been using the text browser links2 in terminal more and more. I can even read the antixforum.com in links2. I have not tried replying in the forum using links2. But I can google and use duckduckgo. I can access many of the major news sites as well as the local news and weather. I find that it is better for me to read the news stories. I find more enjoyment in reading the news instead of watching a bunch of pictures. For my oldest systems that have only 500 Mb of ram, I use links2 with ease. Maybe considering using a text browser as another option in your old system.
    Thanks.

    #59189
    Member
    seaken64
    Helpful
    Up
    0

    Hi @calciumsodium,

    Yes, I do utilize the text based browsers also. But I still feel that a system is not really “usable” for the modern web without at least some modern GUI rendering. This is gettting harder for sure. And expectations have to be low. But I can usually move around the web with a GUI browser using SeaMonkey with NoScript. I can still do that on this machine but it takes a lot of patience. I was hopeful I could find another solution and it seems that Midori is it. I cannot use Badwolf since it appears to require SSE2.

    I’m always searching for the impossible browser. My problme is i’m not very good at programming and compiling so I need to find something alrea in a repo I can use. That limits my choices somewhat since not every possible browser that can be utilized on old equipmwent is in the repos for antiX.

    I like having links2 available. I can go all text or add the graphics. And I can use it either in the GUI (IceWM, etc.) or the Core system with the console and framebuffer only. It’s pretty cool.

    Thanks,
    Seaken64

    #59201
    Member
    seaken64
    Helpful
    Up
    0

    This afternoon I tried two more browsers on this old system – surf and Qupzilla.

    surf works but it does not seem to respond to all the key bindings, like my most used one Ctrl++ to enlarge the view. The manual says it should work with Shift+Ctrl++ but that does not work either. I was able to login to the antixforum.com website but I can’t see anything, it’s too small. surf won’t work for me. Not to mention it is not really meant for a GUI interface.

    Qupzilla became Falkon. The version I installed is 1.8.9. It is very familiar to me, similar in interface to Chrome and Firefox. It was based on Chromium. It works good except it still pegs the CPU at 100% when I go to antixforum.com. I turned off JavaScript in the settings. But nothing seemed to change. I quit the program and then restarted the program. That seemed to work. I logged back in to antixforum.com and it remembered me and I am able to edit my posts. I am typing this message now from Qupzilla. The RAM used is 190M and the CPU is at 10%. This may work.

    So, it seems that I have two candidates for my default GUI browser here in antiX-16, Midori and Qupzilla. I will give them both a chance. I do like the Qupzilla interface since I am familiar with it from my years of using Chrome and Firefox and SeaMonkey. I looked to find a more recent version but there does not seem to be one available. There is a Falkon in the MX-17 repo but that is not Jessie. There is also an appimage in MX-15. I will stay with this Qupzilla version and see what happens.

    Seaken64

    • This reply was modified 5 months, 1 week ago by seaken64.
    #59178
    Member
    seaken64
    Helpful
    Up
    0

    I’m not sure if these two repos that are failing can be fixed or not. Is this just because Jessie is out of support? Or can the invalid signatures be fixed? I have used the fixes for expired signatures on antiX-17 and antix-19 as decribed on the forum. Can I use the same fix for this antiX-16 repo?

    I’m sorry for being so ignorant about tese things. I am still barely conversant on repositories. And now I am wodering if these reported errors are more about Jessie being unsupported or more about expired signatures.

    I’d appreciate any tips you can share. But I also understand if there is no help for antiX-16 anymore.

    Seaken64

    Here’s the output of my update command:

    $ sudo apt update
    [sudo] password for sean:
    Ign http://deb.debian.org jessie InRelease
    Hit http://security.debian.org jessie/updates InRelease
    Hit http://deb.debian.org jessie Release.gpg
    Get:1 http://repo.antixlinux.com jessie InRelease [20.4 kB]
    Hit http://deb.debian.org jessie Release
    Get:2 http://download.opensuse.org InRelease [1,554 B]
    Err http://download.opensuse.org InRelease

    Err http://repo.antixlinux.com jessie InRelease

    Get:3 http://security.debian.org jessie/updates/main i386 Packages [781 kB]
    Hit http://deb.debian.org jessie/main i386 Packages
    Hit http://deb.debian.org jessie/contrib i386 Packages
    Hit http://deb.debian.org jessie/non-free i386 Packages
    Hit http://deb.debian.org jessie/contrib Translation-en
    Hit http://deb.debian.org jessie/main Translation-en
    Hit http://deb.debian.org jessie/non-free Translation-en
    Get:4 http://security.debian.org jessie/updates/main Translation-en [401 kB]
    Hit http://security.debian.org jessie/updates/contrib i386 Packages
    Hit http://security.debian.org jessie/updates/non-free i386 Packages
    Hit http://security.debian.org jessie/updates/contrib Translation-en
    Hit http://security.debian.org jessie/updates/non-free Translation-en
    Fetched 22.0 kB in 31s (692 B/s)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    2 packages can be upgraded. Run 'apt list --upgradable' to see them.
    W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.opensuse.org InRelease: The following signatures were invalid: KEYEXPIRED 1594767246

    W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://repo.antixlinux.com jessie InRelease: The following signatures were invalid: KEYEXPIRED 1619830647 KEYEXPIRED 1619830647 KEYEXPIRED 1619830647 KEYEXPIRED 1619830647 KEYEXPIRED 1619830647 KEYEXPIRED 1619830647 KEYEXPIRED 1619830647 KEYEXPIRED 1619830647 KEYEXPIRED 1619830647

    W: Failed to fetch http://repo.antixlinux.com/jessie/dists/jessie/InRelease

    W: Failed to fetch http://download.opensuse.org/repositories/home:/stevepassert/Debian_8.0/InRelease

    W: Some index files failed to download. They have been ignored, or old ones used instead.

    #59281
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    Read the UPDATED 02-04-2021. EXPKEYSIG error and fix here: expkeysig-fix on the front page for the solution.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #59288
    Member
    skidoo
    Helpful
    Up
    0

    I haven’t checked recently. You may, still, be able to “apt update” from debian repository
    by specifying archive…..oldstable in your /etc/apt/source.lists.d/debian.list

    deb http://archive.debian.org/debian/ jessie main non-free contrib
    or
    deb http://archive.debian.org/debian/ oldoldstable main non-free contrib

    If not, you can at least still browse + manually download packages, from: http://ftp.debian.org/debian/dists/oldoldstable/

    #59325
    Member
    seaken64
    Helpful
    Up
    0

    Oops, I thought this post about the EXPKEYSIG did not get submitted so I added another post in another area. Sorry to double post. But thank you for the guidance. I got it working.

    #59326
    Member
    seaken64
    Helpful
    Up
    0

    Thanks skidoo, I will explore that. I was thinking I may need to update SMTube someday. I will browse around and see what is there in oldstable. Maybe I can update something like this old browser I am using now – Otter 0.9.12 beta 12.

    Seaken64

    #59327
    Member
    seaken64
    Helpful
    Up
    0

    As I mentioned in my last message I found another candidate for my default browser for antiX-16 – Otter. It is a redo of the old Opera 12. It is very low on resources and I have had it up for two days and it has not had any problems yet.

    So now I have three candidates for my default browser – Midori, Qupzilla, and Otter. I am fairly impressed with all of these so far. All of them are doing a better job than SeaMonkey on this old rig with only 384M of RAM.

    I will keep testing and eventually write up a comparison report on these browsers.

    Seaken64

    #59581
    Member
    seaken64
    Helpful
    Up
    0

    I’ve decided on the Otter Browser as my main/default browser for antiX-16 on this P-III 600Mhz with 384M of RAM. I have been very impressed with it’s performance so far and it’s very small memory foot print.

    For anyone else who mught want to try Otter on antiX we don’t have it in the Package Installer. I was able to install it by downloading the deb file from the MX-15 repos. And I like Otter because of the low memory on this machine. For my machines that have 1G and a P4 I still prefer SeaMonkey (which is in the Package Installer). But I have been using Otter for a few days on this old beast and it has not crashed yet. I am careful to have only three or four tabs open at once. It’s working the best as can be expected given the limited resources of this machine.

    Seaken64

    #59615
    Moderator
    Brian Masinick
    Helpful
    Up
    0

    Nice feedback Seaken64!

    Thanks for the Web browsers review for really old hardware.

    Brian Masinick

Viewing 13 posts - 46 through 58 (of 58 total)
  • You must be logged in to reply to this topic.