strange behaviour in AlsaMixer

Forum Forums Official Releases antiX-21/22 “Grup Yorum” strange behaviour in AlsaMixer

  • This topic has 6 replies, 4 voices, and was last updated Nov 13-11:16 pm by Anonymous.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #70562
    Member
    seriousness

      When I start AlsaMixer after booting, the Pre-Amp slider is not present. When I start playing music with audacious, it’s there but not moveable. Then I pause audacious and continue playing and now it is moveable. Is there something wrong with /etc/asound.conf ?

      #70591
      Forum Admin
      dolphin_oracle

        live usb? persistence? installed system?

        my understanding is that pre-amp appears the first time you send sound, but after that its should be a regular slider.

        #70593
        Member
        seriousness

          I executed
          sudo alsactl store
          and rebooted. Now all AlsaMixer settings are restored, including Pre-Amp.

          Edit: sorry, I forgot to mention that I’m on an installed system.

          • This reply was modified 2 years, 6 months ago by seriousness.
          #70805
          Member
          seriousness

            That solved the issue only half-way. On boot the settings are restored from /var/lib/alsa/asound.state which I manually saved, but the file is not overwritten with the current settings when I turn the computer off. To me it looks like the alsa service is not running.
            I found this command:

            $ sv status alsa 
            fail: alsa: unable to change to service directory: file does not exist

            I am new to runit and do not yet understand, how services are managed.

            #70889
            Member
            seriousness

              Finally, I got it working!

              In /etc/runit-core/ I created a symlink to S17alsa-utils named K17alsa-utils.

              Now AlsaMixer settings are stored on shutdown and restored on system start.

              #70890
              Member
              ModdIt

                Thank you seriousness,good info

                please for the sake of less skilled and new users add a short howto

                #70898
                Anonymous

                  Alsa is not a service it’s a sound driver, also sv is not installed by default with antiX.

                  To check a service with antiX run below.

                  sudo service mpd status
                  mpd is running.

                  Service commands for antiX

                  sudo service --status-all
                  To start service
                  sudo service mpd start
                  To check status of service
                  sudo service mpd status
                  To stop service do
                  sudo service mpd stop
                  To relaod service (i.e. stop + start ) do
                  sudo service mpd reload

                  Set default sound card…

                  Open alsa mixer with sudo press F6 or S select your card then type sudo alsactl store.

                  sudo alsamixer

                  sudo alsactl store

                  and OR

                  Setting the default device
                  Jump to: navigation, search

                  Find your desired card with:

                  cat /proc/asound/cards

                  and then create /etc/asound.conf with following:

                  defaults.pcm.card 1
                  defaults.ctl.card 1

                  Replace “1” with number of your card determined above.

                  My sound system—

                  cat /proc/asound/cards
                  0 [HDMI ]: HDA-Intel – HDA ATI HDMI
                  HDA ATI HDMI at 0xfcda0000 irq 95
                  1 [US2x2 ]: USB-Audio – US-2×2
                  TEAC Corporation US-2×2 at usb-0000:0b:00.3-1, high speed

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.