switch audio from headphones jack to hdmi out

Forum Forums New users New Users and General Questions switch audio from headphones jack to hdmi out

Tagged: 

  • This topic has 14 replies, 3 voices, and was last updated Jan 2-3:11 pm by caprea.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #4430
    Anonymous

      Hello,
      I have a rather old media computer that I just installed antix on. It plays sound out the ‘phone jack. I would like to switch the sound out to the hdmi out, but can’t seem to find the correct place to do the switch.
      Any help please ?
      $ inxi -F
      System: Host: antix1 Kernel: 4.10.5-antix.3-amd64-smp x86_64 bits: 64
      Desktop: IceWM 1.4.2 Distro: antiX-17_x64-full Heather Heyer 24 October 2017
      Machine: Device: desktop Mobo: Acer model: RL100 serial: N/A
      BIOS: American Megatrends v: P01-A1 date: 12/27/2010
      CPU: Dual core AMD Athlon II Neo K325 (-MCP-) cache: 2048 KB
      clock speeds: max: 1300 MHz 1: 1100 MHz 2: 1300 MHz
      Graphics: Card: NVIDIA GT218 [ION]
      Display Server: X.Org 1.19.2
      drivers: nouveau (unloaded: modesetting,fbdev,vesa)
      Resolution: 1920×1080@60.00hz
      OpenGL: renderer: Gallium 0.4 on NVA8 version: 3.3 Mesa 13.0.6
      Audio: Card-1 NVIDIA High Def. Audio Controller driver: snd_hda_intel
      Card-2 NVIDIA MCP61 High Def. Audio driver: snd_hda_intel
      Sound: Advanced Linux Sound Architecture v: k4.10.5-antix.3-amd64-smp
      Network: Card-1: NVIDIA MCP61 Ethernet driver: forcedeth
      IF: eth0 state: up speed: 1000 Mbps duplex: full mac: f8:0f:41:1a:55:03
      Card-2: Ralink RT3090 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
      IF: wlan0 state: down mac: 68:a3:c4:50:95:88
      Drives: HDD Total Size: 750.2GB (0.7% used)
      ID-1: /dev/sda model: WDC_WD7500BPVT size: 750.2GB
      Partition: ID-1: / size: 685G used: 2.9G (1%) fs: ext4 dev: /dev/sda1
      ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
      Sensors: System Temperatures: cpu: 75.1C mobo: N/A gpu: 76.0
      Fan Speeds (in rpm): cpu: N/A
      Info: Processes: 160 Uptime: 44 min Memory: 781.0/3954.1MB
      Client: Shell (bash) inxi: 2.3.40

      #4433
      Moderator
      caprea

        Try right-click on the volume-icon in the taskbar,
        go to preferences.
        There you can choose the soundcard and also the channels.

        #4439
        Anonymous

          I tried right-clicking – device selection is fixed at ‘default’

          #4470
          Anonymous

            device selection is fixed at ‘default’

            troubleshooting, this suggests a faulty cable or… currently, no HDMI output device is attached?

            #4472
            Moderator
            caprea

              aplay -l
              would be helpful

              #4489
              Anonymous

                here is aplay output:
                $ aplay -l
                **** List of PLAYBACK Hardware Devices ****
                card 0: NVidia_1 [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
                Subdevices: 0/1
                Subdevice #0: subdevice #0
                card 0: NVidia_1 [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
                Subdevices: 1/1
                Subdevice #0: subdevice #0
                card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
                Subdevices: 1/1
                Subdevice #0: subdevice #0
                card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
                Subdevices: 1/1
                Subdevice #0: subdevice #0
                card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
                Subdevices: 1/1
                Subdevice #0: subdevice #0
                card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
                Subdevices: 1/1
                Subdevice #0: subdevice #0

                #4496
                Moderator
                caprea

                  So, if you open control-center, under hardware choosing the soundcard, is there another option than default?

                  Could you please post the output of
                  aplay -D plughw:1,8 /usr/share/sounds/alsa/Front_Center.wav
                  aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav
                  aplay -D plughw:1,7 /usr/share/sounds/alsa/Front_Center.wav
                  aplay -D plughw:1,9 /usr/share/sounds/alsa/Front_Center.wav

                  Do you hear sound by any of these options ? Then we could try to write a etc/asound.conf .
                  If you don’t hear sound at all, then I’m thinking about, maybe the nouvea-driver for the nvidiacard doesnt support HDMI-audio for this card.

                  #4498
                  Moderator
                  caprea

                    http://nouveau.freedesktop.org/wiki/FeatureMatrix/
                    scrolling down under Notes point 10 is said nouveau does support HDMI-audio for your card.

                    #4527
                    Anonymous

                      here is my output,
                      sure seems like its playing, but no sound.

                      cheesey@antix1:~
                      $ aplay -D plughw:1,8 /usr/share/sounds/alsa/Front_Center.wav
                      Playing WAVE ‘/usr/share/sounds/alsa/Front_Center.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
                      cheesey@antix1:~
                      $ aplay -D plughw:1,8 /usr/share/sounds/alsa/Front_Center.wav
                      Playing WAVE ‘/usr/share/sounds/alsa/Front_Center.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
                      cheesey@antix1:~
                      $ aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav
                      Playing WAVE ‘/usr/share/sounds/alsa/Front_Center.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
                      cheesey@antix1:~
                      $ aplay -D plughw:1,7 /usr/share/sounds/alsa/Front_Center.wav
                      Playing WAVE ‘/usr/share/sounds/alsa/Front_Center.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
                      cheesey@antix1:~
                      $ aplay -D plughw:1,9 /usr/share/sounds/alsa/Front_Center.wav
                      Playing WAVE ‘/usr/share/sounds/alsa/Front_Center.wav’ : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
                      cheesey@antix1:~
                      $

                      #4639
                      Moderator
                      caprea

                        If you don’t hear sound at all, it doesn’t make sens to play with the etc/asound.conf
                        Normally if the output of aplay …. looks like yours, you should look in the mixersettings.
                        You say theres only the option default for the card, this is odd.

                        In alsamixer, if you use the F6 key, can you choose another card, like HDA NVidia ?
                        What does
                        cat /proc/asound/cards
                        say?

                        #4644
                        Anonymous

                          $ cat /proc/asound/cards
                          0 [NVidia_1 ]: HDA-Intel – HDA NVidia
                          HDA NVidia at 0xfaef8000 irq 22
                          1 [NVidia ]: HDA-Intel – HDA NVidia
                          HDA NVidia at 0xfaf7c000 irq 19
                          cheesey@antix1:~
                          I have been muddling around with the alsamixer, I can turn the headphone jack off and on but can’t get the hdmi port to come on, My up/down arrows don’t seem to raise the volume.

                          #4645
                          Moderator
                          caprea

                            Just a suggestion, you could try vlc player.
                            In vlc you can choose under audio the output.It’s worth a try.

                            #4646
                            Anonymous

                              installed vlc got this:
                              $ vlc
                              VLC media player 2.2.7 Umbrella (revision 2.2.7-0-g6e32381286)
                              [000055f843fcdea8] pulse audio output error: PulseAudio server connection failure: Connection refused
                              [000055f843ef5118] core libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
                              qt5ct: using qt5ct plugin
                              qt5ct: D-Bus global menu: no
                              qt5ct: D-Bus system tray: no
                              inotify_add_watch(“/home/cheesey/.config/qt5ct/”) failed: “No such file or directory”
                              QXcbConnection: XCB error: 3 (BadWindow), sequence: 1012, resource id: 12591610, major code: 40 (TranslateCoords), minor code: 0

                              #4647
                              Anonymous

                                UPDATE UPDATE UPDATE !!
                                Got sound with vlc
                                yay
                                Caprea thanks for your help

                                #4677
                                Moderator
                                caprea

                                  Cool ! In firefox there’s an addon called “Open in VLC media player”
                                  After installation, when you for the first time click on the icon in the browser (only visible if you visit a youtube-clip or something)a side will open to download a linux-zip.
                                  Afterwards installing this too, you can look most videos in your browser with vlc.

                                  Radio with vlc is nice with streamtuner2.

                                  • This reply was modified 6 years, 4 months ago by caprea.
                                Viewing 15 posts - 1 through 15 (of 15 total)
                                • You must be logged in to reply to this topic.