synaptic: is it installable in sid?

Forum Forums News Sid Upgraders synaptic: is it installable in sid?

  • This topic has 37 replies, 7 voices, and was last updated Mar 10-2:54 am by anticapitalista.
Viewing 15 posts - 1 through 15 (of 36 total)
  • Author
    Posts
  • #30676
    Member
    fungalnetfungalnet

    I tried to install it and it wants to bring the trash and remove most of antiX pkgs

    I haven’t used it in a while so I can’t remember what the deal was and removed it (maybe elogind which I didn’t want installed) but it is not elogind that is asking it is the whole crappy-trashy-*****d

    #30680
    AvatarAnonymous

    Uuuum, honestly, I’ve never had such a wonderful idea…

    #30681
    Member
    Avatarskidoo

    Even if you get past the immediate hurdle, the Fist of Gnome will be along shortly to enforce
    Debian’s removal of the remaining survivors (libgdk-pixbuf2.0-0 et al) of the gtk2 stack.

    IMO, anyone who already has synaptic v0.84.4 or v0.84.6 installed can (should) just pin the
    existing version. The 0.84.8 version (currently in debian sid and buster repos)
    and the 0.46.6 version, neither of them provides functional improvements compared to 0.84.6
    https://metadata.ftp-master.debian.org/changelogs//main/s/synaptic/synaptic_0.84.8_changelog

    #30726
    Member
    fungalnetfungalnet

    I tried to use 84.6 but its dependencies bring havoc as well, so I give up on this luxury. I only ever used it for scanning software, their sizes, their dependency structure, it was quick and easy to visualize. If I could get shell completion to ever work the way I am used to on debian I wouldn’t need it. apt search is a joke and its output is even worse.

    #30748
    Member
    Avatarskidoo

    First of all…
    apt search is, demonstrably, not “a joke” ~~ it is just often usually not the best tool for an end-user to choose when attempting to perform the immediate task at hand. It is a tiny, feature-lean, utility which is frequently utilized (called) from within scripted operations.
    apropos apt
    apropos dpkg
    ^— following your extended periods of immersion in obarun et al, each time you revisit debianland it will be helpful for you to review the available tools.

    Second, FYI, wondering “What new breakage has the Debian Guh-nome Team wrought THIS week?“, I tested what you have described… but I found no breakage.

    pristine antiX19Full iso, in virtualbox:
    apt update && apt dist-upgrade
    then edited the source.list.d/*.list files, removing all references to repos other than: antix “for use with sid” and debian “unstable”

    then apt update && apt upgrade
    After fussing with some “btrfs file is owned by blahblah” error, I purged the btrfs-whatever package
    then apt dist-upgrade apt upgrade
    and steppy-stepped through a few minor wrinkles (but none related to synaptic).
    Above, I scratched out “dist-upgrade” b/c I apparently hadn’t done that yet ~~ at the time I grabbed the screenshot, sshfs package still hadn’t been upgraded.

    .

    #30749
    Member
    Avatarskidoo

    A point of clarification:

    “synaptic: is it installable in sid?” —} yes

    but, because several packages containing pieces of the gtk2 stack have been purged from,
    banished from the rolling debian/testing (will become “Debian 11 Bullseye”)
    … synaptic v0.48.8 will NOT be installable on systems tracking the debian “testing” repository.

    #30771
    Member
    fungalnetfungalnet

    ^— following your extended periods of immersion in obarun et al, each time you revisit debianland it will be helpful for you to review the available tools.

    I didn’t know I had to punch a card at the forum or somewhere else to maintain my antix-membership …
    My original installation for many years stems back to wheezy days, and has been in antix-sid for the past 2 years. I was talking now about installing synaptic on this new installation I did 3 days ago, which is also sid and updated. It just reminded me that for some reason long ago I got rid of synaptic on my original installation, I thought it was due to elogind and policyckit. I now see that it is not possible, not on one or two hits of trying it. I Tried to install this older version mentioned above and its dependencies make it next to impossible to install as well. So I don’t know how a pinned installation would help without pinning a whole lot of other stuff that could probably affect 5 more wholes of other stuff.

    The output of apt search is not very helpful in using in scripts to screen out unneeded information from it. So either you know in advance and be very specific or you get tons of garbage that you can hardly scan through. It is an antiquity in disguise. I think that is very subjective and I retain my right to label it as such.

    I don’t know what the rest of it means or why you have taken the time to put it out here, is it an answer?

    If you are trying to be provocative because for whatever reason it serves you better that I vanish, I am not interested, continue on your own.

    To get back to the topic, ON SID SYNAPTIC IS NOT INSTALLABLE AS FAR AS I CAN TELL … is there more to the story?

    • This reply was modified 5 months, 1 week ago by fungalnet.
    #30791
    Member
    Avatarskidoo

    {spamfilter?}

    #30792
    Member
    Avatarskidoo

    { double post removed }

    • This reply was modified 5 months, 1 week ago by anticapitalista.
    • This reply was modified 5 months, 1 week ago by skidoo.
    #30793
    Member
    Avatarskidoo

    I’m not being provocative in this post, just calling a spade a spade.

    Your topic-starting post represents an unfounded claim (due to PEBKAC?) that “something is awry”.
    I demonstrated that synaptic currently is, in fact, installable in sid (and explained the steps which led to success).

    The “more to the story” aspect is that your topic-starting post here continues a trend of bemoaning inexplicable, often non-reproducable, problems… then backpedalling and fingerpointing. Sure, it’s sid (unstable) ~~ possibly yesterday when you tried, or even an hour ago, it may not have been installable at that time. You (we, you and I, and future readers) might oughta shrug it off as just another speedbump along the road of tracking sid.

    Instead, you are bent on (ALLCAPS) insisting that an ongoing “uninstallable” problem exists. Quoting a snippet of my reply in order to lambast my choice of wording (or “tone”, or “attitude”) does not bring you closer to solving your “uninstallable” puzzle. Claiming that a (a wrong tool for the job) given tool is an “antiquity” does not bring you closer to solving your “uninstallable” puzzle.

    In another recent exchange, you mentioned “exclusively never provided a single hint for me”.
    From my perspective, that remark is patently untrue and (lather, rinse, repeat?) here, even after I have outright explained the steps which led to success… you don’t understand? Yet, you would insist (have previously proclaimed) that you are a “careful tester” and “been doing this for years” and, and WHAT ?

    I sincerely wish for your success in wrangling sid. I recognize that we each differ, in terms of our relative adeptness across various skillsets. Because I realize that my package management success (adeptness, I would not claim “expertise”) necessitates continually “diving into the docs”, I cannot fathom (nor excuse, nor empathisze with) you apparent unwillingness, across years, to refer to the available manpages and learn-n-understand the plentiful set of provided tools.

    #30845
    Member
    fungalnetfungalnet

    No, you are saying that if I start over again and NOT dist-upgrade but only upgrade it “may” be installable, some of the transition seems fuzzy.
    By just upgrading you are retaining the structure of buster (antix-stable-19) and just upgrading software. Real sid only comes when you dist-upgrade. So the condition you present as synaptic being installable is false, it is not really sid. If you were to upgrade to sid fully with dist-upgrade the synaptic is not really installable.
    At least this is what I understood. If I have missed something please explain.

    #30851
    Member
    Avatarskidoo

    If you were to upgrade to sid fully with dist-upgrade the synaptic is not really installable.

    IIRC, you and I have both expressed a mistrust toward dist-upgrade, so I get where you’re coming from…
    …but I also do not want to “dabble with IFs”. To be clear, yes, my test did include performing dist-upgrade.

    Here’s a set of steps that you, or anyone else, can use to quickly verify that synaptic is (currently, don’t blink eh?) installable.

    pristine antiX-17.4.1_x64-full.iso, in virtualbox:

    
    sudo rm /etc/apt/sources.list.d/*.list
    sudo  bash -c 'echo "deb http://ftp.us.debian.org/debian/ unstable main contrib non-free" > /etc/apt/sources.list.d/debian.list'
    sudo  bash -c 'echo "deb http://la.mxrepo.com/antix/sid sid main nonfree" > /etc/apt/sources.list.d/antix.list'
    echo "en_US.UTF-8 UTF-8" | sudo tee /etc/locale.gen
    LANG=C sudo dpkg-reconfigure --frontend=noninteractive locales
    LANG=C sudo update-locale LANG=en_US.UTF-8
    ### v-- timesaver (rm bloaty pkgs which are inconsequential to the test)
    sudo apt-mark hold firefox-esr 
    sudo apt purge libreoffice-base-core libreoffice-common libreoffice-core
    sudo apt autoremove
    sudo apt purge btrfs-progs
    sudo apt update
    sudo apt upgrade
    sudo apt autoremove
    sudo rm /var/cache/apt/archives/*.deb # CLEANUP
    sudo apt dist-upgrade
    ^---v (per the onscreen instructions, to fix )
    
    sudo apt --fix-broken install
    ### The following additional packages will be installed:
    ########## elogind libelogind0
    ###### The following packages will be upgraded:
    ########## elogind libelogind0
    ^---v
    
    sudo apt dist-upgrade 
    The following packages will be removed: libpolkit-backend-1-0
    Proceed [Y/n] y
    ^---v
    
    sudo apt autoremove
    sudo rm /var/cache/apt/archives/*.deb # CLEANUP (included here due to habit)
    
    sudo synaptic

    .

    #30852
    Member
    KooKoo

    Their is this in the sid change log for synaptic 0.84.8

    synaptic (0.84.8) unstable; urgency=medium

    * debian/control:
    – update recommends of libgtk2-perl to libgtk3-perl
    (closes: #891877)

    — Michael Vogt <mvo@debian.org> Tue, 15 Oct 2019 06:58:08 +0200

    (From my Happy runit buster world KoO)

    MX- AHS 5.5.0-1-amd64 (i3) ROG STRIX B450-I , AMD Ryzen 5 3600 , 32gb.
    2 Laps T430 17.2 X220 17.4

    #30854
    Member
    Avatarskidoo

    pointless detail, mentioning it mainly as a note-to-self:
    Per the screenshot from today’s retest, yes the “sshfs” package remained status:upgradeable even after I had performed the dist-upgrade operation.

    re: “update recommends of libgtk2-perl to libgtk3-perl”

    Yes, I monitor the changelog, that’s why I had its bookmarked URL onhand when I drafted post #30681
    (Anticipating future need, I forked synaptic 0.84.2 and changed its name to ‘wildbob’.
    As a rainy days project, I’ve been occasionally hacking at customizing its UI and its featureset.)

    #30856
    Member
    fungalnetfungalnet

    Am I missing something, I don’t see synaptic getting installed, I see synaptic being already installed.
    So what you are saying is that you can install synaptic in 19/buster and then upgrade to sid? If so, this does not make synaptic installable while you are on sid. Reversing to stable, installing, then going back to sid is an exercise in futility.

Viewing 15 posts - 1 through 15 (of 36 total)
  • You must be logged in to reply to this topic.