synclient: command not found

Forum Forums New users New Users and General Questions synclient: command not found

  • This topic has 59 replies, 10 voices, and was last updated Mar 20-10:05 pm by Brian Masinick.
Viewing 15 posts - 16 through 30 (of 60 total)
  • Author
    Posts
  • #134923
    Moderator
    Brian Masinick

      sudo apt install –reinstall xinput

      In this dialog below, dating all the way back to Debian 9, some people were STILL attempting to use the OLD xserver-xorg-input-synaptic package and having problems. As I also attempted to explain, apparently NOT clearly enough, REMOVE xserver-xorg-input-synaptic, then INSTALL xinput (as shown above).

      https://unix.stackexchange.com/questions/388963/how-can-i-enable-disable-the-synaptics-touchpad-in-debian-9-with-libinput

      --
      Brian Masinick

      #134932
      Member
      Robin

        Works after installing the xinput package without reboot, right after installing. Many thanks.

        $ xinput -list
        ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
        ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
        ⎜   ↳ Mouse Consumer Control           	id=12	[slave  pointer  (2)]
        ⎜   ↳ Mouse                            	id=10	[slave  pointer  (2)]
        ⎜   ↳ SynPS/2 Synaptics TouchPad              	id=14	[slave  pointer  (2)]
        ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
            ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
            ↳ Power Button                            	id=6	[slave  keyboard (3)]
            ↳ Video Bus                               	id=8	[slave  keyboard (3)]
            ↳ Power Button                            	id=9	[slave  keyboard (3)]
            ↳ Video Bus                               	id=7	[slave  keyboard (3)]
            ↳ Mouse Consumer Control           	id=15	[slave  keyboard (3)]
            ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
            ↳ Mouse Keyboard                   	id=11	[slave  keyboard (3)]
        demo@antix1:~
        $ xinput -disable 14

        Touchpad is disabled now finally. Great! Can type again without contortion 🙂

        Will check out your script Brian @Masinick, and also retest, with this xinput package now being installed, the one @PPC has supplied over in the other thread.

        —————
        Edit:
        P.S. And yes, I have purged nonfunctional xserver-xorg-input-synaptics package beforehand again.

        Windows is like a submarine. Open a window and serious problems will start.

        #134940
        Moderator
        Brian Masinick

          I’m going to go back and update (and possibly remove) a few of my posts, which were quite obviously (now) unclear.

          Instead, at most a one line explanation of what to remove, what to add, and the actual commands to do it would be much better.

          So here is the shorter, clearer explanation:

          The package xserver-xorg-input-synaptics and the synaptics feature has been replaced by xinput; this happened a few years ago, but the old packages will soon be purged from the system.

          To properly fix the touchpad, perform these commands:

          sudo apt update; sudo apt purge xserver-xorg-input-synaptics, sudo apt install xinput

          --
          Brian Masinick

          #134956
          Member
          Robin

            Mouse configuration still doesn’t work. I need to disable acceleration and change mouse sensitivity.

            @izby

            After sudo apt update; sudo apt purge xserver-xorg-input-synaptics, sudo apt install xinput , see Brians posting above
            Try:

            $ xinput -list
            ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
            ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
            ⎜   ↳ Mouse Consumer Control           	id=12	[slave  pointer  (2)]
            ⎜   ↳ Mouse                            	id=10	[slave  pointer  (2)]
            ⎜   ↳ SynPS/2 Synaptics TouchPad              	id=14	[slave  pointer  (2)]
            ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
                ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
                ↳ Power Button                            	id=6	[slave  keyboard (3)]
                ↳ Video Bus                               	id=8	[slave  keyboard (3)]
                ↳ Power Button                            	id=9	[slave  keyboard (3)]
                ↳ Video Bus                               	id=7	[slave  keyboard (3)]
                ↳ Mouse Consumer Control           	id=15	[slave  keyboard (3)]
                ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
                ↳ Mouse Keyboard                   	id=11	[slave  keyboard (3)]

            Look up your touchpad in that listing you get on your device from the command. Then, for disabling (replace the 14 by your findings)
            $ xinput -disable 14

            This will disable your touchpad immediately.

            Now, the acceleration and sensivity.

            Try:

            $ xinput --get-feedbacks 10
            1 feedback class
            PtrFeedbackClass id=0
            	accelNum is 2
            	accelDenom is 1
            	threshold is 4

            (again, replace the number by what you have looked up in the output table of the first command for your mouse device) This will show you current values:

            Then use the following syntax to change them:
            xinput --set-ptr-feedback device threshold num denom

            e.g.
            xinput --set-ptr-feedback 10 30 40 1

            Windows is like a submarine. Open a window and serious problems will start.

            #135006
            Moderator
            Brian Masinick
              xinput list
              ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
              ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
              ⎜   ↳ HP HP USB WHEEL MOUSE                   	id=8	[slave  pointer  (2)]
              ⎜   ↳ SYNA32AC:00 06CB:CD50 Mouse             	id=9	[slave  pointer  (2)]
              ⎜   ↳ SYNA32AC:00 06CB:CD50 Touchpad          	id=10	[slave  pointer  (2)]
              ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
                  ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
                  ↳ Video Bus                               	id=6	[slave  keyboard (3)]
                  ↳ Power Button                            	id=7	[slave  keyboard (3)]
                  ↳ AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]
                  ↳ HP WMI hotkeys                          	id=12	[slave  keyboard (3)]
                  ↳ Wireless hotkeys                        	id=13	[slave  keyboard (3)]

              so for me, diabling the touchpad is:
              xinput -disable 10

              --
              Brian Masinick

              #135008
              Moderator
              Brian Masinick

                Oh yes, a few of you rarely use the touchpad; that is the case for me too, which is why I created an alias:

                alias t
                alias t='$HOME/bin/Touchpad.bash'

                so I type t whenever the touchpad interferes with my typing or other activity.
                I have to remember to toggle it AGAIN for the few cases when I don’t have
                the USB mouse connected, THEN I enable the touchpad with another t!

                --
                Brian Masinick

                #135009
                Moderator
                Brian Masinick

                  $HOME/bin/Touchpad.bash:

                  #!/bin/bash
                  # Touchpad.bash
                  read TPdevice <<< $( xinput | sed -nre '/TouchPad|Touchpad/s/.*id=([0-9]*).*/\1/p' )
                  state=$( xinput list-props "$TPdevice" | grep "Device Enabled" | grep -o "[01]$" )
                  if [ "$state" -eq '1' ];then
                      xinput --disable "$TPdevice" && notify-send -i emblem-nowrite "Touchpad" "Disabled" 2> /dev/null
                  else
                      xinput --enable "$TPdevice" && notify-send -i emblem-nowrite "Touchpad" "Enabled" 2> /dev/null
                  fi

                  --
                  Brian Masinick

                  #135012
                  Moderator
                  Brian Masinick

                    I fooled around with this a bit from the command line;
                    the thing is, the alias doesn’t retain the $state variable,
                    so I had to copy and paste a few lines to “see” the
                    variables at work; indeed they DO work!

                    Look at this, including my “boo boo”!

                    read TPdevice <<< $( xinput | sed -nre '/TouchPad|Touchpad/s/.*id=([0-9]*).*/\1/p' )
                    [antix23]/home/masinick: > state=$( xinput list-props "$TPdevice" | grep "Device Enabled"
                    > )
                    [antix23]/home/masinick: > echo $state
                    Device Enabled (167): 0
                    [antix23]/home/masinick: > t
                    [antix23]/home/masinick: > echo $state
                    Device Enabled (167): 0
                    [antix23]/home/masinick: > read TPdevice <<< $( xinput | sed -nre '/TouchPad|Touchpad/s/.*id=([0-9]*).*/\1/p' )
                    [antix23]/home/masinick: > state=$( xinput list-props "$TPdevice" | grep "Device Enabled"
                    > )'
                    bash: syntax error near unexpected token 

                    )’

                    [antix23]/home/masinick: > state=$( xinput list-props "$TPdevice" | grep "Device Enabled")
                    [antix23]/home/masinick: > echo $state
                    Device Enabled (167): 1
                    • This reply was modified 1 month, 1 week ago by Brian Masinick.

                    --
                    Brian Masinick

                    #135076
                    Member
                    izby

                      Doesn’t work.
                      Touchpad is ON again after reboot.

                      #135082
                      Member
                      izby

                        My way worked, your ones do not.
                        How to remove xinput and install xserver-xorg-input-synaptics again?

                        #135089
                        Member
                        PPC

                          @izby – the provided script works. What it does not do, that the GUI from Control Centre (ds-mouse) used to do is to save the change, so antiX always starts with that configuration (i.e.- any change only does for the present session).
                          The way to always have your touchpad disabled would be adding something like this to your antiX startup file (you can do it from Control Centre > Session > click the green rocket icon):
                          read TPdevice <<< $( xinput | sed -nre '/TouchPad|Touchpad/s/.*id=([0-9]*).*/\1/p' ) && xinput --disable "$TPdevice"

                          I don’t advise using synaptics in antiX 23+

                          Also: sooner or later, ds-mouse will be fixed to work with xinput. When that happens, if you insist in using synaptics, ds-mouse won’t work for you…

                          P.

                          • This reply was modified 1 month, 1 week ago by PPC.
                          #135097
                          Forum Admin
                          Dave

                            A couple of questions before looking to deeply…

                            There always seems to be more pointer devices than physically attached to the computer. Is there a way to cross reference the xinput list with another system component (/sys/ for example) to get only the actual hardware devices?

                            Second; do the id values change after a reboot or if unplugged and replugged (for example adding and removing usb mice)?

                            Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                            #135098
                            Member
                            PPC

                              @Dave – I created a thread to discuss reworking the mouse gui (ds-mouse), over at https://www.antixforum.com/forums/topic/reimplementing-a-gui-mouse-configuration-tool-in-antix-23/#post-135084

                              My work-around, for now is just checking for mouse and touchpad input devices. This seems to work:

                              read TPdevice <<< $( xinput | sed -nre '/TouchPad|Touchpad/s/.*id=([0-9]*).*/\1/p' )
                              read Mousedevice <<< $(xinput | sed -nre '/Mouse|Mouse/s/.*id=([0-9]*).*/\1/p')
                              echo "Touchpad is device: $TPdevice (if nothing is indicated, it's not detected)"
                              echo "Mouse is device: $Mousedevice (if nothing is indicated, it's not detected)"
                              • This reply was modified 1 month, 1 week ago by PPC.
                              #135105
                              Member
                              Robin

                                @Dave Please check the great research and testing work Brian @Masinick has done already yesterday, in several threads (e.g. https://www.antixforum.com/forums/topic/antix-23-1-released/page/9/#post-134977 and followup postings. There you’ll get some insights into the new xinput method and how to look up or set the several devices and their properties.

                                Not sure whether the IDs can change. But I guess, yes. Better look them up always before sending something to them.

                                Windows is like a submarine. Open a window and serious problems will start.

                                #135115
                                Member
                                izby

                                  For me it doesn’t matter. I just want ds-mouse to work.
                                  It worked on 23, but it does not work on 23.1, and the team knows why. AntiX 23 updated to the last version works fine on my netbook, but fresh AntiX 23.1 on my laptop works awful. Just explain me how to make ds-mouse works. You changed something and we need to return it.

                                Viewing 15 posts - 16 through 30 (of 60 total)
                                • You must be logged in to reply to this topic.