The findshares doesn’t work after upgrading connectshares-antix

Forum Forums Official Releases antiX-19 “Marielle Franco, Hannie Schaft, Manolis Glezos, Grup Yorum” The findshares doesn’t work after upgrading connectshares-antix

  • This topic has 6 replies, 4 voices, and was last updated Jan 9-8:51 pm by AR.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #49305
    Member
    AR

    The findshares doesn’t work after upgrading connectshares-antix from 0.3.1 to 0.3.2.

    I rarely use findshares, but now I had to, and I found that it doesn’t work:

    $ findshares
    bash: /usr/local/bin/findshares: No such file or directory

    But findshares binary file exist in the proper place with proper attibutes:

    $ ls -l /usr/local/bin/findshares
    -rwxr-xr-x 1 root root 16164 Dec 28 15:44 /usr/local/bin/findshares

    I tried apt-get install –reinstall connectshares-antix (– here is double -), I tried to start findshares via sudo, but still have the same result. Also, point 1 of Connectshares Configuration – “Find shares…” doesn’t work too (empty window). Connectshares itself works fine, the problem is only with findshares. My system is antiX 19.3, upgraded from 19.2.

    What’s wrong?

    #49312
    Forum Admin
    dolphin_oracle
    Helpful
    Up
    0
    :D

    check your path and make sure /usr/local/bin is in it.

    #49316
    Member
    skidoo
    Helpful
    Up
    0
    :D

    tested, virtualbox antiX19 Full, 64bit:
    /usr/local/bin/findshares is present
    /usr/local/bin is listed in $PATH
    will not run ……. same as has reported.

    stat /usr/local/bin/findshares
    indicates it is a 32-bit elf

    FWIW, when I copied into place (from antix17 host system) an older 64-bit findshare executable
    that older version works properly

    #49410
    Member
    AR
    Helpful
    Up
    0
    :D

    @dolphin_oracle, /usr/local/bin is present in the $PATH.

    @skidoo, thank you for testing this problem!

    Now we awaiting corrections in the connectshares-antix package. Maybe return to an older version of findshares for a while?

    PS: I could not find sources of findshares 1.08 too. I have no account at TCL forum.

    #49413
    Forum Admin
    anticapitalista
    Helpful
    Up
    0
    :D

    Can you try the connectshares deb (64 bit) from here:

    https://download.tuxfamily.org/antix/Testing/

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #49415
    Member
    AR
    Helpful
    Up
    0
    :D

    Thank you! I’ll try tomorrow, then report here.

    #49488
    Member
    AR
    Helpful
    Up
    0
    :D

    OK! Connectshares-antix 0.3.3 with findshares 1.0.6 from testing works fine. Thank you one more time, @anticapitalista!

    Now I ask moderators to mark this thread as SOLVED.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.