[solved] The recomended kernel 4.9.0-279.antix will not boot on a live usb

Forum Forums Official Releases antiX-17 “Heather Heyer, Helen Keller” [solved] The recomended kernel 4.9.0-279.antix will not boot on a live usb

Tagged: 

  • This topic has 4 replies, 3 voices, and was last updated Aug 23-12:20 pm by smitty1954.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #65335
    Member
    smitty1954

    When remastered and installed, the recommended kernel for Antix 17.4.1 failed to boot from uefi. In the boot window the fonts ran over the edges of the antix installation screen and froze when they went over the bottom of the screen. It seems to fail on all other options available. Any way to roll this back?

    • This topic was modified 1 month ago by christophe. Reason: original poster said it is fixed
    #65336
    Member
    Xecure
    Helpful
    Up
    0

    http://download.tuxfamily.org/antix/docs-antiX-19/FAQ/remaster.html
    Live Remastering

    The primary purpose of live remastering is to make it as safe, easy, and convenient as possible for users to make their own customized version of antiX. The idea is that you use a LiveUSB or a LiveHD (a frugal install to a hard drive partition) as the development and testing environment. Add or subtract packages and then when you are ready to remaster, use a simple GUI remaster program to do the remaster and then reboot. If something goes horribly wrong, simply reboot again with the rollback option and you will boot into the previous environment.

    Using the rollback boot code will restore the previous remaster (if it wasn’t removed), and assign this remaster as “bad”.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #65371
    Member
    smitty1954
    Helpful
    Up
    0

    In some menus that boot I get the following; Set font to Uni2-TerminusBold28x14 along with no way out of the menu unless I pull the plug. I also do not see a rollback option or code.

    #65390
    Moderator
    christophe
    Helpful
    Up
    0

    Hi, smitty1954.

    I tried to replicate what you did, to try to solve this. (I recently also ran into a similar situation.)

    The remaster ‘rollback’ boot code is for a bad remaster. Not for the kernel update, it seems in my testing. (Please, anyone else with other information, please chime in.)

    So, a normal sequence of events should go like this:

    1. Install the new kernel to your live antiX system.
    2. Remaster.
    3. Reboot, to use the newly remastered system.
    4. Run live-kernel-updater

    If you did this in those steps, you would have found out if your remaster was bad before you were able to run live-kernel-updater.
    If that were the case, you would manually add ‘rollback’ to the boot command. On the live usb grub menu, there is the option to “press “e” to edit,” or something similar. Make it look something like this:
    linux /antiX/vmlinuz quiet splash=v disable=lx rollback

    NOW. live-kernel-updater undo:

    The only way I know how to do that is to manually change the kernel & initrd back from vmlinuz.kold to vmlinuz, and initrd.gz.kold to initrd.gz. To do this, I would boot up another OS, insert and navigate to the live-usb, and in the top-level directories you have antiX, boot, EFI (and one or two others). These files are in the ‘antiX’ directory. When I did this just now, I renamed the vmlinuz & initrd,gz that were already there (the ‘new’ kernels that aren’t working on your computer), to vmlinuz.xxx & initrd.gz.xxx just to keep them. Then rename those two files – vmlinuz.kold & initrd.gz.kold (which are your ‘old’ working versions) – back to vmlinuz & initrd.gz.

    That should fix it. Just a few minutes ago, that’s all it took, and I rebooted into my old kernel.

    Hope that helps. 🙂

    • This reply was modified 1 month ago by christophe.
    • This reply was modified 1 month ago by christophe.
    • This reply was modified 1 month ago by christophe.

    confirmed antiX frugaler, since 2018

    #65472
    Member
    smitty1954
    Helpful
    Up
    0

    The kernel was the problem and the renaming of the files as instructed resolved the inability to boot the system. The renaming of the files has to be done in the root file manager so double down on spelling!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.