[solved] Thinkpad T43 locks up upon wake from suspend

Forum Forums New users New Users and General Questions [solved] Thinkpad T43 locks up upon wake from suspend

  • This topic has 8 replies, 4 voices, and was last updated Jun 7-5:50 am by Anonymous.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #61042
    Member
    RandyBobandy

    Hey all — last topic was marked as spam (not sure why?) so I am posting this a second time. Can’t exactly remember what I wrote in my last post so I am going from memory:

    Just installed the latest version of antiX on my Thinkpad T43 and everything works great beside the ability to wake from suspend. Whenever I suspend by either closing the lid or typing “sudo pm-suspend” into the terminal and attempt to wake up from that, I am greeted with whatever was on my screen before the suspend (i.e. DE, active windows, mouse cursor) but the system has completely locked up. Keyboard and mouse are completely unresponsive (keyboard lights not working either), and I cannot switch between terminals so my only choice is to force-shutdown my laptop by holding down the power-button and boot back into antiX.

    I have attached my pm-suspend.log and inxi -zv8 output to this post. Any help would be much appreciated — thanks in advance.

    • This topic was modified 1 year, 6 months ago by RandyBobandy. Reason: pm-suspend.log change to .txt so I can upload it
    • This topic was modified 1 year, 6 months ago by christophe. Reason: marked solved at original poster's request
    #61065
    Member
    Xecure
    Helpful
    Up
    0
    ::

    It seems that the pm-suspend log only contains information related to the suspension process, but not to the wake from sleep process.

    First, try suspending and waking, and then see if you can move to a Terminal tty
    Control+Alt+F1
    if you are able to reach the terminal, try checking for errors in dmesg. Log in as your user and run
    sudo dmesg | grep -i err > dmesg-error.txt
    So you can share check it or share with us.

    If you can’t, you would need to look at the system log, at the approximate time you woke the computer from sleep, to see if you can find any ERROR messages.

    For now, you could try editing the /etc/elogind/logind.conf file to disable the lid-switch to see if suspend+wake works when the lid switch is being ignored. If there is no difference, then we can eliminate this possibility and explore other options.
    Uncomment #HandleLidSwitch and change it to ignore:
    HandleLidSwitch=ignore
    Save and reboot before testing.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #61094
    Member
    RandyBobandy
    Helpful
    Up
    0
    ::

    Ah ok then I see; sadly I was unable to reach the terminal, and as such was unable to obtain the dmesg error log.

    Setting HandleLidSwitch to ignore doesn’t seem to affect anything, besides the fact that now my laptop does not suspend when I close the lid.

    Looking through my syslog file I can’t seem to find any errors there either — in fact there seem to be no messages recorded at all after I wake my system back up. I’ve decided to upload it too just in case; June 6 12:55 is the last time I tried waking up my computer from suspend if you need any pointers.

    Also not sure how much this matters, but suspend seems to work fine in the latest BionicPup32 build of Puppy Linux; just thought I’d put that out there. Thanks again for your help.

    EDIT: The version of antiX I installed was the “full” version, forgot to mention that.

    • This reply was modified 1 year, 6 months ago by RandyBobandy. Reason: more information
    Attachments:
    #61108
    Member
    Xecure
    Helpful
    Up
    0
    ::

    You are right. I also cannot see anything suspicious in the syslog log.
    Please, share with us the xorg log and the auth.log and kern.log. Instead of uploading, here on the forum, as they are very heavy files, please compress them and upload them to a different website and link it back.

    I don’t know if I will be able to find something, but I may be able to learn a bit more about how to troubleshoot these kind of events.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #61115
    Member
    Robin
    Helpful
    Up
    0
    ::

    I had seen a similar behaviour long ago. Turned out some drivers had to be removed before, and restarted after sleep, in order to allow correct wakeup.

    So try
    rmmod ipw2200
    before sleeping. This is a pure guess, but for me once it worked:
    I believe to recall this was the driver blocking device from wake up properly.
    But as said, this is merely a guess, since your logs show you have also this very same networking device.

    If this does not help you may try to rmmod other modules (e.g. audio-drivers, buetooth-modules or whatever) to figure which is the culprit. One after another. (You only should remove modules not needed for basic functionality…)

    I have finally solved it for me (together with many other issues) by installing proprietary nvidia drivers for graphic card. But you don’t have this option, since you have another manufacturer of graphics device.

    So this will be kind of try and error process for you. And as Xecure said before, make sure to gather as many information from system logs you can in order to finally understand what’s going wrong.

    Windows is like a submarine. Open a window and serious problems will start.

    #61119
    Member
    RandyBobandy
    Helpful
    Up
    0
    ::

    Okay, I’ve compressed and attached the auth, kern and Xorg logs to this reply — file size was much smaller than I anticipated so I was able to upload it here instead of on an external site.

    Thanks Robin for the heads-up; tried unloading that ipw2200 driver like you said, yet my laptop still did not wake from sleep afterwards. Once I get more time I will try going through each driver manually like you said, thanks.

    I have a few more details about my laptop that could help narrow things down:
    – I am not using the internal Intel WiFi card to connect to the internet, instead I am using an external PCMCIA card with the BCM4321 chipset (it’s a Netgear WN511B).
    – Even though I am fairly certain that this specific T43 came with Bluetooth support (there is a Bluetooth light on the indicator LED panel), no Bluetooth adapter is detected under Linux or Windows. Apparently this could be a southbridge issue judging by what pops up on Google, but I’m not sure.

    Attachments:
    #61125
    Member
    RandyBobandy
    Helpful
    Up
    0
    ::

    – I am not using the internal Intel WiFi card to connect to the internet, instead I am using an external PCMCIA card with the BCM4321 chipset (it’s a Netgear WN511B).

    Well, speak of the devil lol…

    Turns out when I unplug that very same card and suspend, I can finally wake from suspend without an issue! It’s exhibiting some odd behaviour when I plug it back in though:
    – When I plug it back in, I am unable to connect to any networks. I cannot suspend, either — I can still use my system yet that terminal just hangs on the pm-suspend command, I can’t even use ctrl-c to get out of it.
    – This same hanging behaviour occurs when I try to run “modprobe b43” (the wireless drivers specific to the card).
    – The card also appears to still be listed in lspci output, even when it’s unplugged?

    All of that also happens if I boot up the system without the card attached — I can only get it to function if it is plugged in on startup, but that’s when the suspend issues crop up again.

    Digging through my syslog I found a kernel oops related to when I try plugging in the card again — perhaps this could be of use also?
    (attached to post)

    EDIT: Forget what I said about the b43 driver — this adapter seems to be using the proprietary Broadcom “wl” drivers instead.

    • This reply was modified 1 year, 6 months ago by RandyBobandy.
    #61128
    Member
    RandyBobandy
    Helpful
    Up
    1
    ::

    Okay so I think I’ve fixed the issue. Blacklisted that proprietary “wl” driver and switched to the open source “b43” drivers and now I can suspend/wake with no issues. You can mark this thread as solved now. Thanks for your guys help.

    #61132
    Anonymous
    Helpful
    Up
    0
    ::

    thanks for reporting the solution, it will be useful for future readers

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.