Touchpad sensitivity

Forum Forums General Hardware Touchpad sensitivity

Tagged: 

  • This topic has 5 replies, 4 voices, and was last updated Jan 15-5:18 pm by Brian Masinick.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #49713
    Member
    dortega

    I’m having trouble with the sensitivity of the touchpad on my laptop. Even the slightest tap triggers the left click action.
    Is there a way to adjust sensitivity?

    #49724
    Moderator
    BobC
    Helpful
    Up
    0
    :D

    I just turn it off usually. I click when I want to click. If you set tapbutton1=0 that will stop it. Fingerhigh and fingerlow are supposed to control its sensitivity, but I haven’t tried that recently.

    synclient -l

    synclient tapbutton1=0

    https://wiki.archlinux.org/index.php/Touchpad_Synaptics

    • This reply was modified 5 months, 1 week ago by BobC.
    #49746
    Member
    Xecure
    Helpful
    Up
    0
    :D

    There is also the Mouse configuration program (Control Centre > Hardware > Mouse Configuration) Threshold option, but this may not work with touchpads.
    I found that my touchpad changed its sensitivity with different kernel versions (with the newest 5.8 kernel version, touch seemed more sensitive).
    If you follow the advice of disabling when you don’t want it to be detected, you can create a hotkey to enable and disable it with the command provided by BobC.

    • This reply was modified 5 months, 1 week ago by Xecure. Reason: wrong name
    #49749
    Moderator
    Brian Masinick
    Helpful
    Up
    0
    :D

    You can also copy and paste this script. Call it Touchpad.bash.
    Once you create it, chmod +x Touchpad.bash.
    You can also use an alias to make it a one or two character command or key sequence, whatever you prefer:

    # Touchpad.bash
    # toggle synaptic touchpad on/off
    
    # get current state
    SYNSTATE=$(synclient -l | grep TouchpadOff | awk '{ print $3 }')
    
    # change to other state
    if [ $SYNSTATE = 0 ]; then
        synclient touchpadoff=1
    elif [ $SYNSTATE = 1 ]; then
        synclient touchpadoff=0
    else
        echo "Couldn't get touchpad status from synclient"
        exit 1
    fi
    exit 0
    • This reply was modified 5 months, 1 week ago by Brian Masinick.

    Brian Masinick

    #49904
    Member
    dortega
    Helpful
    Up
    0
    :D

    I just turn it off usually. I click when I want to click. If you set tapbutton1=0 that will stop it. Fingerhigh and fingerlow are supposed to control its sensitivity, but I haven’t tried that recently.

    synclient -l

    synclient tapbutton1=0

    https://wiki.archlinux.org/index.php/Touchpad_Synaptics

    Thanks. This works somewhat. There’s a huge jump in sensitivity between FingerHigh=39 and FingerHigh=40. And 40 is almost unusable hard. Same with FingerLow. But it does work. More important is MaxTapTime it seems.

    MaxTapTime
    Determines how “crisp” a tap must be to be considered a real tap. Decrease the value to require a more crisp tap. Properly adjusting this parameter can reduce false positives when the hands hover over or lightly touch the pad.

    But MaxTapTime also has a hard edge ..100 is the same as 180 but at 99 it barely registers the tap.

    I don’t want to turn of the tap but thanks for showing this option too.

    #49915
    Moderator
    Brian Masinick
    Helpful
    Up
    0
    :D

    It seems that the touchpad differences between various devices make it difficult for a single program to handle every configuration properly.
    Hopefully there are some features for each device that (in theory at least) allow this to actually work!

    I’ve not had too many problems when I can disable the touchpad completely and connect a USB mouse instead. That tends to work much better – when it’s available.
    Alternatively I turn off the touchpad except when I actually want to use it.

    Brian Masinick

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.