touchpad (solved)

Forum Forums New users New Users and General Questions touchpad (solved)

This topic contains 13 replies, has 6 voices, and was last updated by partsman Oct 29-2:07 pm.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #778
    Member
    Avatar
    1E1E1E

    i am an mx user trying out antix. i like it but i can’t find any way to turn off the touchpad. this is a deal-breaker for me. does any one know how to do it?

    • This topic was modified 1 year, 12 months ago by 1E1E1E.
    #784
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    I don’t know if its installed at the moment, but try

    synclient TouchpadOff=0

    for off and

    synclient TouchpadOff=1

    for on

    from the terminal.

    • This reply was modified 1 year, 12 months ago by dolphin_oracle.
    • This reply was modified 1 year, 12 months ago by dolphin_oracle.
    #787
    Forum Admin
    BitJam
    BitJam

    The synclient program is installed in antiX-17-full. If it doesn’t work for you then you can install xinput and use that to control the touchpad. I used xinput to enable and disable stuff on a 2-in-1 I was running antiX on.

    Cool Tricks with Xinput Device
    https://www.linux.org/threads/cool-tricks-with-xinput-device.10345/

    • This reply was modified 1 year, 12 months ago by BitJam.

    Context is worth 80 IQ points -- Alan Kay

    #790
    Member
    Avatar
    1E1E1E

    I don’t know if its installed at the moment, but try

    synclient TouchpadOff=0

    for off and

    synclient TouchpadOff=1

    for on

    from the terminal.

    It worked.
    Many thanks.

    #821
    Member
    superluminal
    superluminal

    Did it really work? I was just passing by and noticed TouchpadOff=1 should mean that the touchpad is off. i.e 1==True

    I don’t know if its installed at the moment, but try

    synclient TouchpadOff=0

    for off and

    synclient TouchpadOff=1

    for on

    from the terminal.

    It worked.
    Many thanks.

    #840
    Member
    Avatar
    1E1E1E

    Did it really work? I was just passing by and noticed TouchpadOff=1 should mean that the touchpad is off. i.e 1==True

    TouchpadOff=1 is the one that worked.

    #1017
    Member
    partsman
    partsman

    Hello all 🙂
    This is how I turned off touchpad tapping in AntiX-17
    I edited /etc/X11/xorg.conf.d/synaptics.conf
    Lines: 8,9,10

    Option “TapButton1” “0”
    Option “TapButton2” “0” # multitouch
    Option “TapButton3” “0” # multitouch

    changed them from “1” to “0”

    That said ! Only work with root persist enabled ! 😉

    Hope that help someone at some point ! 🙂

    Anyone can build a fast processor. The trick is to build a fast system. (Seymour Cray)

    #1021
    Forum Admin
    BitJam
    BitJam

    That said ! Only work with root persist enabled

    As root, edit the file /live/boot-dev/antiX/state/machine-state-files and add your file to the list. It will be saved on a machine by machine basis even with no persistence. If you would prefer it to be saved across all of your machines then add it to general-state-files instead.

    Context is worth 80 IQ points -- Alan Kay

    #1023
    Member
    partsman
    partsman

    @BitJam Ahh ! Yes ! My bad !
    Still getting both sides of the brain in sync ! 🙂
    Thanks ! 😉

    Anyone can build a fast processor. The trick is to build a fast system. (Seymour Cray)

    #1048
    Forum Admin
    BitJam
    BitJam

    We do not expect perfect recall of tons of new information here. We are still learning how to best use all the tools.

    Context is worth 80 IQ points -- Alan Kay

    #1061
    Member
    partsman
    partsman

    BitJam: wrote

    We do not expect perfect recall of tons of new information here. We are still learning how to best use all the tools.

    Thanks BitJam !

    Its nice to feel part of a community where we can feel free to speak and learn together “and from one another”
    without being criticized for his/her ideas or way of thinking ! I have always believed that is what makes a
    good distro/community ! You guys are doing a good thing here ! And Your efforts are much appreciated ! Thank You ! 😉

    Anyone can build a fast processor. The trick is to build a fast system. (Seymour Cray)

    #1122
    Member
    Avatar
    utu

    I added the two entries to the Control Center Start-up script
    found at MainMenu>ControlCenter>Session>User…>startup
    to tame my own typing difficulties:

    
    # Uncomment to Disable touchpad
    synclient TouchpadOff=1
    
    # Uncomment to Disable caps-lock toggle
    setxkbmap -option ctrl:nocaps
    
    • This reply was modified 1 year, 11 months ago by utu.

    64-bit MX-18.2 using 4.20.12 Kernel LiveUSB on Dell Laptop

    #1136
    Member
    Avatar
    1E1E1E

    I added the two entries to the Control Center Start-up script
    found at MainMenu>ControlCenter>Session>User…>startup
    to tame my own typing difficulties

    Nice. Thanks.

    #1155
    Member
    partsman
    partsman

    @ utu
    @ 1E1E1E

    Awesome guys ! Thanks for the info !
    Amazing how may ways things can be done !
    That is what the freedom of Linux and AntiX
    Are all about ! 😉 Love it !

    Anyone can build a fast processor. The trick is to build a fast system. (Seymour Cray)

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.