Trackpad sensitivity

Forum Forums General Hardware Trackpad sensitivity

This topic contains 15 replies, has 5 voices, and was last updated by Klaas Vaak Jun 28-4:24 am.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #21931
    Member
    Avatar
    Klaas Vaak

    When using Firefox I have noticed that sometimes the page spontaneously starts to scroll fast up or down if I just click on 1 of the 2 arrows on the scroll bar. I tried another browser, Opera, but it does the same. Also, it can happen that the scrolling starts if my finger is close to but not on the trackpad.

    So, putting 1 and 1 together I conclude that the trackpad is overly sensitive.
    1. am I right?
    2. if so, is there a setting to reduce that sensitivity somewhat?

    inxi -Fxz
    System:
      Host: Yoga300 Kernel: 4.19.25-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc 
      v: 6.3.0 Desktop: IceWM 1.4.2 
      Distro: antiX-17.2_x64-full Helen Keller 4 October 2018 
      base: Debian GNU/Linux 9 (stretch) 
    Machine:
      Type: Laptop System: LENOVO product: 80M0 v: Lenovo YOGA 300-11IBY serial: <filter> 
      Mobo: LENOVO model: Mini v: SDK0J33995WIN serial: <filter> UEFI: LENOVO v: C0CN25WW 
      date: 04/21/2015 
    Battery:
      ID-1: BAT1 charge: 12.5 Wh condition: 26.3/30.0 Wh (88%) model: SMP L14M2P22 
      status: Discharging 
    CPU:
      Topology: Dual Core model: Intel Celeron N2840 bits: 64 type: MCP arch: Silvermont 
      rev: 8 L2 cache: 1024 KiB 
      flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8663 
      Speed: 766 MHz min/max: 500/2582 MHz Core speeds (MHz): 1: 746 2: 893 
    Graphics:
      Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
      vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
      Display: server: X.Org 1.19.2 driver: modesetting unloaded: fbdev,vesa 
      resolution: 1366x768~60Hz 
      OpenGL: renderer: Mesa DRI Intel Bay Trail v: 3.3 Mesa 13.0.6 direct render: Yes 
    Audio:
      Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
      vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
      Sound Server: ALSA v: k4.19.25-antix.1-amd64-smp 
    Network:
      Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo 
      driver: r8169 v: kernel port: 1000 bus ID: 01:00.0 
      IF: eth0 state: down mac: <filter> 
      Device-2: Intel Wireless 3160 driver: iwlwifi v: kernel port: 1000 bus ID: 02:00.0 
      IF: wlan0 state: up mac: <filter> 
    Drives:
      Local Storage: total: 29.24 GiB used: 4.57 GiB (15.6%) 
      ID-1: /dev/mmcblk0 model: BGND3R size: 29.12 GiB 
      ID-2: /dev/sda type: USB model: USB NAND FLASH size: 125.0 MiB 
    Partition:
      ID-1: / size: 7.81 GiB used: 4.56 GiB (58.4%) fs: ext4 dev: /dev/mmcblk0p2 
      ID-2: swap-1 size: 2.00 GiB used: 420 KiB (0.0%) fs: swap dev: /dev/mmcblk0p3 
    Sensors:
      System Temperatures: cpu: 41.0 C mobo: N/A 
      Fan Speeds (RPM): N/A 
    Info:
      Processes: 149 Uptime: 1d 1h 18m Memory: 1.83 GiB used: 619.8 MiB (33.0%) 
      Init: SysVinit runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.29
    • This topic was modified 5 months ago by Klaas Vaak.
    #21939
    Forum Admin
    rokytnji
    rokytnji

    Menu>Applications>Preferences>Mouse Configuration might help.

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #21940
    Member
    Avatar
    skidoo

    startpage.com websearch will probably be enlightening:
    linux|debian|ubuntu Lenovo YOGA trackpad sensitivity

    #22229
    Member
    Avatar
    Klaas Vaak

    @rokytnji & @skidoo: sorry for the somewhat late reply, but I was busy trying to figure out settings and combinations thereof. I 1st set the vertical scrolling in one of the system files (can’t remember exactly which one) to zero, which seemed to help a bit, but no completely.

    So I subsequently followed @rokytnji’s suggestion, and 1st set the threshold to 60 (was 1), but that did not do it, then set the acceleration to zero (was 2) and that seems to have done the trick.

    Many thanks for your help.

    #22569
    Member
    Avatar
    Klaas Vaak

    I was too quick off the mark: none of my actions have resolved the issue.

    #22619
    Forum Admin
    rokytnji
    rokytnji

    Well. If it helps. Or not. I am trying to show how to find info on touchpads over here

    https://forum.mxlinux.org/viewtopic.php?p=507091

    Dude is running gnome shell which is throwing me for a loop.

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    #22650
    Member
    Xecure
    Xecure

    @rokytnji & @skidoo: sorry for the somewhat late reply, but I was busy trying to figure out settings and combinations thereof. I 1st set the vertical scrolling in one of the system files (can’t remember exactly which one) to zero, which seemed to help a bit, but no completely.

    You probably edited /etc/X11/xorg.conf.d/synaptics.conf (or something similar like 50-synaptics.conf), and modified the Option “VertScroll” “1” to “0”. To disable it. In some trackpads, it is “DeltaVertScroll”, and instead of decreasing the number, one needs to increase it to make scrolling slower.

    So I subsequently followed @rokytnji‘s suggestion, and 1st set the threshold to 60 (was 1), but that did not do it, then set the acceleration to zero (was 2) and that seems to have done the trick.

    Checking just in case: when applying those changes, did you check “Enable mouse configuration on startup” to on? You probably did, but I wanted to be sure.

    I was too quick off the mark: none of my actions have resolved the issue.

    For the trackpad problem, I started xev on my laptop to see what keys appeared when using the scroll part of the trackpad. I should have guessed: Button4 and Button5 (mouse wheel).

    So, after spending some time researching the trackpad problem, I propose two “solutions”:

    A) “Difficulty: Easy”- Reduce mouse-wheel sensitivity with imwheel (worked on my trackpad, found solution on mx wiki: https://mxlinux.org/wiki/hardware/mouse-tweaks/, I set it to “1” instead of “3” and followed the suggestion in the comment on how to start imwheel only stopping button4 and button5).
    'imwheel --kil --buttons "4 5"
    To make it permamnent you must add the same command to the startup file for your selected window manager (I am sure you will find an answer in the forum for whatever WM you are using).

    B) “Difficulty: Medium” Modify how the trackpad “works” with xinput. (Worked on my laptop)
    Install xinput. Once installed, open a terminal and execute:
    xinput list
    See what id the touchpad has. In my case, it is “ETPS/2 Elantech Touchpad, id=13”
    Use the list-props option
    xinput list-props device-id
    where device-id is the one you have observed in xinput list before. This will display a list of all the different behaviors that can be modified for this device. For me it was:
    xinput list-props 13
    Each device might be different, so pay attention to what you want to modify. In my case, I wanted to modify “Synaptics Edge Scrolling” to disable scrolling, which was initially set to “1, 0, 1”
    xinput set-prop 13 “Synaptics Edge Scrolling” 0 0 1
    If instead of disabling it, I want to increase the “scrolling distance” (reduce scrolling sensitivity) I would change “Synaptics Scrolling Distance· (initially set to 58, 58)
    xinput set-prop 13 “Synaptics Scrolling Distance” 200 200
    This made my trackpad scrolling veeeery slow (less sensitive)
    (more info (but not exactly the same) here: https://help.ubuntu.com/community/SynapticsTouchpad)

    I have played a bit with xinput settings when figuring out how my touchscreen worked, but I really don’t know enough. I recommend you copy all the list-props output and save it to a file so you can reset any changed options incase something goes wrong.

    #22672
    Member
    Avatar
    Klaas Vaak

    Wow, this is incredible, the amount of work you put into my issue when you don’t get anything out of it except a “thank you”. Many thanks.
    Just a couple of remarks/questions.

    You probably edited /etc/X11/xorg.conf.d/synaptics.conf (or something similar like 50-synaptics.conf),

    Yes, it was /etc/X11/xorg.conf.d/synaptics.conf.

    and modified the Option “VertScroll” “1” to “0”. To disable it. In some trackpads, it is “DeltaVertScroll”, and instead of decreasing the number, one needs to increase it to make scrolling slower.

    I set “VertScroll” to “0” because I had read that is the way to disable it.

    Checking just in case: when applying those changes, did you check “Enable mouse configuration on startup” to on? You probably did, but I wanted to be sure.

    You did well to ask me, because it was NOT enabled!! I am actually surprised the default setting is to be not enabled. Anyway, I enabled it.

    A) “Difficulty: Easy”- Reduce mouse-wheel sensitivity with imwheel (worked on my trackpad, found solution on mx wiki: https://mxlinux.org/wiki/hardware/mouse-tweaks/, I set it to “1” instead of “3” and followed the suggestion in the comment on how to start imwheel only stopping button4 and button5).
    'imwheel --kil --buttons "4 5"
    To make it permamnent you must add the same command to the startup file for your selected window manager (I am sure you will find an answer in the forum for whatever WM you are using).

    This seems to me to apply more to a physical mouse – got the same impression from the link. I have not implemented this.

    B) “Difficulty: Medium” Modify how the trackpad “works” with xinput. (Worked on my laptop)
    Install xinput. Once installed, open a terminal and execute:
    xinput list
    See what id the touchpad has. In my case, it is “ETPS/2 Elantech Touchpad, id=13”
    Use the list-props option
    xinput list-props device-id
    where device-id is the one you have observed in xinput list before. This will display a list of all the different behaviors that can be modified for this device. For me it was:
    xinput list-props 13

    On my machine it is exactly the same: id # 13

    If instead of disabling it, I want to increase the “scrolling distance” (reduce scrolling sensitivity) I would change “Synaptics Scrolling Distance· (initially set to 58, 58)
    xinput set-prop 13 “Synaptics Scrolling Distance” 200 200
    This made my trackpad scrolling veeeery slow (less sensitive)
    (more info (but not exactly the same) here: https://help.ubuntu.com/community/SynapticsTouchpad)

    That is exactly what I wanted to do, except I set the numbers each to 100 to see the effect, and maybe adjust a bit more afterwards.

    In fact, I checked what the various parameters for the touchpad in my Mint OS are on my other computer, and adjusted a few more on the AntiX computer to the same values.
    There is only 1 parameter that baffles me: Synaptics Off. On my AntiX computer it is set to 0, on my Mint computer it is set to 2. I have not changed this on my AntiX computer, and the touchpad is active. I have not been able to get good info on this – do you know what it means?

    I must say, this xinput route has given me a bit more hope of not having to replace AntiX on my eMMC computer. So I’ll ask my wife to work with the computer a bit more and see if there is any change.

    • This reply was modified 4 months, 2 weeks ago by Klaas Vaak.
    • This reply was modified 4 months, 2 weeks ago by Klaas Vaak.
    #22677
    Avatar
    Anonymous

    There is only 1 parameter that baffles me: Synaptics Off.

    Why?

    https://linux.die.net/man/4/synaptics

    Maybe reinstalling synaptics might help too.

    #22680
    Member
    Xecure
    Xecure

    If instead of disabling it, I want to increase the “scrolling distance” (reduce scrolling sensitivity) I would change “Synaptics Scrolling Distance· (initially set to 58, 58)
    xinput set-prop 13 “Synaptics Scrolling Distance” 200 200
    This made my trackpad scrolling veeeery slow (less sensitive)
    (more info (but not exactly the same) here: https://help.ubuntu.com/community/SynapticsTouchpad)

    That is exactly what I wanted to do, except I set the numbers each to 100 to see the effect, and maybe adjust a bit more afterwards.

    I must say, this xinput route has given me a bit more hope of not having to replace AntiX on my eMMC computer. So I’ll ask my wife to work with the computer a bit more and see if there is any change.

    I forgot to write that you will need to add that xinput command to your startup file, as xinput changes will reset on restart.
    I found that in skidoo’s article about IceWM, the startup file can be found here: ~/.icewm/startup

    There is only 1 parameter that baffles me: Synaptics Off. On my AntiX computer it is set to 0, on my Mint computer it is set to 2. I have not changed this on my AntiX computer, and the touchpad is active. I have not been able to get good info on this – do you know what it means?

    If what I found in the synaptics’ man page online is correct, the values for SynapticsOff mean:

    0 Touchpad is enabled
    1 Touchpad is switched off
    2 Only tapping and scrolling is switched off

    One last thing I forgot to add.

    Yes, it was /etc/X11/xorg.conf.d/synaptics.conf

    Changes here only take effect after reboot (if I am not mistaken), or if you reload the device (which I don’t know how to).

    Edit: noClue also found it out. I wasn’t fast enough.

    • This reply was modified 4 months, 2 weeks ago by Xecure. Reason: noClue was faster. I submit to thee
    #22685
    Member
    Avatar
    Klaas Vaak

    Maybe reinstalling synaptics might help too.

    Why? Is 0 not good? What good will reinstallation do?

    • This reply was modified 4 months, 2 weeks ago by Klaas Vaak.
    #22687
    Member
    Avatar
    Klaas Vaak

    I forgot to write that you will need to add that xinput command to your startup file, as xinput changes will reset on restart.
    I found that in skidoo’s article about IceWM, the startup file can be found here: ~/.icewm/startup

    Oh no! Does that mean that all the changes I made via xinput will have to be added to icewm? Can that be done in 1 single command?
    I looked at /.icewm/startup, and that startup file has a Terminal icon. Clicking on it does nothing, does not open it. Right-clicking and trying to open with an editor like Nano does not work.

    0 Touchpad is enabled
    1 Touchpad is switched off
    2 Only tapping and scrolling is switched off

    Thanks for that.

    One last thing I forgot to add.

    #22690
    Member
    Xecure
    Xecure

    Oh no! Does that mean that all the changes I made via xinput will have to be added to icewm? Can that be done in 1 single command?
    I looked at /.icewm/startup, and that startup file has a Terminal icon. Clicking on it does nothing, does not open it. Right-clicking and trying to open with an editor like Nano does not work.

    I don’t use IceWM, so I am not entirely sure if antiX uses the startup file when using this window manager (hopefully some IceWM expert can confirm this)
    If you cannot edit through the file manager, try this in a terminal
    geany ~/.icewm/startup
    or nano instead of geany, or whatever editor is of your liking.

    The startup file, once edited, should look like this (example, replace with your own changes):

    #!/bin/bash
    xinput set-prop 13 “Synaptics Scrolling Distance” 200 200
    xinput set-prop 13 “Synaptics Off” 2

    As you can see, you only add the commands that change something. Hopefully they are not too many.

    #22691
    Member
    Avatar
    Klaas Vaak

    The startup file, once edited, should look like this (example, replace with your own changes):

    #!/bin/bash
    xinput set-prop 13 “Synaptics Scrolling Distance” 200 200
    xinput set-prop 13 “Synaptics Off” 2

    As you can see, you only add the commands that change something. Hopefully they are not too many.

    OK Xecure, many thanks. I’ll implement that and see what the effects are.

    1 last question: even after the changes which I think are relevant, the cursor arrow still overshoots the target slightly when I move my finger on the touchpad, despite the changes to various parameters I made via xinput. It has always done it, but now that I am “into” touchpad settings it struck me. The cursor arrow on my Mint machine does not do that. Any suggestion?

    #22695
    Member
    Xecure
    Xecure

    1 last question: even after the changes which I think are relevant, the cursor arrow still overshoots the target slightly when I move my finger on the touchpad, despite the changes to various parameters I made via xinput. It has always done it, but now that I am “into” touchpad settings it struck me. The cursor arrow on my Mint machine does not do that. Any suggestion?

    After some reading, this is what I understand so far:
    The driver used for communication between the system and your touchpad is called Synaptics. You can change the behavior of the touchpad changing the driver’s properties in “/etc/X11/xorg.conf.d/synaptics.conf”. Sometimes, shit happens, and modifying the file doesn’t change Synaptics’ behavior (even after restarting the synaptics driver) and, as we need something else to communicate with the Synaptics driver, we use xinput. This strange behavior is probably the reason noClue recommended to reinstall Synaptics, as sometimes a reinstall will fix this. Maybe this could also solve the touchpad sensitivity problem (wild guess with little probability of working).

    Anyway, as Synaptics changes cannot be saved in the synaptics.conf file, you need to save them somewhere else or execute the changes on startup using xinput (that is what I have proposed). All possible options are documented in the synaptics online man page (the “Options” are what they look like in the synaptics.conf file, and what you see in xinput is called “Property”, so all the Synaptic properties displayed by xinput for the touchpad can be easily searched on this page, so you know what each property does; the options are better described, so you will have to use the browser search function to see the equivalent option for the property you are looking for).

    If what you describe as overshoot happens when you are lifting your finger from the trackpad after moving, it must be related to the “Synaptics Finger” property.
    If what you describe happens when taping, it must be related to the “Synaptics Tap” properties.
    If it happens when moving around (it moves too fast), you may have to modify the other xinput properties that are not related to Synaptics (the ones that are “maybe” modified by some other program). For my device, I can see “Device Accel Profile”, “Device Accel Constant Deceleration”, “Device Accel Velocity Scaling”, etc. I guess for this kind of behavior it is better to use the Mouse configuration program in Control Center > Hardware.

    As I have responded quite late, you have probably figured all this out by now. As this behavior you are experiencing is difficult to describe, you will have to test things out and decide what is related to your overshooting problem.

    • This reply was modified 4 months, 2 weeks ago by Xecure. Reason: Editing to add enfasis
Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.