Troubles with Broadcom WiFi BCM4318

Forum Forums Official Releases antiX-21/22 “Grup Yorum” Troubles with Broadcom WiFi BCM4318

  • This topic has 13 replies, 5 voices, and was last updated Feb 13-12:27 am by Brian Masinick.
Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #93425
    Member
    aspire3023

      Hello!

      I have installed Antix on my old Acer 3023WLMi, and I am quite happy with the OS performance. The laptop had been previously running Debian 11 with LXQT and it was visibly slower.
      There is one major problem though, and it is the Broadcom BCM4318 WiFi. Connman says it is connected, but I can not access anything. I have to say that the last official 32bit Puppy linux works well with the laptop’s WiFi.

      During the Antix installation, the b43-fw_cutter, firmware-b43-installer, firmware-b43legacy-installer have been installed. I have removed firmware-b43legacy-installer, as it is not relevant for the 4318.

      After a re-scan, Network assistant has shown the following loaded drivers: b43,r8169,mii,fjes

      ping 8.8.8.8 fails, with message “Destination Host Unreachable”. The same message appears whenever I try to use a browser to access Internet.

      ping 192.168.1.1 works fine.

      I have attached the output of several commands.
      ==========================================================

      $ rfkill list
      0: acer-wireless: Wireless LAN
      	Soft blocked: no
      	Hard blocked: no
      2: phy0: Wireless LAN
      	Soft blocked: no
      	Hard blocked: no

      ==========================================================

      sudo lshw -C network
        *-network:0               
             description: Wireless interface
             product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller
             vendor: Broadcom Inc. and subsidiaries
             physical id: 5
             bus info: pci@0000:06:05.0
             logical name: wlan0
             version: 02
             serial: 00:0e:9b:c4:99:77
             width: 32 bits
             clock: 33MHz
             capabilities: bus_master ethernet physical wireless
             configuration: broadcast=yes driver=b43 driverversion=4.9.0-326-antix.1-486-smp firmware=784.2 ip=192.168.1.5 latency=64 link=yes multicast=yes wireless=IEEE 802.11
             resources: irq:9 memory:c0204000-c0205fff
        *-network:1
             description: Ethernet interface
             product: RTL8169 PCI Gigabit Ethernet Controller
             vendor: Realtek Semiconductor Co., Ltd.
             physical id: 7
             bus info: pci@0000:06:07.0
             logical name: eth0
             version: 10
             serial: 00:0a:e4:e1:35:d6
             size: 1Gbit/s
             capacity: 1Gbit/s
             width: 32 bits
             clock: 66MHz
             capabilities: bus_master rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
             configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.3 latency=64 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=1Gbit/s
             resources: irq:23 ioport:a000(size=256) memory:c0209400-c02094ff memory:84000000-8401ffff

      ==========================================================

      $lspci -nn -vv  
      ....
      06:05.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
      	Subsystem: AMBIT Microsystem Corp. Aspire 3022WLMi, 5024WLMi, 5020 [1468:0311]
      	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
      	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
      	Latency: 64
      	Interrupt: pin A routed to IRQ 9
      	Region 0: Memory at c0204000 (32-bit, non-prefetchable) 
      	Kernel driver in use: b43-pci-bridge
      	Kernel modules: ssb, wl

      ==========================================================

      $lsmod
      Module                  Size  Used by
      ccm                    20480  2
      b43                   389120  0
      bcma                   53248  1 b43
      mac80211              606208  1 b43
      cfg80211              442368  2 b43,mac80211
      ssb                    57344  1 b43
      rng_core               16384  1 b43
      pcmcia                 49152  1 ssb
      hid_generic            16384  0
      8021q                  28672  0
      garp                   16384  1 8021q
      stp                    16384  1 garp
      mrp                    20480  1 8021q
      llc                    16384  2 garp,stp
      bnep                   20480  2
      bluetooth             442368  7 bnep
      nfsd                  307200  2
      auth_rpcgss            53248  1 nfsd
      nfs_acl                16384  1 nfsd
      nfs                   192512  0
      lockd                  81920  2 nfsd,nfs
      grace                  16384  2 nfsd,lockd
      fscache                69632  1 nfs
      sunrpc                262144  6 auth_rpcgss,nfsd,nfs_acl,lockd,nfs
      parport_pc             32768  0
      ppdev                  20480  0
      lp                     20480  0
      parport                40960  3 lp,parport_pc,ppdev
      dm_crypt               24576  0
      dm_mod                 94208  1 dm_crypt
      arc4                   16384  2
      radeon               1400832  3
      snd_atiixp_modem       20480  0
      snd_atiixp             20480  1
      snd_ac97_codec        118784  2 snd_atiixp,snd_atiixp_modem
      ttm                    77824  1 radeon
      ac97_bus               16384  1 snd_ac97_codec
      acer_wmi               20480  0
      snd_pcm                86016  3 snd_atiixp,snd_ac97_codec,snd_atiixp_modem
      drm_kms_helper        118784  1 radeon
      snd_timer              28672  1 snd_pcm
      snd                    61440  7 snd_atiixp,snd_ac97_codec,snd_timer,snd_atiixp_modem,snd_pcm
      soundcore              16384  1 snd
      drm                   258048  6 radeon,ttm,drm_kms_helper
      powernow_k8            24576  0
      i2c_algo_bit           16384  1 radeon
      edac_mce_amd           28672  0
      fb_sys_fops            16384  1 drm_kms_helper
      edac_core              40960  0
      syscopyarea            16384  1 drm_kms_helper
      sysfillrect            16384  1 drm_kms_helper
      sysimgblt              16384  1 drm_kms_helper
      wistron_btns           16384  0
      sparse_keymap          16384  2 wistron_btns,acer_wmi
      input_polldev          16384  1 wistron_btns
      evdev                  20480  12
      input_leds             16384  0
      joydev                 20480  0
      serio_raw              16384  0
      rfkill                 20480  6 bluetooth,acer_wmi,cfg80211
      tifm_7xx1              16384  0
      k8temp                 16384  0
      wmi                    20480  1 acer_wmi
      yenta_socket           36864  0
      pcmcia_rsrc            20480  1 yenta_socket
      shpchp                 32768  0
      ac                     16384  0
      video                  40960  1 acer_wmi
      battery                20480  0
      button                 16384  0
      btrfs                1069056  0
      xor                    28672  1 btrfs
      raid6_pq              106496  1 btrfs
      psmouse               118784  0
      r8169                  81920  0
      mii                    16384  1 r8169
      firewire_ohci          36864  0
      firewire_core          57344  1 firewire_ohci
      pcmcia_core            20480  3 yenta_socket,pcmcia,pcmcia_rsrc
      uas                    24576  0
      usb_storage            53248  4 uas
      i2c_piix4              20480  0
      thermal                20480  0
      rtc_cmos               20480  0
      fjes                   28672  0

      ==========================================================

      $ iwconfig
      lo        no wireless extensions.
      eth0      no wireless extensions.
      wlan0     IEEE 802.11  ESSID:"OUR_NET"  
                Mode:Managed  Frequency:2.447 GHz  Access Point: 50:A9:DE:79:52:26   
                Bit Rate=1 Mb/s   Tx-Power=20 dBm   
                Retry short limit:7   RTS thr:off   Fragment thr:off
                Power Management:off
                Link Quality=57/70  Signal level=-53 dBm  
                Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
                Tx excessive retries:21  Invalid misc:1146   Missed beacon:0

      ==========================================================
      The file /etc/resolv.conf has only two lines:

      # Generated by Connection Manager
      nameserver 192.168.1.1

      ==========================================================
      The file /etc/network/interfaces has also just two uncommented lines:

      auto lo
      iface lo inet loopback
      ==========================================================
      I have also followed the steps advised on B43 thread found in the Antix Forum:

      1. sudo rfkill unblock all
      2. sudo apt purge firmware-b43-installer
      3. sudo apt update
      4. sudo apt install –reinstall firmware-b43-installer
      5. sudo modprobe -r b43
      6. sudo modprobe b43

      Unfortunately, nothing has changed.

      Have to say that my laptop has been working relatively fine for several years with Debian. After the last Debian update the Wifi stopped working and this was the reason to move to Antix.

      Another detail is that when I move my Wifi connection to the top of the Connman list of Services, the connection begins to work for a while, albeit at a really slow speed. After about 1 minute, the connection is lost again.

      This problem is way outside my experience and I would be grateful for any help.

      #93448
      Moderator
      Brian Masinick

        I wonder if the Ceni network manager would have different results.

        I’ve had a few cases where it’ll solve things and sometimes switching between connman and ceni help; the switching network topl can be helpful for this kind of switching back and forth; sometimes it helps identify or magically solve networking issues.

        As far as the Broadcom commands, yes, those are accurate.

        If you can throw a few dollars at this, sometimes grabbing a removable USB wireless antenna/adapter helps but be careful to choose one that has a well supported card that works well with Linux so that you have a working solution.

        --
        Brian Masinick

        #93451
        Member
        madibi

          Dear aspire3023,
          I experimented your issue in December 2021 when installing antiX on an Acer from 2007, and I found that the solution proposed in the top of the forum was optimal for me.
          The same issue was detected in a lot of Debian derivatives such as Mx, Q4OS, Sparkly, etc and NOT on the *buntus => the issue lies in Debian and not in antiX.
          The forum solution worked both on antiX 19 and in 21.
          In some cases, with antiX 22, some problems with Connman are reported, and @Brian Masinick in the previous post pointed you to a solution.

          As a 1st step: I’d search using a live with 21, to verify if the forum solution works.
          Don’t forget to do : “sudo apt update” before following the 6 steps.
          In this case you need another way to be connected to internet: in case your internet connection is done with another wifi dongle or an eth cable, you can immediately test if the forum solution is good for you.
          In case your internet connection is done using your mobile phone, usb connection, unfortunately you should reboot your Acer in order to see if your b43 now works. In this case you should make your live try, using the root persistence.

          As a 2nd step: now you know if your b43 is working or not, if it works now you can try on antiX 22 as now you will have located your problem.

          Good luck 🙂
          m

          EDIT
          A member of the forum named @lefti, pointed out another solution that you can find here:
          https://www.antixforum.com/forums/topic/split-fix-broadcom-b43-problems-discussion/ ==> see feb the 1st
          https://www.antixforum.com/forums/topic/split-linux-live-kit/page/2/ ==> see jan the 31st

          • This reply was modified 1 year, 3 months ago by madibi.
          #93454
          Moderator
          BobC

            Did you look at the thread up near the top about Broadcom WiFi?

            Maybe you didn’t notice it above. Here is a link…

            https://www.antixforum.com/forums/topic/fix-broadcom-b43-problems/

            my bad, I bet that is the thread you referred to…

            PS: I fired up the old Dell D620 laptop I have, and it has a Broadcom 4311, so everything isn’t identical.

            • This reply was modified 1 year, 3 months ago by BobC.
            • This reply was modified 1 year, 3 months ago by BobC.
            #93457
            Moderator
            BobC

              I am guessing Debian (or upstream of them) maybe changed something which affected your card, and that code is used by antiX as well. I would suggest you try an older version of antiX, but don’t update it before you install. My 4311 had trouble running from antiX off the flashdrive, but worked ok once installed to the hard drive. Maybe the 4318 will have the same issue.

              PS: If you get it working at good speeds let us know, please. My 4311 has gotten much slower. BTW, the best answer I found so far was to add a separate wifi adapter.

              Thanks.

              • This reply was modified 1 year, 3 months ago by BobC.
              #93599
              Member
              aspire3023

                Hello,
                Many thanks for all of your helpful replies.

                I have bought a TP-Link TL-WN722N wireless USB adapter. It began working immediately after I had plugged it in. There was a user panic after the first reboot, as the adapter was shown as connected to my wireless service, but again there was no internet connection. Luckily, moving the connection to the top of the Connman services solved the problem. The connection was fast and stable. So the only minor annoyance left is that after every reboot, I have to manually start the Wifi connection, which is OK with me. This was not an option with the latest version of the b43 driver, as the laptop was losing connection shortly after gaining it.

                Then, I have removed completely b43 related software from my laptop and reinstalled an older version of the firmware-b43-installer.

                $sudo apt purge *b43*    
                $sudo apt list -a *b43*  
                $sudo apt install firmware-b43-installer=1:019-3

                After that, I have rebooted my laptop and manually pushed my WiFi network to the top of Connman services. This time, the connection provided by the BCM4318 was stable and its speed was acceptable. Still, the TL-WN722N USB adapter seems faster, than the old BCM4318.

                Many thanks again!

                #93612
                Moderator
                BobC

                  Glad to hear it worked. Thanks for posting the solution. I’ll give it a try on my 4311. Its pretty similar.

                  #93641
                  Member
                  madibi

                    Dear aspire3023,
                    I’m happy that you could find a solution.

                    Still, the TL-WN722N USB adapter seems faster, than the old BCM4318

                    To me happened the same: using the native B43, the max speed arrived to 20Mbps (average 10), while with the TP-link it was easy to arrive > 35 Mbps.
                    In any case, my needs are not so high, so I ended up using the internal wifi, being happy that way.
                    m

                    #93654
                    Moderator
                    BobC

                      I downloaded Debian 11.5 and tried to install it on my Dell D620 with the Brcm4311 wifi, and B43 does come up on the list to select it, but it doesn’t recognize the card, and won’t install.

                      #93660
                      Moderator
                      Brian Masinick

                        Isn’t it interesting; a decade ago that same hardware could run almost anything and in it’s prime it was an excellent laptop.

                        Dell, IBM/Lenovo and HP equipment has always worked well for me and I have had pretty good results with Gateway and Acer too.

                        --
                        Brian Masinick

                        #93717
                        Member
                        aspire3023

                          Hi BobC,

                          You may have already checked it and tried it, but BCM4311 is also supported by the wl driver in broadcom-sta-dkms package.
                          Also, during my first Debian installations, I had to complete the installation without the WiFi drivers. I had to download the drivers on another computer, and then I have copied and installed them on my acer 3023.

                          I have followed the installation procedures for the bcm 43xx drivers shown here:
                          http://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

                          And the for the wl driver you may check this link as well:
                          http://wiki.debian.org/wl

                          As we had already commented above, after the last Debian 11 update, I had to use the previous version of b43 package 1:019-3, because the latest 1:019-7 provided by the installer didn’t work. It may be the same with the broadcom-sta-dkms package. I do not know how you can choose a previous/older version of a specific driver during the Debian installation though.

                          #93832
                          Moderator
                          BobC

                            I will look into it and also try the solution you used. I was looking, and there was a bug reported in 2012 that affected machines with 2 Broadcom adapters, which mine has, and it doesn’t look like it was ever fixed.

                            http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=668613

                            #132674
                            Member
                            Valea

                              I had a similar issue installing MX Linux 23.2-386 on a HP Pavilion ze2000. The issue was present booting from Live-USB as well as booting from a fresh installed system. The WiFi access points were visible but I could not connect to any.

                              The 6 steps procedure described in the first post worked like a charm, on live system and installed system. I just had to retype the step-4 command due to a syntax mismatch. The “reinstall” parameter must be preceded by two “-” (not the strange “–”).
                              sudo apt install --reinstall firmware-b43-installer

                              Thanks to @aspire3023. Resurrected this antic but useful comp.

                              • This reply was modified 2 weeks, 5 days ago by Valea.
                              • This reply was modified 2 weeks, 5 days ago by Valea.
                              • This reply was modified 2 weeks, 5 days ago by Valea.
                              #132972
                              Moderator
                              Brian Masinick

                                The incorrect dashes in any command copied is due to the way in which certain characters are interpreted in the text widget of the forum software — is correct – or _ is incorrect, as is some graphical display of dashes instead of –, so you were correct in fixing this.

                                --
                                Brian Masinick

                              Viewing 14 posts - 1 through 14 (of 14 total)
                              • You must be logged in to reply to this topic.