Trying to make Hyprland work on Antix

Forum Forums New users New Users and General Questions Trying to make Hyprland work on Antix

  • This topic has 1 reply, 2 voices, and was last updated Apr 20-7:48 pm by abc-nix.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #140006
    Member
    keshav-uses-linux

      hi from an noob, antiX-23_x64-full user.
      it feels like i am taking a big step to tackle installing Hyprland from scratch install
      anyways, got some errors and need help

      What Steps have I done?:-

      1. According to the Official installation guide , did the following stuff
        • They gave a one liner to install mutiple lib files for every Distro. Guide only Supports certain Distros Ubuntu was supported assumin it must work on Antix too, i ran the One liner for Ubuntu that read like
          sudo apt-get install -y meson wget build-essential ninja-build cmake-extras cmake gettext gettext-base fontconfig libfontconfig-dev libffi-dev libxml2-dev libdrm-dev libxkbcommon-x11-dev libxkbregistry-dev libxkbcommon-dev libpixman-1-dev libudev-dev libseat-dev seatd libxcb-dri3-dev libegl-dev libgles2 libegl1-mesa-dev glslang-tools libinput-bin libinput-dev libxcb-composite0-dev libavutil-dev libavcodec-dev libavformat-dev libxcb-ewmh2 libxcb-ewmh-dev libxcb-present-dev libxcb-icccm4-dev libxcb-render-util0-dev libxcb-res0-dev libxcb-xinput-dev xdg-desktop-portal-wlr libtomlplusplus3
          

          but got the error that

          The following packages have unmet dependencies:
           libudev-dev : Depends: libeudev-dev but it is not installable

          so, found an forum post that said.

          We use eudev not udev so you need
          sudo apt install libeudev-dev

          so, replace libudev-dev with libeudev-dev
          Command succesfully Ran

        • copied the binary (Hyprland) to /usr/bin/. from the release download tar package
        • copied hyprctl to /usr/bin/.
        • copied hyprpm to /usr/bin/.
        • Then the guide said to copy the wlroots .so (libwlroots.so.XX032) to /usr/lib/., Didn’t understood that completely, so after some Head Banging, installed sudo apt install libwlroots10
          with no certainty of it working
        • Copied copy the desktop entry (example/hyprland.desktop) to /usr/share/wayland-sessions/
        • after these instructions, the rest of the guide is about mannualy compiling and doing some shit that i dont understand
          so, i think there’s nothing left from the guide for me to follow

      2. Now, tried to run the Executable Hyprland with sudo (gave “Permission denied” without sudo)
        got this beautiful error

        
        $ sudo Hyprland
        Hyprland: error while loading shared libraries: libxcb-errors.so.0: cannot open shared object file: No such file or directory
        
      3. Tried doing a simple sudo apt install libxcb-util0. but still the same state

      consider me as a Actuall Noob. its only been a few months that i started using linux

      • This topic was modified 1 month ago by keshav-uses-linux.
      • This topic was modified 1 month ago by keshav-uses-linux.
      #140010
      Member
      abc-nix

        Forget about running hyprland on antiX 23 (with bookworm repos). You need at least to run testing or sid. I run Hyprland on testing.

        But there is an issue now with antiX and testing repos. Because of the chaos in Debian sid, some packages from sid backported to testing make it impossible to upgrade (pipewire 1.0.4-3.0nosystemd1 cannot be installed because of these issues), so you cannot update right now.

        Hopefully the issues in sid will be resolved soon and you can follow an easy path to update to testing/sid. When you do, you can download the packages I built for testing which I use myself to install hyprland on my system.

      Viewing 2 posts - 1 through 2 (of 2 total)
      • You must be logged in to reply to this topic.