ufw bug?

Tagged: 

This topic contains 10 replies, has 6 voices, and was last updated by Yoghi Nov 4-5:00 pm.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #28454
    Member
    macondo
    macondo

    I can’t reproduce the error, did ‘# ufw enable”

    I’m writing from another distro, the ‘Submit’ button does not work in this sub-forum using antiX. Can’t connect to the irc with hexchat. Using antiX Core,

    Intallation went fine, everything went perfect, installed: sudo,nano,xorg, firefox, icewm, menu, xfe, hexchat, ufw, mirage, unclutter, numlockx, mplayer, mpv, alsa-utils, alsa-tools.

    The only problem is the connection to the forum, I can login but not submit the post, other sites worked well.

    Good job on antiX Core installation!!

    • This topic was modified 3 weeks ago by macondo.
    • This topic was modified 3 weeks ago by macondo.
    • This topic was modified 3 weeks ago by macondo.
    #28460
    Member
    Avatar
    PPC

    I’m assuming this is after changing antix Kernel, as per https://www.antixforum.com/forums/topic/enabling-firewall-stops-wifi-network/#post-28451
    I do think this may be the only “deal breaker” for using/upgrading to antiX 19- not being able to use the default firewall out of the box… I usually always have it turned on… but not since I began testing antiX 19 betas… I always thought that would be “fixed” on the final version
    So the only thing that does not work (internet related is the Submit button and hexchat? Did you try turning off the firewall and reload the page and see if the button pooped back up or if hexchat worked? Also are you using firefox-esr? or just “firefox” that you installed?
    No solutions for you, unfortunalty, just some ideas you can test, my friend…

    P.

    #28462
    Member
    macondo
    macondo

    So the only thing that does not work (internet related is the Submit button and hexchat? Did you try turning off the firewall and reload the page and see if the button pooped back up or if hexchat worked? Also are you using firefox-esr? or just “firefox” that you installed?
    No solutions for you, unfortunalty, just some ideas you can test, my friend…
    P.

    Thanks, buddy.

    I can’t turn off the firewall, is not working, cannot enable it, using FF quantum esr

    #28467
    Member
    macondo
    macondo

    I moved to Sid, hexchat works, will see if the Submit button works here…
    my kernel is still 4.9 in Sid, there were no upgrades…
    I uncommented the line for Sid in /etc/apt/sources.list.d/antix.list and commented the original one, did update/dist-upgrade, this is what i get:

    # Use with Debian Stable/buster repositories. Set as default for antiX-19.
    #deb http://mxlinux.mirrors.tds.net/mxlinux/antix/buster/ buster main nonfree
    #deb http://la.mxrepo.com/antix/buster buster main nonfree
    #deb-src http://la.mxrepo.com/antix/buster buster main nonfree

    # Use with Debian Testing/’rolling’ repositories.
    #deb http://la.mxrepo.com/antix/testing testing main nonfree
    #deb-src http://la.mxrepo.com/antix/testing testing main nonfree

    # Use with Debian Sid repositories.
    deb http://la.mxrepo.com/antix/sid sid main nonfree
    #deb-src http://la.mxrepo.com/antix/sid sid main nonfree

    bobo@foo:~
    $ sudo apt-get update
    Hit:1 http://ftp.us.debian.org/debian buster-updates InRelease
    Get:2 http://ftp.us.debian.org/debian buster InRelease [122 kB]
    Hit:3 http://security.debian.org buster/updates InRelease
    Hit:4 http://la.mxrepo.com/antix/sid sid InRelease
    Fetched 122 kB in 4s (29.0 kB/s)
    Reading package lists… Done

    bobo@foo:~
    $ sudo apt-get dist-upgrade
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Calculating upgrade… Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    bobo@foo:~

    what gives?

    • This reply was modified 3 weeks ago by macondo.
    • This reply was modified 3 weeks ago by macondo.
    #28478
    Forum Admin
    Dave
    Dave

    It appears that you have only changed the antiX repository to sid. Perhaps you also were hoping to set the debian repositories to sid?

    If so you must edit the debian list in /etc/apt/sources.list.d/

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #28507
    Member
    macondo
    macondo

    It appears that you have only changed the antiX repository to sid. Perhaps you also were hoping to set the debian repositories to sid?

    If so you must edit the debian list in /etc/apt/sources.list.d/

    Thanks, pal, forgot you have several lists 🙂

    #28913
    Member
    Avatar
    Yoghi

    Hello Macondo,

    are you using ufw 0.36?

    It seems buggy, it doesn’t work if the kernel modules needed aren’t compiled as bult-in but I have still a little to investigate.

    The problem on antiX 19 is due to af_packet, even if loaded with iptables 1.8 ufw fails, it absolutely wants af_packet as a built-in modules.

    Have you tried with ufw disabled?

    Btw. A lot of thanks! You teached me to manage jwm and helped me to find the courage to use it.
    https://forums.freebsd.org/threads/howto-jwm-configuration.59265/ 😀

    Yoghi

    • This reply was modified 1 week, 3 days ago by Yoghi.
    #28918
    Member
    Avatar
    skidoo

    Yoghi, I already replied to your other ufw topic but wanted to respond to this bit

    [ufw 0.36] absolutely wants af_packet as a built-in modules

    I retrieved and inspected the source code for ufw 1.8.2-4 v 0.36-1 (main) [buster] package.
    FWIW, there are zero occurrences of “af_packet” within the source code, and I found nothing to indicate that ufw knows//cares whether the AF_PACKET capability is provided by an internal (vs external) kernel module.

    edit:
    corrected typo (ufw version number)

    • This reply was modified 1 week, 3 days ago by skidoo.
    #28922
    Member
    Avatar
    Yoghi

    Yoghi, I already replied to your other ufw topic but wanted to respond to this bit

    [ufw 0.36] absolutely wants af_packet as a built-in modules

    I retrieved and inspected the source code for ufw 1.8.2-4 (main) [buster] package.
    FWIW, there are zero occurrences of “af_packet” within the source code, and I found nothing to indicate that ufw knows//cares whether the AF_PACKET capability is provided by an internal (vs external) kernel module.

    ufw is release 0.36
    1.8.2-4 is iptables library but you are anyway right, it’s ufw which requires that modules are built-in I explained how I did the check in the other post.

    I’ve already spent three days, if someone would compile an antiX kernel with af_packet as built-in and check if ufw works ootb I will really appreciate his/her effort.

    Thanks

    Yoghi

    #28928
    Forum Admin
    anticapitalista
    anticapitalista

    Try antiX kernel 4.19 or 5.2 series in the repos.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #28973
    Member
    Avatar
    Yoghi

    Try antiX kernel 4.19 or 5.2 series in the repos.

    I’ve already tried and I reported it on linuxquestions where I was sometimes with my old nick before to succeed in solving the trouble with captcha, changing browser, and register here.

    Iptables can work flawlessly also with loaded modules as I discovered here

    But ufw developer stated that the needed modules have to be built-in or nothing, it’s stated in ufw README contained in original source tarball (see attachment).
    It’s a kick in the back to software portability which depends on ufw developer maybe cause they are losing themselves in systemd complexity.

    If you are glad you can read the full thread here I still have an ubuntu account I created some years ago so I take advantage to ask in ufw launchpad list.

    As last thing, thanks, a lot, to skidoo who confirmed that the required modules are not stated by ufw, I have to ask to iptables guys if I’m right and af_packet (not compiled as built-in at least in 4.9.193) is really the missing piece as it seems.

    If I’m right there’s no other way to make ufw works with iptables 1.8 than recompile kernels with af_packet as a built-in or let ufw… sink and look for other.

    I don’t know your opinion but to me is “Code portability first” antiX 4.9.193 has alredy 235 built-in modules against 131 of Debian 10.1.0 standard live 4.19.0 (which I used for the tests and on which ufw works flawlessly ootb) should we include modules never ending only cause they are messed up with systemd?

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.