Unable to edit pdf's with LibreOffice draw

Forum Forums General Software Unable to edit pdf's with LibreOffice draw

  • This topic has 6 replies, 5 voices, and was last updated Dec 29-10:16 am by Anonymous.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4026
    Member
    PPC

      Hi, another day another strange situation with my beloved Antix box:
      I’m not sure if this one is a Antix or a Libreoffice “error”. I usualy us Libreoffice Draw to compress large pdf files (reducing DPI, and stuff like that).

      -What should happen: Usualy (in windows, Mint, lubuntu and xubuntu) I open a file manager, click the pdf I want to compress and open it with Libreoffice draw. Draw imports the file, and I print it to pdf with the desired quality.

      -What happens: when I click on the file and select to open it with draw, it always opens in writer (a mess of ascii characters).

      -What I tried: I checked if Libreoffice pdf importer (I’m not sure if that’s the correct file name) and tried to install it via Synaptic, Even tried to open the pdf file with draw via cli, and it always opens with writer.

      I’m using Antix 16.2 (with the last Libreoffice available in antix installed: Version: 5.2.7.2, Build ID: 1:5.2.7-1~bpo8+1) but this also happens in my antix 17 live USB.

      Any pointers? Also do you know any other good way to compact pdf files in antix? I tried a couple of linux options without success (before converting to antix), that’s why I settled with Libreoffice.

      As always thanks for any input.

      #4030
      Forum Admin
      rokytnji

        While not a expert on what you are doing. I know some pdf files are write protected. No?

        Add Write Protection in Adobe Acrobat. To set permissions to read-only in Adobe Acrobat XI, start by clicking the Tools pane. Open the Protection panel, click “Encrypt,” click “Encrypt With Password” and, when prompted, confirm that you want to add write protection to your document.Mar 31, 2015

        Otherwise. Maybe this link will help

        Sometimes I drive a crooked road to get my mind straight.
        I don't suffer from insanity. I enjoy every minute off it.
        Motorcycle racing is rocket science.

        Linux Registered User # 475019
        How to Search for AntiX solutions to your problems

        #4067
        Anonymous

          roky got that right. If a pdf file is protected by the original writer, you will play heck trying to modify it.

          #4145
          Member
          PPC

            Thanks for the reply, guys, but I belive I was unable to state the true nature of my problem: it has nothing to do with pdf protection. Most of the pdf’d I need to compress using Libreoffice Draw are scanned by me… My problem is that LibreOffice refuses to use open Draw to import a pdf file and even insists on loading Writer even if I try forcing Draw to open the pdf file from the terminal…
            I belive there’s some kind of plugin missing in the LibreOffice version antix uses (and that never happeded to me, across serveral OS, for about 15 years…)

            #4234
            Member
            cyrilus31

              Did you install libreoffice-pdfimport package?
              From what you detailed “I checked if Libreoffice pdf importer (I’m not sure if that’s the correct file name) and tried to install it via Synaptic” it seems to be yes but I had the same issue and after installing this package I can open pdfs in Draw again.

              For an alternative did you try some of the links Skidoo and others gave in the specific topic

              • This reply was modified 6 years, 5 months ago by cyrilus31.
              #4435
              Member
              PPC

                Hi, cyrilus31, thanks for your feedback…
                I had installed libreoffice-pdfimport version 1:4.3.3-2deb8u7 and now, after reading your post, upgraded it to version u9. Still no luck, my pdf’s still open with writer. May I ask wich Libreoffice version are you using?
                I’ll try the Skidoo links as soon as I can.

                EDIT:
                I figured out what is the cause of the problem. It’s really the libreoffice-pdfimport version.
                On my Antix 17 live boot, I went to pkgs.org, read the instructions and followes their how-to:

                Update the package index:

                # sudo apt-get update

                Install libreoffice-pdfimport deb package:

                # sudo apt-get install libreoffice-pdfimport

                And that solved the problem, installing libreoffice-pdfimport version 1:5.5.7-1

                2- On my Antix 16.2, following the same steps only displays a message saying libreoffice-pdfimport is up to date (version 1:4.3.3-2deb8u9).

                So my problem on Antix 16.2 is that the repo’s only have a older version of libreoffice-pdfimport. Any tips how to get a newer version for this distro? (I didn’t upgrade antix on my pc because 16.2 runs smoother than 17…)

                • This reply was modified 6 years, 5 months ago by PPC.
                #4456
                Anonymous

                  You can add debian’s jessie-backports repo to your sources list, then (apt update and) install version 1:5.2.7-1~bpo8+1

                  Another option: install the packaged-as-AppImage version of LibreOffice http://www.libreoffice.org/download/appimage/

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.