(SOLVED) Unable to install LibreOffice language packs on Antix 19.3 (32bit)

Forum Forums Official Releases antiX-19 “Marielle Franco, Hannie Schaft, Manolis Glezos” (SOLVED) Unable to install LibreOffice language packs on Antix 19.3 (32bit)

  • This topic has 7 replies, 5 voices, and was last updated May 2-10:44 am by ModdIt.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #57662
    Member
    FrecklesGFrecklesG

    Hello guys,

    I noticed that Antix 19.3 (32bit) comes with an updated version of LibreOffice 7.0.2.2 (and now upgradable to 7.0.4) Kudos for that 😉

    However, when I tried to install the language pack for Spanish libreoffice-l10n-es apt wouldn’t install it because the l10n pkg available on Antix is version 6.1.5. and it did complain about needing the dependency pkg libreoffice-common of the same version 6.1.5. (libreoffice-common installed is now version 7.0.2.2)

    After doing some research… I managed to successfully install the language pack 6.1.5 on LibreOffice 7.0.2.2 by doing:
    sudo apt download <pkg name>
    sudo dpkg –force-all -i <name of the dwldd pkg here>

    After that I went to LibreOffice Menu: Tools > Options > Language Settings > Language
    and changed the language to Spanish, and miraculously enough LibreOffice changed its interface to Spanish! and it also gave me the option to check grammar in both English and Spanish. I didn’t notice any issues 🙂

    The issue appeared when I tried to install any other app and I was not able to do it because APT said there was a dependency conflict between versions of the Language pack and the libreoffice-common pkg, and it would not proceed until those were fixed, and the only fix was to uninstall the language pack 🙁

    So, could we please have the LibreOffice Language Packs on antiX updated to LibreOffice v7? or is there another workaround?

    Thank you

    • This topic was modified 3 weeks, 4 days ago by Brian Masinick.
    #57673
    Moderator
    AvatarModdIt

    Hi, in the antix package installer you should find language packs for latest LibreOffice not just older
    version. They are under languages entry tab, if not there yet on version changes.
    You can fix the problem with:
    Download a fitting langpack from Libreoffice.org site and install it with apt or dpkg.
    sudo apt install /home/demo/Downloads/yourpackagename.deb Change demo to username.

    • This reply was modified 3 weeks, 5 days ago by ModdIt.
    #57695
    Moderator
    capreacaprea

    Yes, the package installer should help you here and offer the right language-package

    You are getting the error because the latest libreoffice is provided by buster-backports repo.
    So this should work too
    sudo apt install libreoffice-l10n-es/buster-backports

    #57819
    Member
    FrecklesGFrecklesG

    Thank you for your responses, I did try the Package Installer and found the following language pack options:

      Spanish_LO_full

    (*does nothing)

      Spanish_LO_Latest_full

    (this can work but it tries to install several more packages, besides it upgrades the whole LibreOffice suite)

      Spanish_LO_Latest_main

    (this can work but it tries to install several more packages, besides it upgrades the whole LibreOffice suite, although this would install less packages than previous option as it says it doesn’t contain the databases..?)

      Spanish_LO_main (does nothing)

    (*does nothing)

    *When installing these options the package installer just says “Processed Finished!” but if you check, nothing was installed and the checkbox on package is unchecked. Apparently the package installer tries to install the 6.1.5 version of the packages but it doesn’t inform you when there’s a dependency error.

    As per the deb packages, I couldn’t find any for 32bit on the LibreOffice site: https://downloadarchive.documentfoundation.org/libreoffice/old/7.0.2.2/deb/

    So I tried the solution recommended by @caprea
    sudo apt install libreoffice-l10n-es/buster-backports

    And voila! the installation of the language pack went smoothly!

    Thank you ;)!

    PS: is there as way to mark this post as resolved?

    #58388
    Member
    FrecklesGFrecklesG

    Hello guys, just an update on this topic.

    So, I was able to install the language correctly, but then when doing some tests with LibreOffice Writer it started giving me errors when trying to save a document in ODT format.
    it was the following error: Error saving the document General Error General Input/Output error.

    After some research and troubleshooting I was able to find a solution for the ODT error, so I decided to make a video to show how I was able to solve both issues; the LibreOffice ODT error and adding the Language to LibreOffice and as a bonus, I show how to install the offline help documents and enable the synonyms feature in LibreOffice : )

    How to fix LibreOffice ODT Error and Change Language

    I hope this little contribution helps someone having any of these issues with LibreOffice on antiX.

    Regards

    #58393
    Member
    marcelocripemarcelocripe

    Hi FrecklesG,

    Congratulations on the video. The first “jewel”/”positive”/”like” was mine.
    Could you please provide here the text file that you used as a guide in the video containing each step with the commands?

    Thanks.

    marcelocripe
    (Original text in Brazilian Portuguese)

    ———-

    Olá FrecklesG,

    Parabéns pelo vídeo. O primeiro “joia”/”positivo” foi o meu.
    Por favor, você poderia disponibilizar aqui o arquivo de texto que você usou de guia no vídeo contendo cada etapa com os comandos?

    Obrigado.

    marcelocripe
    (Texto original em idioma Português do Brasil)

    #58395
    Member
    Avatarskidoo

    Thanks for producing this well-paced, thorough, tutorial!

    #58427
    Moderator
    AvatarModdIt

    Nice, thanks.
    Lucky I guess, never hit the issues you experienced.
    Only one sometimes bothering has been installation of LanguageTool, (highly recommend)
    that needs java, as does LO Data Base application.
    Java was on some occasions not found. Easiest solution for inexperienced or new user is
    to install the complete version of LO even if not all parts are needed. That pulls in and
    puts the required java in the correct place.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.