Unofficial antiX 23 Frequently Asked Questions

Forum Forums Official Releases antiX-23 “Arditi del Popolo Unofficial antiX 23 Frequently Asked Questions

  • This topic has 24 replies, 5 voices, and was last updated Mar 27-7:28 pm by Brian Masinick.
Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
    Posts
  • #123551
    Moderator
    Brian Masinick

      @PPC

      Yes, that’s right.
      Too bad I have been unavailable, otherwise I could have told you the same thing. Grub is one area of personal expertise because I multi boot most of my systems.

      Grub 2 is a pain in many ways but it does do more than the old Grub.

      GRUB_DISABLE_OS_PROBER=false
      does the trick.

      --
      Brian Masinick

      #128417
      Member
      PPC

        *When updating the system or installing something I get an error about rtl8821cu! How can I solve it?

        Ok, this one is quite easy to solve in most cases, but it requires a small explanation (please note that I’m not an hardware technician):
        Many, many drivers (software that allows pieces of hardware like graphics cards, wireless network chips, etc) are included in the Linux Kernel (the main program that allows the computer to interact with the user and run programs, use the hardware, etc). Many of those drivers are included in Kernels via “dkms” (Dynamic Kernel Module Support).
        This error is caused by the dkms for the driver of the rtl8821cu (realtek wifi chip), that no longer works with the 5.1.X Kernel that antiX includes. The system is just letting you know that particular driver does not work with that kernel. Unless you require that driver to use your wifi connection, it’s perfectly safe to “delete” it. Even if you require that driver to use your wifi connection… well, it’s safe to remove it too, because it’s not working.
        The only problem is that, if you have that particular wifi chip, your wifi won’t work under that kernel.

        So, you have 2 possible solutions:

        A -To “delete” rtl8821cu, simply do this (if your wifi works correctly and you are seeing the “rtl8821cu” error):
        antiX menu > Terminal and type (or copy and paste this command):
        sudo apt-get purge rtl8821cu-dkms
        Press enter to run the command, enter your password if asked to. Wait until the procedure completes. The error message about “rtl8821cu” should no longer appear in the future.
        OR

        B -To use an wifi card that requires rtl8821cu-dkms:
        Probably the best way is installing and using an older Linux kernel, for which that module still works.
        There are several ways of doing that. One of them is using the Package Installer (available from the toolbar by default), on the first Tab, click the “Kernels” option and then select the one you want to install.
        After the kernel is installed, reboot, and on the boot screen select to boot from the kernel you installed. From then on, you should, by default, always boot to that kernel.

        P.

        • This reply was modified 3 months, 1 week ago by PPC.
        • This reply was modified 3 months, 1 week ago by PPC.
        • This reply was modified 3 months, 1 week ago by PPC.
        #129694
        Member
        PPC

          * How do I install Nvidia Drivers?
          Usually, just open the Control Centre, go the the “Drivers” tab and click the button to install the Nvidia driver (you can’t miss it, it has the Nvidia logo, and should be the only button on that tab), following any indications it displays. Enter your password, if asked to.

          If, for any reason that fails to work for you, there’s a nice and detailed tutorial here: https://www.antixforum.com/forums/topic/how-to-install-nvidia-drivers-on-antix/page/2/#post-129551

          #133733
          Member
          pb

            Thank you very much PPC, this not only solved my problem but also helped me to better understand the problem.
            antiX 23 is really excellent.
            And the community is fantastic.
            Have a good day

            pierrebulens

            #134857
            Member
            PPC

              * What is BIOS and what what is UEFI?

              (As always, a disclaimer: I’m not a “computer technician”!)
              That can be answered reading this fine article: https://www.makeuseof.com/tag/why-does-my-motherboard-have-a-battery/ in Short, quoting the relevant parts:

              BIOS (Basic Input/Output System): “When your computer boots up, the BIOS starts up, performs a power-on self-test (POST), and initializes the computer’s hardware (…) then passes control over to a boot loader (…) The boot loader then loads your operating system (…)”.

              UEFI (Unified Extensible Firmware Interface): “introduced to supplant BIOS (…) UEFI improves on BIOS. Due to having its roots in the 1980s (…) era of personal computers, BIOS has some limitations. UEFI overcomes these, adding, for example, support for drives of 2.2TB or larger(…)”.

              BIOS information is stored in volatile memory. This means that it requires constant power in order to keep the information stored, so motherboards with BIOS always, always have batteries to keep BIOS information “alive” in it’s RAM.
              Modern UEFI information is stored in non volatile memory, that does not require constant power in order to keep the information stored, so UEFI does not require a battery. Even so, modern computers with UEFI stored in non volatile memory still usually have a battery. Why? “Simple: Motherboards still include a Real Time Clock (RTC). Power the computer on or off—the battery runs all the time. The real time clock is essentially a quartz watch, like an old wristwatch. When the computer is off, the battery provides power for the real time clock to run. This is how your computer always knows the correct time when you power it on.”

              TIP: How to tell if you booted in UEFI?
              There are several ways. One, that you can try, when running antiX:
              antiX menu > Terminal > run this command:

              inxi -zv8| grep "UEFI:"

              If you get an answer in terminal, it’s because your computer has an UEFI, if you don’t get an answer, it’s because your computer has a BIOS.

              You can even run a mini script to provide a more direct answer (as indicated here https://askubuntu.com/questions/162564/how-can-i-tell-if-my-system-was-booted-as-efi-uefi-or-bios):

              dmesg | grep -q "EFI v"    # -q tell grep to output nothing
              if [ $? -eq 0 ]      # check exit code; if 0 EFI, else BIOS
              then
                  echo "You are using EFI boot."
                else
                  echo "You are using BIOS boot"
              fi

              EDIT: it seems that some models of modern computers can, in fact, have a tiny BIOS and a UEFI.

              P.

              • This reply was modified 1 month, 2 weeks ago by PPC.
              • This reply was modified 1 month, 2 weeks ago by PPC.
              • This reply was modified 1 month, 2 weeks ago by PPC.
              #135104
              Member
              Robin

                * What should I do if zzzFM file manager doesn’t show some files I’m perfectly sure they are present in a folder?

                — If we are talking about hidden files (you can recognise those by the preceding dot the filename starts with), then make sure to right click into the zzzFM pane where the files are listed, and from contextmenu’s submenu ›view‹ check the entry ›hidden files‹. This will bring up those file types in display.

                — If we are talking about files you access on a remote share, in a directory mounted to a local folder, and you miss some files you know to be present there, make sure these have proper file permissions set on the remote machine, so the user running the share on the remote machine can at least read them and traverse all the parent folders (he needs execute permissions set at all parent folders). Otherwise these files will not show up when accessing a share remotely, and as a consequence, not be present in zzzFM when displaying the mounted share in the mountpoint folder locally. You won’t see them by running the ls command on console either.

                — And then, there is an issue with zzzFM. Sometimes, after having used it heavily for file and folder operations, it will simply forget to display some files or subfolders within a folder. When counterchecking the folder content on console by the ls command, the files or subfolders are present and in perfect condition, with proper permissions set and everything. This happens rarely, but I’ve observed it more than once over the years in different antiX versions including latest antiX 23.1 and on different hardware, 32 and 64 bit both, so it’s not a faulty RAM register. If this happens to you, close zzzFM by using its ›exit‹ entry in the file menu, beforehand you may want to tick the box ›Save tabs‹ from the file menu to have back the current tabs you are working in, once zzzFM is reopened again. Wait for it having settled all the cleanup. Then make sure, zzzFM isn’t running anymore in the background (check the output of ps -aux | grep zzzfm | grep -v grep in a terminal window and close down what zzzfm still is up by sending a kill -15 to its pid). Then start zzzFM again, e.g. from the system tray entry or from antiX main menu, and voilà, the formerly missing files and folders are back in all zzzFM tabs and panes. There is no way to get them displayed without this procedure, you may go to another folder, then reopen the folder with the missing files, or refresh the folder content from the refresh icon at the top right, or open the folder in a new tab: Nothing brings them back to display, but a full restart of zzzFM. Be carefully, you might easily overwrite something you can’t see. zzzFM will give you a restrained hint in the line above the name entry fields in the file creation dialog, reading *overwrite existing file, when trying to create a file or folder of the same name, so double check for the presence of this extra fragment in the line, even when no file of this name seems to exist since it is not displayed properly.

                Windows is like a submarine. Open a window and serious problems will start.

                #137816
                Member
                blur13

                  3- Some apps (like Firefox) appearance is not managed either by the Window Manager or the GTK theme. On those apps, you’ll have to find out how to select a dark theme, if one is available, from inside their settings.

                  Setting the theme to “system theme” in Firefox and Chrome will have those browsers respect the GTK theme. So for example, in firefox, go to settings, extensions and themes, themes, system theme -auto

                  #137901
                  Member
                  PPC

                    * How can I restore antiX to it’s default settings?

                    When we try to configure antiX, we tend to change it’s configuration files. When editing any important file, it’s always advisable to MAKE BACK UP COPIES. If you have not done so (I’ve been there, yeah, we all feel dumb when we don’t do that and wreck our systems), there are ways to restore the Window Managers settings to their default values.
                    antiX has a folder called /etc/skel where it stores most of the templates used to create the config files it uses.
                    For example, IceWM’s original configuration files are stored in the hidden folder /etc/skel/.icewm
                    To restore IceWM to it’s default setting all you have to do is copy the contents of that folder to the place where antiX stores IceWM’s configuration files for your user (~/.icewm, where, as explained previously ~/ is the same as typing /home/your_user_name/ or $HOME/ )
                    You can restore IceWM configuration by copying the files that are in the folder /etc/skel/.icewm to the folder ~/.icewm. There are multiple ways you can do that:
                    – you can, using a File Manager, open the original file (in the skel folder) that you want to restore to it’s default value (Ex: toolbar), copy it’s content, and then open your current “toolbar” configuration file, available from antiX Menu > Control Centre > first tab > click the button that referes to editing the config files for window manager (ex: IceWM) > click the tab referring to the configuration file you want to restore (ex: toolbar) > replace it’s current content by deleting it and pasting the content of the configuration file that’s in the “/etc/skel”… folder. Save the change to that configuration file.
                    – you can use a File Manager to copy the configuration file you want to restore to the default value from the “/etc/skel”… folder, to the current configuration folder for your user, replacing it (make sure your File Manager is is configured to display hidden files and folders- you can toggle that on/off, in ZzzFM by pressing CTRL+H)
                    – you can use the terminal to copy the files you want, from the “/etc/skel”… folder to your user’s configuration file’s folder. In case you want to restore all of IceWM’s settings to their default values
                    WARNING: RUNNING THIS COMMAND WILL RESTORE ICEWM TO IT’S DEFAULT SETTINGS:
                    antiX Menu > Terminal > type (or copy and paste this command and then press “enter”. If you paste the command from here to the terminal, make sure to left click the terminal window, to make sure it has focus, before pressing the “enter” key, to run the command)
                    cp -r /etc/skel/.icewm/* ~/.icewm/

                    IMPORTANT NOTE: After replacing your current configuration files, you have to restart your window manager, so the configuration is reloaded. If you don’t know how to do that, you can log off and log back on or reboot your computer. If just replacing the menu file, any change should happen instantly, no need to restart the window manager.

                    You can adapt the procedure explained above to restore the configuration files for JWM, FLUXBOX and even for your bashrc file, etc.

                    How can I restore the Fluxbox Window Manager to it’s default configuration?
                    WARNING: RUNNING THIS COMMAND WILL RESTORE FLUXBOX TO IT’S DEFAULT SETTINGS:
                    antiX Menu > Terminal >
                    cp -r /etc/skel/.fluxbox/* ~/.fluxbox/
                    and restart the window manager/log off and log back on/reboot

                    How can I restore the JWM Window Manager to it’s default configuration?
                    WARNING: RUNNING THIS COMMAND WILL RESTORE JWM TO IT’S DEFAULT SETTINGS:
                    antiX Menu > Terminal >
                    cp -r /etc/skel/.jwm/* ~/.jwm/
                    and restart the window manager/log off and log back on/reboot

                    P.

                    • This reply was modified 2 weeks, 6 days ago by PPC.
                    • This reply was modified 2 weeks, 6 days ago by PPC.
                    • This reply was modified 2 weeks, 6 days ago by PPC.
                    #137934
                    Moderator
                    Brian Masinick
                        *How can I set date & time?

                      Setting date and time can be done using the Control Centre: antiX Menu > Control Centre > “System” tab > Date and Time

                      (Changing the system date and time is important, so, if you have not recently entered you password, you’ll be prompted to do so)

                      A borderless window lists all the options:

                      – set the Current Time
                      – set the Current Date
                      – set the Time Zone
                      – set time and date using a Internet Time server
                      – set the system clock to LOCAL
                      – set the system clock to UTC
                      – the final option is to Quit the set Time and Date window

                      If your Time Zone is correct, usually the best and fastest option is to click the Internet Time server button.

                      Advanced Tip: if you are comfortable using the terminal, the “date” command can be used to set time and date. For more information, please use “man date”

                      IMPORTANT NOTES: Updating the system (using antiX-Updater; Synaptic Package Manager, apt, etc) may require the correct time and date to be set. If it’s off, you may get server errors.

                      Also, modern browsers may stop you from logging on to services (like antiX’s forum) if time and date are not correct.

                      --
                      Brian Masinick

                      #137935
                      Moderator
                      Brian Masinick

                        Changes above suggested by our resident question answering writer, @PPC! 🙂

                        Happy to oblige!

                        --
                        Brian Masinick

                      Viewing 10 posts - 16 through 25 (of 25 total)
                      • You must be logged in to reply to this topic.