Update Error procps (2:3.3.17-7.1nosystemd1) SOLVED

Forum Forums News Sid Upgraders Update Error procps (2:3.3.17-7.1nosystemd1) SOLVED

  • This topic has 2 replies, 2 voices, and was last updated Oct 25-6:55 pm by ModdIt.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #91398
    Member
    ModdIt

      Not so sure what to make of below update error, would wait but posting as nosystemd package involved.
      I Translated from German so error message may/will differ in UK or US english

      Hoping I still get a clean reboot

      procps (2:3.3.17-7.1nosystemd1) being setup …
      Global symbol “$scriptname” requires explicit package name (did you forget to declare “my $scriptname”?) at /usr/sbin/update-rc.d line 399.
      Execution of /usr/sbin/update-rc.d aborted due to compilation errors.
      dpkg: Fehler beim Bearbeiten des Paketes procps (–configure):

      post-installation-Skript of Paket procps«-Underprocess gave Error 1

      • This topic was modified 1 year, 4 months ago by ModdIt.
      #91424
      Forum Admin
      anticapitalista

        There should be a newer version of init-system-helpers that fixes this bug.
        It is already in the antiX repos – maybe the mirrors haven’t caught up yet.

        You need init and init-systemd-helpers version 1.65.2+antix2

        http://repo.antixlinux.com/sid/pool/nosystemd/i/init-system-helpers/

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #91509
        Member
        ModdIt

          @anticapitalista,
          Many thanks for info and fix, installed no errors, other held packages also installed fine.
          Clean reboot.

          The sid antiX rolling remix, mine is with debian kernel and NVidia Tesla 470 drivers makes my
          12 year old device run faster than Bolt. love it.

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.