Update problem regarding conman [solved]

Forum Forums General Software Update problem regarding conman [solved]

  • This topic has 2 replies, 2 voices, and was last updated Sep 16-3:13 pm by orthodox42.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #116965
    Member
    orthodox42

      updating via apt-get update leads to:

      Vorbereitung zum Entpacken von .../connman_1.41-3.0antix1_amd64.deb ...
      Entpacken von connman (1.41-3.0antix1) über (1.40-1.0antix1) ...
      dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/connman_1.41-3.0antix1_amd64.deb (--unpack):
       Versuch, »/etc/apport/crashdb.conf.d/connman-crashdb.conf« zu überschreiben, welches auch in Paket connman-iptables 1.40-1.0antix1 ist
       
      dpkg-deb: Fehler: »einfügen«-Unterprozess wurde durch Signal (Datenübergabe unterbrochen (broken pipe)) getötet
      Fehler traten auf beim Bearbeiten von:
       /var/cache/apt/archives/connman_1.41-3.0antix1_amd64.deb

      apt-get install -f

      doesn’t make any difference

      Can somebody help, please?

      #116968
      Member
      abc-nix

        Hi.
        What version of antiX are you using? Is it antiX 21/22?

        My guess is that the newer connman trying to get installed no longer needs the connman-iptables package. You probably need to remove it first.

        First, make a backup of the new connman package just in case. Run in terminal:
        cp /var/cache/apt/archives/connman_1.41-3.0antix1_amd64.deb $HOME/

        Then, remove connman-iptables
        sudo apt remove connman-iptables

        After that, try installing the new connman again.
        sudo apt install connman=1.41-3.0antix1

        If it cannot install, install it from the copy you made in your home folder
        sudo apt install $HOME/connman_1.41-3.0antix1_amd64.deb

        Once the issue is solved, you can remove the copy of the connman package we saved in your home folder. You can use the file manager, or if using the terminal:
        rm $HOME/connman_1.41-3.0antix1_amd64.deb

        Let us know if something goes wrong.

        • This reply was modified 9 months, 1 week ago by abc-nix. Reason: instructions to remove copy
        #116978
        Member
        orthodox42

          cat /etc/antix-version
          antiX-21_x64-full Grup Yorum 31 October 2021

          Everything worked out well. No more error messages. Thanks a lot!

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.