Upgrading antiX – don’ts

Forum Forums General Tips and Tricks Upgrading antiX – don’ts

  • This topic has 39 replies, 22 voices, and was last updated May 14-5:11 pm by Brian Masinick.
Viewing 15 posts - 16 through 30 (of 40 total)
  • Author
    Posts
  • #97563
    Member
    marcelocripe
      #97564
      Member
      PPC

        I choose to update with the newer files and not to keep the old. In such cases what we choose?

        Please read the threads that Marcelo posted links to (the first one in English, the second one in Portuguese).
        My advice is usually to stick with the default suggestion indicated during the upgrade process (by pressing Enter). In this case, by typing “Y” or the equivalent key in your language to let the updated replaced your old files with the new ones, the templates (models) used to generate the menu and the toolbar to a new user would always be in english (because the updated templates are always in English). If you want your system’s menu and toolbar to be in Greek (and updated to the latest version – that removes any costumization you mande), please adapt the script I posted in the Portuguese Thread (instead of in “pt_BR” or “pt” use the Greek locale code) or try running the (NOT FULLY TESTED) script I posted here: https://www.antixforum.com/forums/topic/the-update-on-01-10-2023-lost-translations-of-the-first-level-menus/page/4/#post-97477.

        When in doubt, I always stick with the default answer, it’s usually the safest

        P.

        • This reply was modified 1 year, 6 months ago by PPC.
        #98869
        Member
        jeffmernier

          Hello Gents,

          Is anybody knowledgeable enough how to dist-upgrade 19.4 to latest-stabled?

          Thanks!

          #100352
          Member
          MarkG_108

            4. Use the Package Installer app first to install popular applications such as google-chrome, wine etc. This app is there for a reason.

            Does that mean I should not use apt in the terminal to install applications? Like, for example, “apt install wine”?

            #100363
            Moderator
            Brian Masinick

              4. Use the Package Installer app first to install popular applications such as google-chrome, wine etc. This app is there for a reason.

              Does that mean I should not use apt in the terminal to install applications? Like, for example, “apt install wine”?

              If you genuinely know what you are doing you may use whatever method you wish. IF you are switched to “root” user privileges and are comfortable using a terminal, yes, you may install applications from the terminal. We’ve recently mentioned that it is a bad idea to switch between different package management programs. So if you use apt, stick with apt. I would say as far as interactive tools, either apt or apt-get are the appropriate tools.

              The Package Installer already includes quite a few popular applications and it takes care of referencing the appropriate sources when it installs software. Wine is available in the Package Installer in the category Misc.

              --
              Brian Masinick

              #100368
              Member
              MarkG_108

                Great. Thanks for the response. As a longtime Debian user, I’m quite comfortable with apt, so I’ll continue to use it.

                IF you are switched to “root” user privileges and are comfortable using a terminal, yes, you may install applications from the terminal.

                One further question: I notice you mention “root” user privileges. In the past when using Debian, I’ve avoided “sudo” set ups, and stuck with having a normal user and a root user. In this recent antiX install, it defaulted to being set up with sudo powers being granted to my normal user. However, I decided to change the password that I had set up for my user. But, in attempting this, I ended up activating the root user (it’s not relevant, but in a later attempt, I subsequently did also change the password of my regular user — so there are two different passwords, one for the regular user and one for the root). Anyway, when updating/upgrading the system and/or installing packages, should I use root and not the sudo set up of my normal user? My assumption is that it wouldn’t really matter, but I figure I should make sure.

                #100370
                Moderator
                Brian Masinick

                  If you are familiar and comfortable to use root, you may do so. There are different groups with considerably different opinions on this matter. As long as you know what you are doing, they all effectively grant you similar access – su, sudo, or directly logging in as root.

                  Some distributions prohibit root login; again, if you understand how they do it, it’s possible to change that behavior, but those distributions (without modification) insist on sudo rather than su, root, or any other means of obtaining privileged access.

                  --
                  Brian Masinick

                  #100383
                  Member
                  MarkG_108

                    they all effectively grant you similar access – su, sudo, or directly logging in as root.

                    Okay, great. Thanks again. I’m quite impressed with antiX.

                    #100384
                    Moderator
                    Brian Masinick

                      antiX has always been a lean, efficient distribution designed to work well on aging equipment.

                      Over the past few years we’ve had forum contributions that attempt to make the overall system easier to use for beginners and also attractive while still keeping the overall effort clean and efficient.

                      The results are encouraging. Those who want complete control of their system can utilize the direct commands to handle applications and system activities. Those who prefer clicking a few menu entries have a good assortment of options too while doing so in a relatively efficient way.

                      --
                      Brian Masinick

                      #100385
                      Forum Admin
                      anticapitalista

                        Just to add that there are some apps in Package Installer that user cannot simply install via ap(get) since such apps come from outside the Debian/antiX repos eg the ‘popular’ client zoom

                        Philosophers have interpreted the world in many ways; the point is to change it.

                        antiX with runit - leaner and meaner.

                        #102826
                        Anonymous

                          I may have discovered a new one. I did the Antix install on a Lenovo T400 laptop perched on a chair, and I have to crouch down uncomfortably to type on it. So I got the IP address from ifconfig and ssh’d in to it sitting comfortably at my Gentoo desktop PC to upgrade apps from the install to the latest. I ran “sudo apt update && sudo apt dist-upgrade” from an xterm on my desktop. What ccould possibly go wrong?

                          Part way through writing .jwm the upgrade died, complaining about “SCREEN”. Re-running it from the laptop keyboard also failed, so something was badly screwed up. I eventually gave up, re-installed, and did the upgrade properly from the laptop keyboard. It works OK now.

                          #102878
                          Moderator
                          Brian Masinick

                            Walter, it’s helpful to sit properly and have a reasonable environment around you. That’s called ergonomics, I think.

                            You can get into antiX many different ways but if you want a graphical user environment, the interface has to provide access. It appears you encountered steps requiring root (privileged) access and the first method you used was denying the display to write the visual response, hence the failure.

                            I’m glad this is resolved.
                            I run into such things occasionally but I’ve never thought to write about them because I know what to change.

                            Thank you very much for raising this, along with your solution.

                            --
                            Brian Masinick

                            #103969
                            Member
                            Ciara

                              thank you . it was very helpful

                              Barcode Label Maker by http://www.barcodelabelmaker.org

                              #105313
                              Member
                              scruffyeagle

                                I have an installation of antiX-21 on an old Dell laptop. It’s had the problem of conky getting wiped off the screen, as soon as the Veracrypt window closes. (This problam hasn’t occurred in my installations of antix-19 &/or antix-22.) I was hoping to avoid doing a full install of antiX-22, and thought that perhaps doing an upgrade from a21 to a22 would fix it…

                                I used the code “sudo apt update && sudo apt dist-upgrade” in a terminal.

                                Afterward, I used “inxi -Fxxxrz” to verify whether or not the installation had been upgraded. It appears as if it was NOT, because the OS is still being reported as “antix-21_x64-full”, and the problem with conky being wiped off the screen is still continuing.

                                Here’s the output of “inxi -Fxxxrz”:
                                —————————————-

                                $ inxi -Fxxxrz
                                System:
                                Kernel: 5.10.57-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc
                                v: 10.2.1 Desktop: IceWM v: 3.3.3 vt: 7 dm: slimski v: 1.5.0
                                Distro: antiX-21_x64-full Grup Yorum 31 October 2021 base: Debian
                                GNU/Linux 11 (bullseye)
                                Machine:
                                Type: Portable System: Dell product: Precision M6300 v: N/A
                                serial: <superuser required> Chassis: type: 8 serial: <superuser required>
                                Mobo: Dell model: 0JM680 serial: <superuser required> BIOS: Dell v: A14
                                date: 12/06/2011
                                Battery:
                                ID-1: BAT0 charge: 37.3 Wh (100.0%) condition: 37.3/73.3 Wh (50.9%)
                                volts: 12.4 min: 11.1 model: PS2 DELL 00 type: Li-ion serial: <filter>
                                status: full
                                CPU:
                                Info: dual core model: Intel Core2 Duo T7250 bits: 64 type: MCP
                                smt: <unsupported> arch: Core2 Merom rev: D cache: L1: 128 KiB L2: 2 MiB
                                Speed (MHz): avg: 1545 high: 1880 min/max: 800/2001 boost: enabled cores:
                                1: 1880 2: 1210 bogomips: 7977
                                Flags: ht lm nx pae sse sse2 sse3 ssse3
                                Graphics:
                                Device-1: NVIDIA G84GLM [Quadro FX 1600M] vendor: Dell driver: nouveau
                                v: kernel arch: Tesla pcie: speed: 2.5 GT/s lanes: 16 ports: active: LVDS-1
                                empty: DVI-D-1,VGA-1 bus-ID: 01:00.0 chip-ID: 10de:040d class-ID: 0300
                                temp: 71.0 C
                                Display: x11 server: X.Org v: 1.20.11 driver: X: loaded: modesetting
                                unloaded: fbdev,vesa dri: nouveau gpu: nouveau display-ID: :0.0 screens: 1
                                Screen-1: 0 s-res: 1400×900 s-dpi: 96 s-size: 369x237mm (14.53×9.33″)
                                s-diag: 439mm (17.27″)
                                Monitor-1: LVDS-1 model: Seiko Epson 0x3155 res: 1400×900 hz: 60 dpi: 97
                                size: 367x230mm (14.45×9.06″) diag: 433mm (17.1″) modes: max: 1920×1200
                                min: 640×350
                                API: OpenGL v: 3.3 Mesa 20.3.5 renderer: NV84 direct-render: Yes
                                Audio:
                                Device-1: Intel 82801H HD Audio vendor: Dell driver: snd_hda_intel v: kernel
                                bus-ID: 00:1b.0 chip-ID: 8086:284b class-ID: 0403
                                Sound API: ALSA v: k5.10.57-antix.1-amd64-smp running: yes
                                Network:
                                Device-1: Broadcom NetXtreme BCM5756ME Gigabit Ethernet PCI Express
                                vendor: Dell driver: tg3 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: N/A
                                bus-ID: 09:00.0 chip-ID: 14e4:1674 class-ID: 0200
                                IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter>
                                Drives:
                                Local Storage: total: 1.2 TiB used: 301.68 GiB (24.5%)
                                ID-1: /dev/sda vendor: Western Digital model: WD3200BPVT-75JJ5T0
                                size: 298.09 GiB speed: 3.0 Gb/s type: HDD rpm: 5400 serial: <filter>
                                rev: 1A03 scheme: MBR
                                ID-2: /dev/sdb type: USB vendor: Western Digital
                                model: WD My Passport 0748 size: 931.48 GiB type: N/A serial: <filter>
                                rev: 1019 scheme: MBR
                                Partition:
                                ID-1: / size: 38.15 GiB used: 9.62 GiB (25.2%) fs: ext4 dev: /dev/sda6
                                Swap:
                                ID-1: swap-1 type: partition size: 9.77 GiB used: 0 KiB (0.0%) priority: -2
                                dev: /dev/sda5
                                Sensors:
                                System Temperatures: cpu: 61.0 C mobo: N/A sodimm: SODIMM C gpu: nouveau
                                temp: 71.0 C
                                Fan Speeds (RPM): cpu: 0
                                Repos:
                                Packages: pm: dpkg pkgs: 1978
                                No active apt repos in: /etc/apt/sources.list
                                Active apt repos in: /etc/apt/sources.list.d/antix.list
                                1: deb http://mirrors.rit.edu/mxlinux/mx-packages/antix/bullseye bullseye main nosystemd nonfree
                                Active apt repos in: /etc/apt/sources.list.d/bullseye-backports.list
                                1: deb http://deb.debian.org/debian bullseye-backports main contrib non-free
                                Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
                                1: deb http://ftp.us.debian.org/debian/ bullseye-updates main contrib non-free
                                Active apt repos in: /etc/apt/sources.list.d/debian.list
                                1: deb http://ftp.us.debian.org/debian/ bullseye main contrib non-free
                                2: deb http://security.debian.org/ bullseye-security main contrib non-free
                                No active apt repos in: /etc/apt/sources.list.d/various.list
                                Info:
                                Processes: 164 Uptime: 1h 21m wakeups: 2 Memory: 3.84 GiB
                                used: 726.6 MiB (18.5%) Init: SysVinit v: 2.96 runlevel: 5 default: 5
                                Compilers: gcc: 10.2.1 alt: 10 Shell: Bash v: 5.1.4 running-in: roxterm
                                inxi: 3.3.25
                                spirit@M6300A214:~
                                $

                                #105326
                                Member
                                Xunzi_23

                                  the OS is still being reported as “antix-21_x64-full”, That is normal as the version which was initialy installed is kept.

                                  Conky dissapearing is probably an older issue. Thread is in the depths of the forum. Link below.
                                  https://www.antixforum.com/forums/topic/conky-not-showing/#post-90668

                                  Perhaps helpful to see if your conky rc is beginning as below.
                                  # set to yes if you want Conky to be forked in the background
                                  background yes

                                  short_units yes

                                  cpu_avg_samples 1
                                  net_avg_samples 1

                                  out_to_console no

                                  # X font when Xft is disabled, you can pick one with program xfontsel
                                  #font 7×12
                                  #font 6×10
                                  #font 7×13
                                  font 8×12
                                  #font 7×12

                                  # Use Xft?
                                  use_xft yes

                                  # Xft font when Xft is enabled
                                  #xftfont gentium:size=12
                                  #ftfont DejaVu Sans:size=10
                                  xftfont DejaVu Sans:bold:size=9
                                  #xftfont DejaVu Sans:size=9

                                  # Create own window instead of using desktop (required in nautilus, pcmanfm and rox desktops)
                                  own_window yes
                                  own_window_transparent yes
                                  own_window_hints undecorated,below,sticky,skip_taskbar
                                  own_window_type normal

                                  # Text alpha when using Xft
                                  xftalpha 1.0

                                  #on_bottom no

                                  # Update interval in seconds
                                  update_interval 1

                                  # Use double buffering (reduces flicker, may not work for everyone)
                                  double_buffer yes

                                  • This reply was modified 1 year, 2 months ago by Xunzi_23.
                                Viewing 15 posts - 16 through 30 (of 40 total)
                                • You must be logged in to reply to this topic.