URL opening in Geany, not the browser

Forum Forums New users New Users and General Questions URL opening in Geany, not the browser

  • This topic has 3 replies, 3 voices, and was last updated Jun 16-7:48 pm by Splined.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #23114
    Member
    SplinedSplined

    So, this seems like it should have an answer somewhere in the forum, but I haven’t been able to find anything relevant.
    I just installed Python Anaconda and it is working fine *except* when I try to open a notebook. This should open in the default browser, but it opens in Geany instead. The url will be something like </home/splined/.run/jupyter/nbserver-229774-open.html> I can manually type this into the browser and it will open just fine, but obviously a pain.
    in the control centerI have checked
    * Preferred Applications
    ** Web Browser: firefox-esr.desktop
    and
    * Alternatives Configurator
    ** www-browser: /usr/bin/links2
    ** x-www-browser: /usr/bin/firefox-esr

    which both seem reasonable.
    Is there some other setting I am missing?

    Regards,
    Splined

    Antix 17.2
    rox-fluxbox
    Persist Root Enabled

    #23120
    Forum Admin
    anticapitalistaanticapitalista

    You might need to edit ./config/mimeapps.list

    Have a look at arch wiki – https://wiki.archlinux.org/index.php/Xdg-utils

    • This reply was modified 1 year, 3 months ago by anticapitalista. Reason: typo fixed

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #23142
    Member
    Avatarskidoo

    The url will be something like </home/sp…

    In my book, that’s not a URL (it lacks a scheme).
    It is a file path (or, depending on who ya ask, a network-path reference)

    Anyhoo, for the jupyter commandline command, you should not need to supply a “url”.

    how-do-i-get-help-about-notebook-server-options
    setting-up-anaconda-and-jupyter-notebook-on-gnu-linux/
    https://github.com/jupyter/notebook/issues/4304

    https://jupyter-notebook.readthedocs.io/en/stable/config.html

    The notebook server can be run with a variety of command line arguments. A list of available options can be found below in the options section. Defaults for these options can also be set by creating a file named jupyter_notebook_config.py in your Jupyter folder. The Jupyter folder is in your home directory, ~/.jupyter

    To create a jupyter_notebook_config.py file, with all the defaults commented out, you can use the following command line:
    $ jupyter notebook –generate-config

    Options

    [..]

    NotebookApp.browser : Unicode
    Default: ”

    Specify what command to use to invoke a web browser when opening the notebook.
    If not specified, the default browser will be determined by the [python] webbrowser standard library module, which allows setting of the BROWSER environment variable to override it.

    #23160
    Member
    SplinedSplined

    Should have mentioned I was launching the notebook from the anaconda-navigator interface, not the cli.

    anticaptialista: I added the line “text/html=firefox-esr.desktop” to the mimeapps.list file and that seems to do the trick. Now launches the browser. Thanks for the info on xdg-utils, very handy.

    skidoo: You’re right. As noted above, it isn’t a url but a txt/html file.
    That github issue looks exactly on point. I just started messing with anaconda, so I’m sure I’ll be doing a lot of reading/tweaking with that setup guide.

    Only two things are infinite. The universe and my ignorance of Linux.

    Thanks again,
    splined

    • This reply was modified 1 year, 3 months ago by Splined.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.