USB drives not auto mounting

Forum Forums Official Releases antiX-16 “Berta Cáceres” USB drives not auto mounting

This topic contains 4 replies, has 4 voices, and was last updated by seaken64 Jan 28-11:00 pm.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #17703
    Member
    Avatar
    seaken64

    I have antiX-16.3 installed and if I have a USB drive in the USB hub when I boot up the USB drive gets mounted and I can read and write to it using SpaceFM and I can use the litle icon next to the start button to unmount ands remove the drive.

    But when I plug the drive back in I can not get it mount. I can’t even find it in the devices list. If I reboot the system the drive comes back. If I plug in another USB drive, a new drive, it does not get recognized. I cannot mount a USB drive on the fly.

    What am I missing? Is there a program I should be using? How do I find out if antiX-16 should be auto-mounting a driove upon insertion? The conky says auto mount is active.

    Seaken64

    #17704
    Member
    Avatar
    BobC

    I don’t have a 16.3 system to check, but in my 17.3 control centre, on the disks tab, there is a button to configure automounting. I would check there first. In my version it can be set to override the spacefm setting or not. Mine is set to Automount External Devices, and Do not change Spacefm Automount settings is not checked.

    Spacefm also has its own automount configuration under Devices, Settings, Automount. Mine is set to Mount Removable

    Hope that helps. If that doesn’t solve it, you will need help from someone more knowledgeable.

    PS: in Spacefm on mine you need to be in a Root window to manually mount or unmount devices.

    • This reply was modified 2 months, 3 weeks ago by BobC.
    #17711
    Member
    Avatar
    skidoo

    IIRC rox-filer, not spaceFM, is the default file manager and the conky output reflects the rox automount policy.

    spaceFM follows a separate set of preferences, found here:
    spaceFM }} Devices }} Settings }} AutoMount }} Removable

    Although the above setting (on my antiX 17 live system) is tickmarked, mounting by non-sudo user is prohibited due to my bootmenu (or bootline) election which stipulates “noautomount”.

    But when I plug the drive back in I can not get it mount. I can’t even find it in the devices list. If I reboot the system the drive comes back. If I plug in another USB drive, a new drive, it does not get recognized. I cannot mount a USB drive on the fly.

    What am I missing?

    I hear ya ~~ it’s confusing. What you are probably “missing” is a raft of antiX17 amenities, including an automounts manager GUI utility accessible via the ControlCentre.

    Here’s a video which explains how to accomplish smooth automounting on an older version antiX system: https://www.youtube.com/watch?v=MBLaevalf7Y

    #17894
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    it is very possible that the hub is not the hotplug signal when devices are plugged in or that its being mis-interpreted by udev. have you tried inserting your usb directly into a usb port on your PC?

    • This reply was modified 2 months, 3 weeks ago by dolphin_oracle.
    #18029
    Member
    Avatar
    seaken64

    I watched the video. I had seen that before so I knew something wasn’t setup right. But it turned out to be as dolphin_oracle suggested. I put a USB stick directly into the USB port and it came right up. It was mounted and displayed in Rox. I unmounted it and plugged in an extension and tried it again. It works with the extension.

    So, I can’t use this hub and I’ll have to use the extension for now. The port is on the back of the computer and it’s on a shelf. It’s a pain to reach the port on the back of the computer.

    But now I know what I was missing. I will experiment with some other hubs to see if any other hubs work for the hotplug.

    Thank you for the help.
    Seaken64

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.