USBLive – Why is it not possible to get the right keyboard directly for Belgium?

Forum Forums New users New Users and General Questions USBLive – Why is it not possible to get the right keyboard directly for Belgium?

  • This topic has 25 replies, 4 voices, and was last updated Feb 3-10:32 pm by skidoo.
Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #51306
    Member
    AvatarWallon

    Dear developers,

    In Belgium, there are 3 official languages, Dutch, French and German.The official keyboard is Belgian Azerty for the 3 languages.
    The Belgian Azerty keyboard is different from the French Azerty keyboard!

    I do the following tests;

    F2 Language : fr_BE (French)
    F3 Timezone: Auto
    The keyboard becomes Querty US. This is not the right keyboard!

    F2 Language : nl_BE (Dutch)
    F3 Timezone: Auto
    The keyboard becomes Querty US. This is not the right keyboard!

    F2 Language: de_BE (German). This option does not exist! Why not?
    F3 Timezone : Not possible to test with the “Auto” option or Berlin (Language = German) which has the same time as Belgium.

    F2 Language : fr_BE (French)
    F3 Timezone : Brussels does not exist ! Why does it not exist? I take Paris (Language = French) which has the same time as Belgium.
    The keyboard becomes Querty US. It’s not the right keyboard!

    F2 Language : nl_BE (Dutch)
    F3 Timezone : Brussels does not exist ! Why does it not exist? I take Amsterdam (Language = Dutch) which has the same time as Belgium.
    The keyboard becomes Querty US. It’s not the right keyboard!

    If I want to change my keyboard by the control center I have to type the password “demo”. But this doesn’t work with a Belgian Azerty keyboard. You have to type “de?o” with a Belgian Azerty keyboard. You have to replace the key “m” by the key “?”. This is not mentioned in the FAQ or the Antix manual.

    Wouldn’t it be easier to put a Timezone “Brussels” and link a Belgian Azerty keyboard directly?

    For information, the translation of Brussels in English is in;
    -> French: Bruxelles,
    -> German: Brüssel,
    -> Dutch: Brussel.

    Thank you for the attention you will give to my request because the installation of AntiX is not obvious for a new user.

    Best regards,
    Wallon
    (Belgium)

    #51308
    Forum Admin
    anticapitalistaanticapitalista

    Maybe you should try an ‘easier’ distro like Ubuntu?

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #51309
    Forum Admin
    anticapitalistaanticapitalista

    Wouldn’t it be easier to put a Timezone “Brussels” and link a Belgian Azerty keyboard directly?

    (Belgium)

    We only have so much space on the live menu. If we added all the languages and timezone cities, just think how awful that menu would look.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #51310
    Forum Admin
    anticapitalistaanticapitalista

    Post the output (running live) of /var/log/live/live-init.log

    fr_BE gives me an azerty keyboard (be2-latin1)

    
    Tue Feb  2 07:26:37 EST 2021  /live/etc/init.d/live-L10n
    live-L10n: Régionalisation de la console et du fuseau horaire
      Erreur: Fuseau horaire inconnu Brussels/Europe
      Configuration de la locale sur fr_BE.UTF-8
      Configuration de la console pour un clavier be2-latin1
    
      Réglage de xkb-layout sur be,fr,us

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #51311
    Member
    XecureXecure

    WARNING: The flag in the system tray ONLY changes from US flag the first time you start typing with the keyboard.

    It took me ages to write these tables in the wiki:
    https://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters#Live_Session_Personalization
    be-language-antix-wiki
    Expand the boxes.
    I just tested with
    lang=fr_BE -> Belgian Azerty keyboard was working (I opened a “Éditeur” and started writing. Seems the azerty keyboard worked properly, and the flag in systray changed)
    lang=nl_BE -> Belgian Azerty keyboard was working (I opened a “Editor” and started writing. Seems the azerty keyboard worked properly, and the flag in systray changed)

    Other possibilities (the one I use for my language when booting antiX, so I don’t have my interface change language and only my keyboard changes language):
    kbd=be
    You can also read in the wiki article other live boot parameters (there are still a lot missing) used in antiX.

    If there is something wrong, let the devs know.

    • This reply was modified 2 months, 1 week ago by Xecure. Reason: add image
    #51321
    Member
    AvatarWallon

    OK, this is a good tip and trick. Open an editor and press some keys. The flag in systray becomes Belgian Azerty keyboard. All is perfect.
    Thank you very much.
    I don’t know Ubuntu. I’m going to test it.
    This is very kind of you.

    #51332
    Member
    Avatarskidoo

    The flag in the system tray ONLY changes from US flag the first time you start typing with the keyboard.

    What is the name of the program responsible for drawing the tray icon. If this is a bug, maybe we can patch it (or at least report the bug to the upstream maintainer)

    If multiple utilities are involved, maybe the control center utility just needs an added wrapper ~~ kill/relaunch the tray utility after each usage of the kbswitcher utility.

    #51351
    Member
    XecureXecure

    What is the name of the program responsible for drawing the tray icon.

    Package: fbxkb
    Version: 0.6-2.8
    Priority: standard
    Section: main
    Maintainer: anticapitalista <antiX@operamail.com>
    Installed-Size: 5,703 kB
    Depends: libc6 (>= 2.7), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.24.0), libx11-6
    Homepage: http://fbxkb.sourceforge.net
    Download-Size: 5,296 kB
    APT-Manual-Installed: yes
    APT-Sources: https://ftp.caliu.cat/pub/distribucions/mxlinux/MX-Packages/antix/buster buster/main amd64 Packages
    Description: X11 keyboard indicator and switcher
     It shows a flag of current keyboard in a systray area and
     allows you to switch to another one. It's written in C and
     uses the GTK+2.4 library only (no GNOME is needed).
    #51362
    Member
    AvatarWallon

    I did some more tests.

    Language F2 = fr_BE
    The flag in the systray is in US Querty.
    I click on the flag. Nothing changes, it remains on Querty US.
    I want to take a screenshot, the flag immediately changes to Belgian Azerty.
    With the mouse, I click again on the flag. It changes into French flag, then into US flag and then into Belgian flag.
    Conclusion, I have to use at least one key on the keyboard (editor, screen print…) for the flag in the systray to wake up, to activate.
    But if I want to work with an English version (F2 Language UK or US), on a Belgian computer, I have to go to the control center and type the password “de?o”.
    Still with F2 Language UK or US, I tried to use the boot options (lang=fr_BE). But antix is configured in querty ! Here is for example the boot options typed with my Belgian keyboard (lqng/fr+BE). So it is not possible to type with my Belgian keyboard in the boot options.
    Do you have a solution to work with an English version on a Belgian pc ? As you know, I use an English version on one pc to compare it with the French version on another pc.

    #51363
    Forum Admin
    anticapitalistaanticapitalista

    The default live system for fr_BE sets up 3 language options.

    1. The default is be, but it only shows up as the be flag once you use the keyboard
    2. After 1, you can click on the flag to toggle between be, fr and us.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #51366
    Member
    AvatarWallon

    I’m on a USB Live in English.
    Timezone = Auto
    There is no flag in systray. I don’t know why?

    First possibility;
    1) Icon Favorite Applications,
    2) Control Centre,
    3) System,
    4) Icon “Set System Keyboard Layout”
    It asks me the password “demo”, but I can’t type it with my Belgian keyboard. The good password is on my keyboard “de?o”.

    Second possibility;
    1) Icon Favorite Applications,
    2) Control Centre,
    3) Session,
    4) Icon “Change Keymap for Sessions”
    I choose Belgium, option Belgian, Apply. It doesn’t ask me for the password “demo”. I can work with an English version on a Belgian computer for the session.

    #51367
    Member
    Avatarskidoo

    @Xecure
    I’ve tweaked it to also call update_flag() in response to XkbMapNotify events, but I am unable to test.
    64bit debfile for testing on antiX19 here if you care to test https://gitlab.com/antix-skidoo/fbxkb

    #51394
    Member
    XecureXecure

    Thanks, skidoo.
    I just tested the new package in an installed system and still the first flag displayed is US flag (even if no US keyboard was set). I need to hit a key for the flag to automatically change. Same behavior as before.
    I wouldn’t worry too much about it. There aren’t that many people that use multiple keyboards, and after hitting any key the flag changes appropriately. If someone presses a key they will immediately realize their keyboard is properly set.

    #51395
    Member
    XecureXecure

    @Wallon
    If you had read my other post or the wiki link I provided, you would have discovered a boot parameter
    kbd=<keyboard-layout-code>
    If you use
    kbd=be
    No matter the language you set, the keyboard layout will be set using the kbd= boot parameter, ignoring the language setting.

    From the wiki I seem to be only writing for myself (ironic)

    The lang=<language-code> boot option will let you change the language of the live system and the proceding boot messages. It will also change the keyboard layout and the timezone to one that matches the language selected (and also the repo mirror to the closest to said timezone). You can override these keyboard and timezone selections with the boot parameters kbd=<keyboard-layout> and tz=<time-zone> to specify the ones you want to use instead.

    • This reply was modified 2 months, 1 week ago by Xecure. Reason: fix format
    #51398
    Member
    AvatarWallon

    Concern: USB Live – Antix Full 19.3 64bits – English US – Timezone = Auto

    Please find detail of /var/log/live/live-init.log

    Wed Feb 3 05:28:27 EST 2021 /live/etc/init.d/live-usb-save
    live-usb-save: Restore state information
    Restore machine specific state file /etc/adjtime
    Restore machine specific state file /etc/default/numlockx
    Restore machine specific state file /etc/udev/rules.d/70-persistent-net.rules
    Restore machine specific state file /var/lib/alsa/asound.state
    Restore machine specific state file /var/lib/connman/ethernet_4ccc6a4ad99a_cable/data
    Restore machine specific state file /var/lib/connman/ethernet_4ccc6a4ad99a_cable/settings
    Restore machine specific state file /var/lib/connman/settings

    Wed Feb 3 05:28:28 EST 2021 /live/etc/init.d/live-init
    live-init: Localizing/configuring X-Windows
    Load microcode
    Creating issue file for antiX 19.3 (Manolis Glezos) 64-bit
    make-fstab: Create new /etc/fstab
    make-fstab: Put 6 hard drive entries into /etc/fstab
    make-fstab: Put 1 removable entry into /etc/fstab
    Scanning for hardware specific video modules ...
    Found KMS video module(s) nouveau
    Found default user demo
    Populating /home/demo directory

    Wed Feb 3 05:28:31 EST 2021 /live/etc/init.d/live-disable-services
    live-disable-services: Customizing services
    Disabling Virtual Box service
    Disabling some services (L, lean)
    Disabling more services (X, Xtralean)

    Please find a screenshot – there isn’t a flag in systray.

Viewing 15 posts - 1 through 15 (of 26 total)
  • You must be logged in to reply to this topic.