video better in v16 than in v17?

Forum Forums New users New Users and General Questions video better in v16 than in v17?


  • This topic has 11 replies, 5 voices, and was last updated Jan 21-1:30 pm by masinick.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #9268

    Hi all you antiXers. I have been doing some trials on my old Pentium-III box this weekend and have hit a wall. I am reading up on how video outputs and drivers work in Linux and Debian. I’ve got a lot to learn!

    I have a question about how video card drivers and the kernel and Xorg all fit together in a distro like antiX. I’m not quite sure yet how to form the question. Maybe I should start with how I became confused on this topic to begin with.

    I have antiX-16 working on this P-III just fine. I have SMTube installed and it plays youtube video with either SMPlayer or VLC. It works fine (For an old computer anyway). The video card is a GeForce2 MX200 and the driver module installed is “nouveau”. The Kernel I think is 4.3? Xorg is at 1.16? Can’t remember exactly right now.

    I have been trying to finish setting up antiX-17 on this old box and to my surprise SMTube and SMPlayer were not working. I kept getting an “oops, something went wrong” error. I did some digging and found the video driver was set as “vesa” and I can not change the screen resolution using xrandr. So something is wrong with the video driver. I traced the video settings to having used the “failsafe” mode to start the live DVD/USB I used to install this version 17. My Grub start line had a VGA=791 and nomodeset.

    I removed the nomodeset parameter in the grub config and rebooted. The video driver now says “fbdev, nouveau” when I look at inxi. I installed VLC and I got it to work with SMTube using the “X11” video output. My openGL renderer says “Gallium 0.4 on llvmpipe”. I’ve done some reading and this appears to be the driver for the latest nouveau.

    But here’s my question. Why is video worse in version 17 than it is in version 16? Shouldn’t things get better with the newer version?

    Okay, maybe that’s not the question. I’m not sure what is happening here. I know that this old nvidia graphics card is no longer supported and that I am supposed to use nouveau for these old cards. But the nouveau driver in version 16 is better than in version 17? Why? Or is it the same and it is something else? The kernel? Xorg?

    I don’t understand why youtube video plays so nicely in version 16 but so choppy and slow on version 17. The hardware is the same.

    Thanks for your help,


    Usually everything gets better, but sometimes something goes wrong. 🙂

    I would see if the old driver will work under 17, if it were me having this trouble.

    The best bet, when about to install to disk, is to set everything up when running ‘live’ & keep all the changes, that way your new system will be as good as when you tested the distro.

    Linux (& BSD) since 1999

    Forum Admin

    Newer Xorg is not supporting a lot of old computer video chips anymore. My savage chip on my IBM T23 is a good example of this current situation. I have to roll with vesa to get a desktop. All my posts on this were on the old forum on the Beta AntiX 17 threads.

    Bitjam and others listened to my beta tests.

    Newer software does not mean better when dealing with obsolete computer hardware. Because they leave out stuff they think no body uses anymore. That boot cheat code was put there for gear like mine so one could get to a desktop.

    Newbies with old gear need that bootcode. So I guess, Be glad it is there.

    • This reply was modified 2 years, 5 months ago by rokytnji.

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    I'm not outa place. I'm from outer space.

    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

    Forum Admin

    PS. AntiX 16 uses a older version of xorg. Comprende? Because one is Jessie. The other is Stretch.
    To clarify a little better. A old IBM 390E would probably run better on some old puppy 3.0 version or AntiX version 6 or 7. Than a modern operating system that ignores that type of gear now. So newer does not mean better.

    Just teaching you since you are asking. One expects to work harder when reviving older computers. Now this one. So Far. Is not as picky as my IBM T23. It don’t care what I throw at it.

    $ inxi -zv8 -y85
      Host: biker Kernel: 4.9.83-antix.1-686-smp-pae i686 bits: 32 compiler: gcc 
      v: 4.9.2 Desktop: IceWM 1.3.8 dm: slim 
      Distro: antiX-15-V_386-full Killah P 30 June 2015 
      Type: Laptop System: LENOVO product: 2347DS2 v: ThinkPad T430 serial: N/A 
      Chassis: type: 10 serial: N/A 
      Mobo: LENOVO model: 2347DS2 serial: N/A UEFI [Legacy]: LENOVO v: G1ET41WW (1.16 ) 
      date: 05/25/2012 
      ID-1: BAT0 charge: 20.0 Wh condition: 20.0/56.2 Wh (36%) volts now/min: 12.4/10.8 
      model: SANYO 45N1001 type: Li-ion serial: <filter> status: Full 
      RAM Report: permissions: Unable to run dmidecode. Are you root? 
    PCI Slots:
      Permissions: Unable to run dmidecode. Are you root? 
      Topology: Dual Core model: Intel Core i5-3320M type: MT MCP arch: Ivy Bridge 
      rev: 9 L2 cache: 3072 KiB bogomips: 20753 
      Speed: 1882 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1882 2: 1449 3: 2758 
      4: 3159 
      Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov 
      constant_tsc cx16 cx8 de ds_cpl dtes64 dtherm dts eagerfpu epb ept erms est f16c 
      flexpriority fpu fsgsbase fxsr ht ida lahf_lm lm mca mce mmx monitor msr mtrr 
      nonstop_tsc nx pae pat pbe pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pts 
      rdrand rdtscp sep smep smx ss sse sse2 sse4_1 sse4_2 ssse3 tm tm2 tpr_shadow tsc 
      tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr 
      Card-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
      bus ID: 00:02.0 chip ID: 8086:0166 
      Display Server: X.Org 1.16.4 driver: intel unloaded: fbdev,modesetting,vesa 
      resolution: 1600x900~60Hz 
      OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile x86/MMX/SSE2 v: 3.3 Mesa 10.3.2 
      compat-v: 3.0 direct render: Yes 
      Card-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
      v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
      Sound Server: ALSA v: k4.9.83-antix.1-686-smp-pae 
      Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e v: 3.2.6-k 
      port: 5080 bus ID: 00:19.0 chip ID: 8086:1502 
      IF: eth2 state: down mac: <filter> 
      Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel 
      bus ID: 03:00.0 chip ID: 8086:0085 
      IF: wlan0 state: up mac: <filter> 
      IP v4: <filter> scope: global broadcast: <filter> 
      IP v6: <filter> scope: link 
      WAN IP: <filter> 
      HDD Total Size: 298.09 GiB used: 74.48 GiB (25.0%) 
      ID-1: /dev/sda model: HGST_HTS545032A7 size: 298.09 GiB serial: <filter> 
      rev: AC90 scheme: MBR 
      Optical-1: /dev/sr0 vendor: Optiarc model: DVD RW AD-7740H rev: 1.S1 
      dev-links: cdrom,cdrw,dvd,dvdrw 
      Features: speed: 24 multisession: yes audio: yes dvd: yes 
      rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
      Message: No RAID data was found. 
      ID-1: / size: 7.56 GiB used: 5.25 GiB (69.4%) fs: 7.8g dev: /dev/sda1 
      label: antiX15root uuid: 685d85b2-6651-49ed-928c-d5e17f70f500 
      ID-2: /home size: 67.16 GiB used: 3.04 GiB (4.5%) fs: 68.4g dev: /dev/sda2 
      label: antiX15home uuid: 8d150b09-c903-4b7d-9326-7b88e7ac84f2 
      ID-3: /media/_data1 size: 118.34 GiB used: 46.61 GiB (39.4%) fs: 120.4g 
      dev: /dev/sda5 label: /data1 uuid: 8c692b69-46f7-48ef-abc9-e6963655e259 
      ID-4: /media/_data2 size: 96.00 GiB used: 19.59 GiB (20.4%) fs: 97.7g 
      dev: /dev/sda6 label: /data2 uuid: b76696e8-11ba-4177-970b-0d237aa5a8ae 
      ID-5: swap-1 size: 3.91 GiB used: 0 KiB (0.0%) fs: 3.9g dev: /dev/sda3 label: N/A 
      uuid: 45720f5c-3d28-4e6d-a06d-9ce4a9fe5370 
      Message: No unmounted partitions found. 
      Hub: 1:1 usb: 2.0 type: Full speed (or root) hub chip ID: 1d6b:0002 
      Hub: 1:2 usb: 2.0 type: Intel Integrated Rate Matching Hub chip ID: 8087:0024 
      Device-1: Acer bus ID: 1:3 usb: 2.0 type: Video chip ID: 5986:02d5 
      Hub: 2:1 usb: 2.0 type: Full speed (or root) hub chip ID: 1d6b:0002 
      Hub: 2:2 usb: 2.0 type: Intel Integrated Rate Matching Hub chip ID: 8087:0024 
      Hub: 3:1 usb: 2.0 type: Full speed (or root) hub chip ID: 1d6b:0002 
      Hub: 4:1 usb: 3.0 type: Full speed (or root) hub chip ID: 1d6b:0003 
      System Temperatures: cpu: 45.0 C mobo: N/A 
      Fan Speeds (RPM): cpu: 3211 
      Active apt repos in: /etc/apt/sources.list.d/antix.list 
      1: deb jessie main nosystemd
      Active apt repos in: /etc/apt/sources.list.d/debian.list 
      1: deb jessie main contrib non-free
      2: deb jessie/updates main contrib non-free
      No active apt repos in: /etc/apt/sources.list.d/mx.list 
      Active apt repos in: /etc/apt/sources.list.d/palemoon.list 
      1: deb /
      No active apt repos in: /etc/apt/sources.list.d/siduction.list 
      No active apt repos in: /etc/apt/sources.list.d/various.list 
      CPU top: 5 
      1: cpu: 24.5% command: seamonkey pid: 2740 mem: 375.2 MiB (2.3%) 
      2: cpu: 15.0% command: inxi started by: perl pid: 9608 mem: 12.8 MiB (0.0%) 
      3: cpu: 3.7% command: x pid: 2311 mem: 44.6 MiB (0.2%) 
      4: cpu: 0.2% command: python pid: 2315 mem: 10.9 MiB (0.0%) 
      5: cpu: 0.1% command: [irq/32-iwlwifi] pid: 429 mem: 0.00 MiB (0.0%) 
      Memory top: 5 
      1: mem: 375.2 MiB (2.3%) command: seamonkey pid: 2740 cpu: 2.3% 
      2: mem: 44.6 MiB (0.2%) command: x pid: 2311 cpu: 0.2% 
      3: mem: 25.6 MiB (0.1%) command: python pid: 2706 cpu: 0.1% 
      4: mem: 22.8 MiB (0.1%) command: spacefm pid: 2627 cpu: 0.1% 
      5: mem: 20.6 MiB (0.1%) command: volumeicon pid: 2705 cpu: 0.1% 
      Processes: 169 Uptime: 1h 11m Memory: 15.56 GiB used: 408.8 MiB (2.6%) 
      Init: SysVinit v: 2.88 runlevel: 5 default: 5 Compilers: gcc: 4.9.2 alt: 4.8/4.9 
      Shell: bash v: 4.3.30 running in: roxterm inxi: 3.0.00 

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    I'm not outa place. I'm from outer space.

    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems


    Thank you,

    Yes, I am figuring out that the problem seems to be that the kernel or Xorg, or both, no longer support the GeForce2 video display driver.

    I am happy to be able to use antiX-16 for as long as I can. It works good. But maybe that will be the end of the road?

    My goal for this P-III has always been to experiment to see if it could be used as a regular computer in the current year. So far it has worked as a fairly good computer even in 2018. Slow, but usable. I find this facinating. Not that I would suggest that anyone use a P-III as their main computer. But I do find it interesting that such old kit can still hold it’s own. All thanks to Linux. Windows and DOS sure don’t help! (Except for nostalgia or games).

    So now my project will be as fatmac suggests and try to get the driver from version 16 to work in 17. May have to recompile something. Never done that but I guess that’s my next step in learning how to make Linux work on old computers.



    Now, after reading up on this and thinking about it, I guess it makes a certain amount of sense. Should we, as users, expect our developers to forever support our old hardware when there is so much new stuff to focus on? And I have the same problem with Windows 10 in our business. I have about four older workstations that run Win10 fine except for the video driver. If I want to fix the video I’ll have to upgrade the graphics hardware. But I’m living with it, for now.

    But I was wondering why the developers would not leave the users some way to support their old hardware themselves. Couldn’t we use a kernel “add-on” module for old hardware? Well, it seems there is this type of support built in to the Linux kernel. I’m not sure about how it works. Still learning. And I’m not sure if it works this way with Xorg also. But I’ll keep looking into it. I may be able to recompile my own kernel that will support my hardware. And maybe this kernel can work with the current antiX?



    Same feeling here. I wish I knew how to make my hardware last longer by modifying all that software stuff. But to be honest, 20 years in the computing world is already a lot.


    Same feeling here. I wish I knew how to make my hardware last longer by modifying all that software stuff. But to be honest, 20 years in the computing world is already a lot.


    Well, up til now Linux developers, such as this fine group at antiX, have done some amazing stuff that allows this old hardware to still be used. I can’t use DOS or Windows on those old machines anymore. But I can usually find a linux distro that will work with a fairly “modern” browsing experience. And I can still use these machines off-line just fine. But the real test for me is if I can access youtube. I don’t worry about full browser use such as shopping or banking. I wouldn’t do that on an old computer. But for entertainment and education a P-III is still useful. That’s pretty amazing in 2018.

    As time moves on it is becoming harder to find a ready-made OOB distro. But antiX is close. Sometimes Puppy works. But I think I will have to learn to do more self modifications and some compiling. Should be fun.



    The real determined (is this *hardcore* or stubbornness?) may want to take an old kernel that works (with the necessary drivers containing old hardware support) and see if more recent security kernel patches can be applied to the old systems.

    At some point backward, those patches simply will not work. The smartest people may, in theory, be able to rewrite the code to work, but that is not easy, and it is probably the reason why really old systems are no longer supported. For the TRULY determined, this is a great learning challenge to pursue!

    Brian Masinick


    This appears to be what some clever developer has done with a version of Puppy. It uses an old kernel but he keeps updating it and it works with some modern software. I have used it on old P-II and P-III boxes. It works but is not as comfortable to me as antiX. But this type of thing is way beyond me. I might be able to do some compiling and script editing but I’m no developer. I’ll be happy to play with whatever the community comes up with. If the P-III no longer gets any love, so be it. But like I said previously, I’m pretty impressed with what is currently available that runs on this old box.



    Well, it took awhile but I finally got this problem solved. As it turns out I did not have to change the kernel or compile an old driver to work. All I had to do was use some “cheat codes” on the boot line from the live DVD and add to a blacklist file in /etc/modprobe.d/.

    Here’s what I did to get antiX-17 installed on this old Pentium-III:

    After booting with the Live DVD I changed the F7 video selection to “default”. Then I typed in the cheat codes “xorg=nouveau” and “bp=b9” then hit enter to continue the boot.

    A bash shell came up and I entered “modprobe nouveau”, enter, then used “Ctrl-d” to continue the boot.

    Eventually the Live desktop came on screen. I checked the inxi, lsmod, and xorg. All looked good and setup for nouveau.

    Ran the installer and then robooted. After booting the X system did not start. I came to a text login. I logged in and then checked inxi and lsmod. Nouveau was loading but so was the nvidiafb and rivafb modules. I was reminded by a forum member that sometimes the nvidiafb module has to be blacklisted for nouveau to work. So I added “blacklist nvidiafb” and “blacklist rivafb” to the blacklist files in /etc/modprobe.d/. Rebooted.

    After reboot the X desktop came up. I logged in and then took another look at inxi, lsmod and xorg.log. It all looked properly setup for nouveau.

    I updated SMTube and tried playing a YouTube video. It plays fine, at least for an old computer. Not choppy and it was in sync. Good!

    So thank you all very much. I got these tips from here on the antiX forum and on the MX forum and I am happy to find that antiX-17 works great on this old P-III, even in 2019!




    Congratulations on your “problem solved”. Thank you everyone who contributed ideas, comments, or encouragement.

    Thanks Seaken64 for summarizing your approach and solution.

    Brian Masinick

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.