video freeze in gaupol – possibly pipewire audio issue?

Forum Forums Official Releases antiX-23 “Arditi del Popolo video freeze in gaupol – possibly pipewire audio issue?

  • This topic has 4 replies, 2 voices, and was last updated Nov 11-6:52 pm by Xunzi_23.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #122955
    Member
    Robin

      Not sure what to make of it. I have to report another issue in antiX 23 which wasn’t present in antiX 23 testing.
      Using gaupol for editing video subtitles, a strange thing happens now frequently while editing:

      Using the “o” key starts the playback of the very subtitle entry in gaupol when a video file was attached before. This works fine for the first maybe 10 or 20 times. Same when using the „p” key for pausing and resuming the video. But all of a sudden, the video wouldn’t play on, and no sound from this anymore. But neither gaupol nor mpv in the background is completely frozen, you can still edit or save the srt file, and even move through the video file. But all what you get is still images from the respective position of the video, without any sound. When requesting the external preview, the file is played properly with full sound in the external mpv window, it gets its own entry in the new GUI audio mixer antiX 23 comes with.

      What did I try already?
      – Pausing and resuming the video.
      – Moving around to arbitrary positions within the video, including the very start and the end.
      – Muting/unmuting the audio device.
      – Muting/unmuting the audio source
      – Increasing/decreasing the volume slider (master as well as the individual sliders for the input from MPV)
      All the above doesn’t make it work again.

      What helps at least partly?
      – Reload the video file into gaupol via the menu (video → load video file…)
      But after this the video playback stutters a bit, it stops for a very short instance every second or two.

      What really helps?
      – Save your work, close gaupol, and then start it again completely. Load your srt file and the video.
      Then you can work for the next short time, before the issue stops you again.

      My observation is on antiX 23 (final) I can at most enter ~10 entries before it happens.
      On antiX 23 (testing) the issue wasn’t present at all, you could work several hours and create hundreds of entries in one go without any issue.

      I decided to start gaupol from console to get some more information the very moment when the issue shows up, but actually nothing is printed to console this moment. Only the error messages from startup are present:

      $ gaupol
      (python3:2585766): Gtk-WARNING **: 16:42:48.616: Theme parsing error: cinnamon-applications.css:12:30: The style property GtkWidget:focus-padding is deprecated and shouldn't be used anymore. It will be removed in a future version
      (python3:2585766): Gtk-WARNING **: 16:42:48.617: Theme parsing error: cinnamon-applications.css:17:15: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'
      (python3:2585766): Gtk-WARNING **: 16:42:48.617: Theme parsing error: cinnamon-applications.css:25:15: The 'icon-shadow' property has been renamed to '-gtk-icon-shadow'
      (python3:2585766): Gtk-WARNING **: 16:42:48.617: Theme parsing error: cinnamon-applications.css:47:28: The style property GtkRange:slider-width is deprecated and shouldn't be used anymore. It will be removed in a future version
      (python3:2585766): Gtk-WARNING **: 16:42:48.623: Theme parsing error: gtk.css:2115:4: Junk at end of value for border-left-color
      /usr/share/gaupol/gaupol/renderers/time.py:46: Warning: g_value_get_int: assertion 'G_VALUE_HOLDS_INT (value)' failed
        editor.set_text(self.props.text)
      /usr/lib/python3/dist-packages/gi/overrides/Gio.py:42: Warning: g_value_get_int: assertion 'G_VALUE_HOLDS_INT (value)' failed
        return Gio.Application.run(self, *args, **kwargs)

      So I guess this issue might be connected somehow to the new pipewire audio system antiX 23 final comes with? Isn’t this thing interacting with the video as well? I remember before updating the Live system (and remastering) there was a similar issue with mpv, video only presenting still images and no sound. This now looks pretty similar, but now not immediately, but after some ten leaps/pause/resume operations from within gaupol.

      Any suggestions how to trace down the true culprit?

      System:
        Kernel: 6.1.55-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
          parameters: lang=de_DE quiet splasht disable=lxF
        Desktop: IceWM v: 3.4.3 vt: 7 dm: slimski v: 1.5.0 Distro: antiX-23-runit_x64-full Arditi del
          Popolo 26 August 2023 base: Debian GNU/Linux 12 (bookworm)
      Machine:
        Type: Desktop Mobo: ASUSTeK model: P7P55-M v: Rev X.0x serial: <superuser required>
          BIOS: American Megatrends v: 0903 date: 07/09/2010
      Battery:
        Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard serial: <filter> charge: 100%
          (should be ignored) rechargeable: yes status: discharging
        Device-2: hidpp_battery_1 model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter>
          charge: 90% (should be ignored) rechargeable: yes status: discharging
      Memory:
        RAM: total: 7.75 GiB used: 4.53 GiB (58.5%)
        RAM Report: permissions: Unable to run dmidecode. Root privileges required.
      PCI Slots:
        Permissions: Unable to run dmidecode. Root privileges required.
      CPU:
        Info: model: Intel Core i3 540 bits: 64 type: MT MCP arch: Westmere gen: core 1 level: v2
          built: 2010-11 process: Intel 32nm family: 6 model-id: 0x25 (37) stepping: 5 microcode: 0x2
        Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache: L1: 128 KiB
          desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 4 MiB desc: 1x4 MiB
        Speed (MHz): avg: 1244 high: 1366 min/max: 1200/3067 scaling: driver: acpi-cpufreq
          governor: schedutil cores: 1: 1204 2: 1204 3: 1204 4: 1366 bogomips: 24618
        Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov constant_tsc cpuid cx16 cx8 de
          ds_cpl dtes64 dtherm dts ept est flexpriority fpu fxsr ht lahf_lm lm mca mce mmx monitor msr
          mtrr nonstop_tsc nopl nx pae pat pbe pcid pdcm pebs pge pni popcnt pse pse36 pti rdtscp
          rep_good sep sse sse2 sse4_1 sse4_2 ssse3 syscall tm tm2 tpr_shadow tsc vme vmx vnmi vpid
          xtopology xtpr
        Vulnerabilities:
        Type: gather_data_sampling status: Not affected
        Type: itlb_multihit status: KVM: VMX disabled
        Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
        Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable
        Type: meltdown mitigation: PTI
        Type: mmio_stale_data status: Unknown: No mitigations
        Type: retbleed status: Not affected
        Type: spec_rstack_overflow status: Not affected
        Type: spec_store_bypass status: Vulnerable
        Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
        Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling, PBRSB-eIBRS: Not
          affected
        Type: srbds status: Not affected
        Type: tsx_async_abort status: Not affected
      Graphics:
        Device-1: AMD Cedar [Radeon HD 5000/6000/7350/8350 Series] vendor: ASUSTeK driver: radeon
          v: kernel alternate: amdgpu arch: TeraScale-2 code: Evergreen process: TSMC 32-40nm
          built: 2009-15 pcie: gen: 2 speed: 5 GT/s lanes: 16 ports: active: HDMI-A-1
          empty: DVI-I-1,VGA-1 bus-ID: 01:00.0 chip-ID: 1002:68f9 class-ID: 0300 temp: 63.0 C
        Display: x11 server: X.Org v: 1.21.1.7 driver: X: loaded: radeon
          unloaded: fbdev,modesetting,vesa dri: r600 gpu: radeon display-ID: :0.0 screens: 1
        Screen-1: 0 s-res: 2048x1152 s-dpi: 96 s-size: 541x304mm (21.30x11.97") s-diag: 621mm (24.43")
        Monitor-1: HDMI-A-1 mapped: HDMI-0 model: PMO S321-IQSC serial: <filter> built: 2021
          res: 2048x1152 hz: 60 dpi: 74 gamma: 1.2 chroma: red: x: 0.655 y: 0.337 green: x: 0.322 y: 0.612
          blue: x: 0.153 y: 0.059 white: x: 0.314 y: 0.329 size: 700x390mm (27.56x15.35")
          diag: 801mm (31.5") ratio: 16:9 modes: 2048x1152, 1920x1200, 1920x1080, 1920x1080i, 1600x1200,
          1680x1050, 1680x945, 1400x1050, 1600x900, 1280x1024, 1440x900, 1280x960, 1366x768, 1360x768,
          1280x800, 1152x864, 1280x768, 1280x720, 1024x768, 1024x576, 832x624, 800x600, 720x576,
          848x480, 720x480, 640x480, 720x400
        API: OpenGL v: 4.5 Mesa 22.3.6 renderer: AMD CEDAR (DRM 2.50.0 / 6.1.55-antix.1-amd64-smp LLVM
          15.0.6) direct-render: Yes
      Audio:
        Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: ASUSTeK 5
          driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403
        Device-2: AMD Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series] vendor: ASUSTeK
          driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.1
          chip-ID: 1002:aa68 class-ID: 0403
        Sound API: ALSA v: k6.1.55-antix.1-amd64-smp running: yes
        Sound Server-1: JACK v: 1.9.21 running: no
        Sound Server-2: PipeWire v: 0.3.65 running: yes
      Network:
        Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK M4A785/P7P55
          driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: c800 bus-ID: 02:00.0
          chip-ID: 10ec:8168 class-ID: 0200
        IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
        IP v4: <filter> scope: global broadcast: <filter>
        IP v6: <filter> scope: link
        WAN IP: <filter>
      Bluetooth:
        Message: No bluetooth data found.
      Logical:
        Message: No logical block device data found.
      RAID:
        Message: No RAID data found.
      Drives:
        Local Storage: total: 3.89 TiB used: 1.48 TiB (38.0%)
        SMART Message: Unable to run smartctl. Root privileges required.
        ID-1: /dev/sda maj-min: 8:0 vendor: Maxtor model: STM3250318AS size: 232.89 GiB block-size:
          physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC38
          scheme: MBR
        ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Toshiba model: EXTERNAL USB size: 3.64 TiB
          block-size: physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: 5438 scheme: GPT
        ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: SMI (STMicroelectronics) model: USB DISK
          size: 29.49 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1100
          scheme: GPT
        SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
        Message: No optical or floppy data found.
      Partition:
        ID-1: /live/boot-dev raw-size: 29.44 GiB size: 28.91 GiB (98.18%) used: 18.54 GiB (64.1%)
          fs: ext4 dev: /dev/sdc1 maj-min: 8:33 label: antiX-Live-usb
          uuid: 82879146-f0be-47e4-95f3-2518ff4d59eb
        ID-2: /media/ANTIX-UEFI raw-size: 49 MiB size: 48.2 MiB (98.43%) used: 12.4 MiB (25.6%)
          fs: vfat dev: /dev/sdc2 maj-min: 8:34 label: ANTIX-UEFI uuid: 6C35-F4DC
        ID-3: /media/homeantiX raw-size: 49.02 GiB size: 47.95 GiB (97.82%) used: 1.38 GiB (2.9%)
          fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: homeantiX uuid: e1991eba-59bf-4106-8a46-09b3ee0e94af
        ID-4: /media/rootantiX21 raw-size: 24.43 GiB size: 23.88 GiB (97.74%) used: 6.59 GiB (27.6%)
          fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: rootantiX21
          uuid: 9d2f9bb5-5d2f-4aad-96ed-12c96919bd8d
        ID-5: /media/sda4 raw-size: 155.27 GiB size: 151.78 GiB (97.75%) used: 130.51 GiB (86.0%)
          fs: ext4 dev: /dev/sda4 maj-min: 8:4 label: N/A uuid: c48583c1-9e59-4d5b-9114-c6041479f9f7
        ID-6: /media/sdb1 raw-size: 3.64 TiB size: 3.58 TiB (98.40%) used: 1.33 TiB (37.1%) fs: ext4
          dev: /dev/sdb1 maj-min: 8:17 label: N/A uuid: ade4760b-84fb-4bcf-8de6-2071af30fe8d
      Swap:
        Kernel: swappiness: 10 (default 60) cache-pressure: 50 (default 100)
        ID-1: swap-1 type: partition size: 3.91 GiB used: 783 MiB (19.6%) priority: -2 dev: /dev/sda2
          maj-min: 8:2 label: swapantiX uuid: 57ab2d2d-e0e9-49e6-b8d0-d8bea277cf7c
      Unmounted:
        Message: No unmounted partitions found.
      USB:
        Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002
          class-ID: 0900
        Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 speed: 480 Mb/s
          chip-ID: 8087:0020 class-ID: 0900
        Device-1: 1-1.1:3 info: Toshiba America MQ04UBF100 type: Mass Storage driver: usb-storage
          interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 500mA chip-ID: 0480:0900 class-ID: 0806
          serial: <filter>
        Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002
          class-ID: 0900
        Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 speed: 480 Mb/s
          chip-ID: 8087:0020 class-ID: 0900
        Device-1: 2-1.7:3 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
          driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 98mA
          chip-ID: 046d:c52b class-ID: 0300
        Hub-5: 2-1.8:4 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s power: 100mA
          chip-ID: 05e3:0608 class-ID: 0900
        Device-1: 2-1.8.3:5 info: Silicon Motion - Taiwan (formerly Feiya ) USB DISK type: Mass Storage
          driver: usb-storage interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 500mA chip-ID: 090c:2000
          class-ID: 0806 serial: <filter>
      Sensors:
        System Temperatures: cpu: 46.0 C mobo: 35.0 C gpu: radeon temp: 63.0 C
        Fan Speeds (RPM): cpu: 1339 case-1: 1250
        Power: 12v: 12.26 5v: N/A 3.3v: 3.42 vbat: N/A
      Repos:
        Packages: pm: dpkg pkgs: 2383 libs: 1262 tools: apt,apt-get,aptitude,synaptic
        Active apt repos in: /etc/apt/sources.list.d/antix.list
          1: deb [signed-by=/etc/apt/keyrings/antix-archive-keyring.gpg] http: //ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/bookworm bookworm main nonfree nosystemd
        Active apt repos in: /etc/apt/sources.list.d/bookworm-backports.list
          1: deb http: //deb.debian.org/debian bookworm-backports main contrib non-free non-free-firmware
        Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
          1: deb http: //ftp.de.debian.org/debian/ bookworm-updates main contrib non-free non-free-firmware
        Active apt repos in: /etc/apt/sources.list.d/debian.list
          1: deb http: //ftp.de.debian.org/debian/ bookworm main contrib non-free non-free-firmware
          2: deb http: //security.debian.org/ bookworm-security main contrib non-free non-free-firmware
        No active apt repos in: /etc/apt/sources.list.d/librewolf.list
        No active apt repos in: /etc/apt/sources.list.d/liquorix.list
      Processes:
        CPU top: 5 of 200
        1: cpu: 27.4% command: yad pid: 2596147 mem: 28.3 MiB (0.3%)
        2: cpu: 15.6% command: gaupol started-by: python3 pid: 2585766 mem: 377.7 MiB (4.7%)
        3: cpu: 5.5% command: pavucontrol pid: 296123 mem: 43.4 MiB (0.5%)
        4: cpu: 5.0% command: xorg pid: 7467 mem: 82.8 MiB (1.0%)
        5: cpu: 4.0% command: firefox-esr pid: 2592908 mem: 683.3 MiB (8.6%)
        Memory top: 5 of 200
        1: mem: 1881.3 MiB (23.7%) command: mpv pid: 2970014 cpu: 4.0%
        2: mem: 683.3 MiB (8.6%) command: firefox-esr pid: 2592908 cpu: 4.0%
        3: mem: 394.6 MiB (4.9%) command: document started-by: xournal pid: 296262 cpu: 0.0%
        4: mem: 377.7 MiB (4.7%) command: gaupol started-by: python3 pid: 2585766 cpu: 15.6%
        5: mem: 222.7 MiB (2.8%) command: zzzfm pid: 7580 cpu: 0.2%
      Info:
        Processes: 200 Uptime: 7d 1h 49m wakeups: 1459 Init: runit v: N/A runlevel: 2 tool: service
        Compilers: gcc: 12.2.0 alt: 12 Client: shell wrapper v: 5.2.15-release inxi: 3.3.25

      Windows is like a submarine. Open a window and serious problems will start.

      #122962
      Member
      Xunzi_23

        Hi Robin, couple of things come to mind, Kernel and cache, could you see if deleting cached content has same effect as a restart.
        Kernel and cache management are interwoven, maybe trying with the older kernel delivered with antiX 23 testing could help in
        diagnosis.

        #122981
        Member
        Robin

          Many thanks for the ideas, Xunzi!

          could you see if deleting cached content has same effect as a restart.

          Which cache do you refer to? System cache or MPV cache? How can I delete their content?
          Btw, I don’t have to perform a system restart to get back to normal, its enough to close and restart gaupol after saving the current srt file. As stated, no other programs are affected, not even programs using audio or video.

          For now I’ll check next whether this issue still occurs when I switch pipewire off for testing. Let’s see what happens. Only if this doesn’t sort out the issue already I’ll follow your trace with kernel and cache. Still, system cache shouldn’t be involved since no other programs or mpv instances are affected when started or running parallel, and same issue was present already before the recent kernel update. If I remember correctly I ran the very same 6.x kernel successfully on the testing version before without having this issue, so it’s pretty unlikely these things cause it. The single big difference seems to be the new audio layer which was introduced in the final antiX 23.

          Another trace might be problems in python3 to pipewire pulseaudio-emulation transfer. In the new antiX audio mixer neither gaupol nor mpv show up in this case, but the slider is named „python3” instead (see screenshot). I didn’t notice this issue when running media directly in mpv, so it’s most likely some of the new additional layer constructions pipewire utilises interfer with the existing construction gaupol uses to integrate mpv for internal playback management. As said, the video playback doesn’t freeze completely, but you only get still images without any sound when moving around in the video file once it has occurred.

          Windows is like a submarine. Open a window and serious problems will start.

          #123057
          Member
          Robin

            Issue is resolved for now (at least I’ve found a temporary workaround).

            Disabling Pipewire using the menu entry in antiX menu resolves the issue, even without reboot. After this gaupol didn’t stop working properly anymore, even after some more entries and jumping around wildly (for stress testing purposes) in the file and the subtitle entries. Also all other programs (like firefox) had to be restarted to get sound again after this. And well, I had to fine tune all the alsamixer and alsaequalizer sliders, they were horribly out of range so the audio output ran into clipping and was distorted. But after this basic adjustment the sound output seems to me just the same again as on the antiX 23 testing system before, which came without pipewire still. Will have to observe next days.

            I guess the gaupol positioning and repeated playback sends that many pause/resume/leap commands in very short intervals to the video playback process, the pipewire server layer can’t keep up with these multiple (and possibly contrary) commands, constantly trying to shut down and re-establish the sink and switch the sound, resulting in killing pulseaudio emulation driver for this application? Just a guess…

            But the most interesting thing is: Deactivating pipewire has resolved immediately also the other issue I had reported, concerning the mouse.

            Hopefully this issue can get fixed completely, so I can reactivate pipewire. Yes, I can work with plain alsa as well, I’m used to it, but honestly: The new gui and it’s features are way more convenient than knitting sophisticated alsa config files :)

            @Xunzi Do you think this still could be kernel or cache related, or is it rather something induced by pipewire itself?

            Windows is like a submarine. Open a window and serious problems will start.

            #123197
            Member
            Xunzi_23

              Hi Robin, i am unsure whether your issue is cache related,
              the description you gave made me think of full cache or
              possibly slowdown due swapping.
              i have not tried to replicate the issue as Pipewire makes my
              sound card drop to 8 bit mode, maybe why poor output quality
              annoys me even on present satellite sub system.
              Actually comes from teufel and is pretty good, the situation
              can only get worse when my Kali Speakers come,
              sometime soon I hope.
              They are, good but can be improved easily.
              once the plastic front is damped and case braced and damped
              extremely revealing, Means up with some much more expensive near
              to mid field studio monitors.

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.