[Solved] VLC player doesn’t show close, maximise or minimise buttons.

Forum Forums New users New Users and General Questions [Solved] VLC player doesn’t show close, maximise or minimise buttons.

  • This topic has 8 replies, 5 voices, and was last updated Aug 2-4:18 am by anilkagi.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #39692
    Member
    Avataranilkagi

    Hello there,

    When I open VLC player it does not have those usual, close, maximise or minimise buttons. The usual topmost bar is absent. It looks as shown in the attachment below.

    I am having this issue right from the beginning when I installed Antix-19.2.1-x64-Base. I thought I shall look at it later, when time permits.

    Today I tried resolving it by pressing F11 – no use.

    I tried: View > Fullscreen interface – no use

    I couldn’t find anything in: Tools > Preferences > Simple/All > Interface – to change the interface.

    I now have to close the VLC player either by right clicking on the taskbar or by typing “Control + q”.

    I don’t find a way to resolve this.

    Thanks and regards.

    • This topic was modified 1 week, 5 days ago by anilkagi.
    • This topic was modified 1 week, 5 days ago by anilkagi.
    • This topic was modified 1 week, 5 days ago by anilkagi.
    #39696
    Member
    AvatarModdIt

    Hi on my box this sometimes occurs with other programmes too,
    Try toggling with win key and F Keys or Number keys. I can not replicate just now because new chinese mechanical gamer keyboard is different to my old one where I could toggle with win f9. The behaviour will be according to setup in WM configuration.

    #39699
    Member
    Avataranilkagi

    Thank you Moddit for coming,

    I tried the different possible combinations you suggested, but the issue did not resolve.

    #39701
    Member
    Avatarwatsoccurring

    For me it started with changes in VLC maybe 1-2 months ago , I could not pin it down to when. (In this case it was to connect to sat.box. with a rotating dish)

    #39702
    Member
    XecureXecure

    If using icewm (I suspect that is the window manager you are using), follow these steps.

    1. Open ~/.icewm/winoptions
    xdg-open ~/.icewm/winoptions
    2. Search for any vlc related lines and remove them. (If you find none, then there is nothing to remove.)
    3. At the end of the file add:
    vlc.vlc.dTitleBar: 1
    4. Save the file and close it.
    5. Go to the menu > Logout > Restart Icewm
    6. Open vlc again and see if it is fixed.

    #39704
    Member
    Avataranilkagi

    Xecure, thanks for the suggestion.

    I did as suggested, but the issue did not resolve.

    However, one thing happened here. As you said the WM is the one that needs some editing.

    Whenever I start VLC it opens in several places on the desktop, namely the four corners of the screen. During one of the times that I opened VLC earlier, it so happened that it opened at the bottom right of the screen. Moreover, when it opened, at that time the title-bar was visible. I thought then that the issue must have resolved itself on its own. However, when I started it the next time it opened in other places and again the title-bar was not visible.

    Now after editing as you suggested, the VLC opened in the left-top corner. This time a considerable left hand side of the player was not visible. It was hidden out of the visible desktop.

    Another issue with this thing is, when this happens, I cannot even drag the VLC interface to the center of the screen to make all of the interface visible. Even with the Fullscreen interface enabled, the complete interface is not visible.

    I think, VLC has the title-bar view enabled but because it opens such that a portion of the interface is hidden beyond or out of the screen space and I cannot drag it to the center, the complete interface is not visible, though I am not sure about this.

    Is there a way to edit that behavior by which the interface gets hidden beyond the visible screen space?

    • This reply was modified 1 week, 5 days ago by anilkagi.
    #39706
    Member
    capreacaprea

    In my icewm/winoptions I have this

    vlc.geometry: 640×480+300+200

    Otherwise vlc will jump with every opening over the screen and sometimes parts are hidden.
    You can play with the 300+200 numbers to make it open on another place.

    If the hidden buttons were might caused by some settings in vlc,you can also delete the ~/.config/vlc folder to reset the preferences.

    #39710
    Member
    XecureXecure

    I just installed vlc on a clean antiX 19.2 system running icewm and I cannot reproduce. I even tried Tools > Preferences > Video > Display > (disable) Window decorations and I still cannot get it to launch with no tittlebar.
    Do as caprea suggests and delete the VLC config (or maybe in vlc, Tools > Preferences > Reset Preferences).

    Next time you encounter something similar and cannot move the window, use this trick. While pressing the ALT key, left-click on the window. Hold the left click and move the cursor. the window should move with the cursor.

    #39711
    Member
    Avataranilkagi

    Yes, that’s it, Caprea. The problem is resolved.

    First I entered the line;

    vlc.geometry: 640×480+300+200

    and played with the numbers. It didn’t give results.

    Then I renamed the .config/vlc to temp.vlc, and relogged.

    That solved the problem. The VLC now opened at the center of the screen with the complete interface showing this time.

    Thanks a lot Caprea & Xecure for you efforts to help. I am marking this thread as solved. 👍

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.