Wait, it "does not work right", okay, that was aimed at the Wireless. (Driver)

Forum Forums New users New Users and General Questions Wait, it "does not work right", okay, that was aimed at the Wireless. (Driver)

This topic contains 3 replies, has 4 voices, and was last updated by rokytnji Jul 11-9:09 am.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #24337
    Member
    Avatar
    GuruSR

    First, it’s not my first Linux, probably won’t be my last, but I had an old Compaq Armada M300 with 392MB of ram just sitting there with an empty IDE->CF adapter, so I stuck a 32GB one in (UDMA7 for speed) and went ahead and installed it (using the USB stick on a pc that won’t boot from it, using a CD disc that lets me boot from a USB stick, yeah, confusing as all). Tried it on the USB stick first, it worked, tried installing it and it stalled (the CD disc’s grub is a bit “temper-mental” a restart fixed it).

    So, now I have it all basic 17.4.1 (386) Full, but I have a small Netis WF-2110 150N mini adapter plugged into a USB 2.0 PCMCIA card adapter (yeah, totally all upgraded here). Sadly, I tried to scan for a connection and after doing so, the only way I could get the machine to respond was pull the power cord and battery out (yep, tried killing everything, didn’t help).

    So, I went looking for a driver, the original OS (not immediately available), had an in-house driver that worked with it, so no joy there, basic MS driver from Realtek, great. I did have the driver mini-cd and found the driver file (attached) for it, well, MacOS and Linux are the only two, so sadly, no joy in using the Windows Driver installer. But if someone out there can take a peek or tell me if there is another driver for this RTL8192CUS that I can plug a wire into the laptop and acquire it, I’ll do so, but it’s been a very very very very long while since my Unix days and I don’t recall installing linux drivers well enough, why I am attaching the file I have for it, see if someone here can take a peek at it and give me a suggestion on what to do with it, I already have it on the machine, just not sure the procedure of installing it or if the driver I have will even work in AntiX.

    (Right now, Windows 10 build 1903 has yet again failed to install on my other laptop, so much joy it’s not funny.)

    GuruSR.

    #24343
    Moderator
    fatmac
    fatmac

    Normally, you would put a driver into /lib/firmware & reboot, the system should then find & use it.

    Linux (& BSD) since 1999

    #24344
    Member
    Xecure
    Xecure

    I just checked, and antiX17.4 brings rtl8192cu drivers and firmware included. No need to install them. It could mean that the usb device is not being detected.

    Check to see if your usb device is detected
    lsusb
    You should see an entry mentioning RTL8192CU. If so, then check to see if the module is loaded:
    lsmod | grep "rtl8192"
    It should say something like “rtl_usb number 1 rtl8192cu

    Finally, check to see if there is any info in dmesg
    dmesg | grep "rtl8192"
    If there is any error, you will see it there.

    If it says that it is correctly loaded and there are no errors, try to see if ceni detects it:
    sudo ceni
    wlanX (where X is a number) should appear with a description “wireless MAC:ADDRESS rtl8192cu 802.11n USB WLAN”. Select and try to connect. If it freezes again, you may have to check that the device really works on other hardware. If it does, maybe you have to upgrade your kernel.

    Even if the drivers are included in the 4.9 kernel, I experienced myself with one device that wifi would not work until upgrading to a newer kernel. As I have experienced problems with 5.xx kernels, I recommend you download the antiX 4.19 kernel here (as a .deb file). Choose the correct one for your device (Thank anticapitalista for always giving us the best kernels with all security patches included).
    64 bits: http://repo.antixlinux.com/stretch/pool/main/l/linux-4.19.52-antix.1-amd64-smp/linux-image-4.19.52-antix.1-amd64-smp_4.19.52-antix.1-amd64-smp-1_amd64.deb
    32 bits PAE: http://repo.antixlinux.com/stretch/pool/main/l/linux-4.19.52-antix.1-686-smp-pae/linux-image-4.19.52-antix.1-686-smp-pae_4.19.52-antix.1-686-smp-pae-1_i386.deb
    32-bits NON PAE: http://repo.antixlinux.com/stretch/pool/main/l/linux-4.19.52-antix.1-486-smp/linux-image-4.19.52-antix.1-486-smp_4.19.52-antix.1-486-smp-1_i386.deb
    Move the corresponding kernel to a USB device and load and install it in your antiX 17.4 system. Restart and again follow the previous steps. If all seems well, try connecting through ceni.

    Let us know how it goes.

    • This reply was modified 5 days, 12 hours ago by Xecure. Reason: Correcting wording
    #24357
    Forum Admin
    rokytnji
    rokytnji

    To add to xsecure good post. We include inxi in AntiX and you will get better help with a

    inxi -Fxz

    report included in this thread.

    • This reply was modified 5 days, 7 hours ago by rokytnji. Reason: improper command line

    Sometimes I drive a crooked road to get my mind straight.
    Not all who Wander are Lost.
    Linux Registered User # 475019
    How to Search for AntiX solutions to your problems

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.