Wallpaper scaling

  • This topic has 12 replies, 3 voices, and was last updated Jan 8-10:17 am by delix02.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #4761
    Member
    delix02

      On an HP MT40 I have antiX17 with the testing repos and rox-icewm windowmanager running. The screen resolution is 1366×768.
      In contrast to my antiX16 PC I don’t have the option for the scaling, filling or centering of the the wallpaper ( see the screenshot ). file
      When I set the option via the control centers desktop session option manually in the wallpaper.conf, I get always the “scale” option as soon as I applied any choice in the conctrol centers wallpaper dialog — even if I wrote “fill” or “center” in the wallpaper.conf file. The I checked the wallpaper.conf file again and here the option is overwritten with “scale”.

      I notice this behavior when I used a wallpaper of my own. With the default wallpaper the effect is there, but I never noticed it as a deviation of the vertical and horzontal scaling factor doesn’t change the appearance much…..

      Attachments:
      #4764
      Forum Admin
      Dave

        Where you using rox-icewm before?
        Reason for asking: I have not changed anything related to this from V16-V17… as far as I know from when the app was written the other options are only available when in a window manager only session (icewm, jwm, fluxbox) not any of the variants based on icon manager (rox-*, space-*)

        Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

        #4768
        Member
        delix02

          on my antiX16 PC I have “rox-fluxbox” in the ~/.desktop-session/default-desktop and here the options are available. Is there a technical reason why they are not available in the other icon desktops ?

          #4769
          Member
          delix02

            I checked the antiX16 system and found no running rox instance with htop. So, this seems to be another problem specific with my setup, but this explain the availability of the scaling options on this PC.
            However, would be nice to these options on plain-wm systems, anyway…..

            • This reply was modified 6 years, 4 months ago by delix02.
            #4774
            Forum Admin
            Dave

              It would be nice. As far as I know though, the fill and center options do not work for spacefm desktop / rox filer desktop. If you know a way to set this via the command line I can add the options in the wallpaper app

              Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

              #4782
              Member
              delix02

                I found several suggestions to use external programs for the background wallpaper, as
                http://wiki.archlinux.org/index.php/feh

                this seems to work for me with both the plain Icewm and Rox-Icewm.
                I’ll test it for a while and I think I’ll accept it as a workaround solution if no problems are coming up.
                Don’t know whether it is really worth it to be included in the ControlCenter.
                Thx for the hints.

                #4783
                Forum Admin
                Dave

                  Feh is the backend used to set the wallpaper for the desktops without icons 😉

                  Actually it is used in all setting as conky displays a black background with the icons… even with the wallpaper being set in space or rox

                  Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                  #4784
                  Member
                  delix02

                    Aah okay – didn”t know that.

                    But when I switch the desktop from Icewm to Rox-Icewm, start a terminal and run the suggested commands, everything seems to run just fine -centering, scaling, filling and even tiling. As far as now I can see no conflicts. And the background remains the same after closing the terminal window. Maybe, the missing terminal window is the problem here ?
                    Haven’t tried the random-timed option because I wrote noc script therefore.

                    • This reply was modified 6 years, 4 months ago by delix02.
                    #4788
                    Forum Admin
                    Dave

                      Perhaps you could show the steps and commands?
                      I cannot get the wallpaper to change with the icons open. It sets for behind anything that show pseudo transparency, but not behind the icons.

                      BTW here is the section of the script with the commands that are run to set the wallpaper. $style is the option in ~/.desktop-session/wallpaper.conf and $wallpaper is the wallpaper saved in ~/.desktop-session/wallpaper-list.conf

                      case $im in
                              rox)
                                  Rox-Wallpaper "$wallpaper" &
                                  feh --bg-$style "$wallpaper" &
                                  ;;
                              space)
                                  spacefm --set-wallpaper "$wallpaper" &
                                  feh  --bg-$style "$wallpaper" &
                                  ;;
                              *)
                                  feh  --bg-$style "$wallpaper" &
                                  ;;
                          esac
                      

                      Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                      #4789
                      Member
                      delix02

                        well, I don’t use any icons 🙂

                        thought it was a general matter of the implementation.
                        Probably you spent already hours on this issue..

                        If it’s me who finds a solution (what is not very likely), I’ll post the code then. Sorry, it was a misunderstanding.

                        #4820
                        Member
                        delix02

                          I think part of the problem is the missing –no-fehbg option.

                          However, the real problem is the caching of the settings. The cached settings are not completely updated and they overwrite the settings from the manually given commands in the terminal. This is far over my head……

                          #4830
                          Anonymous

                            I don’t have the option for the scaling, filling or centering of the the wallpaper

                            delix02, your screenshot looks like what I would see after clicking to make a selection and
                            (naturally, aka expected) the other form controls are obscured while that selectbox is displaying all the available choices.
                            So, I’m asking: Are you saying that the screenshot is what you see (immediately, without clicking anything) when the application window opens?
                            If not, you’ll probably need to document (and post) a click-by-click, step-by-step explanation so that the “bug” can be reproduced/diagnosed/fixed.

                            .
                            not changed anything related to this from V16-V17…but should be (changed)?
                            seems like wider button width assignments should be specified, toward avoiding truncated text labels

                            #4862
                            Member
                            delix02

                              Version 1 : plain Icewm
                              when I open the wallpaper menu in the ControlCenter, I see two text lines with a hook, indicating there are menus with options

                              Static
                              with the options “Static” “No wallpaper”, “Random wallpaper”, “Random wallpaper timed”
                              scale
                              with the options “scale”, “center” and “fill”

                              and below the 3 buttons.
                              Everything seems to work as expected. However, the feh options “max” and “tile” are missing.
                              I choose the “Random wallpaper timed” and “center” options. I open a terminal and set the command

                              feh –randomize –no-fehbg –bg-tile /usr/share/wallpaper

                              The first pic is shown in tiled style filling the whole screen, the blue icon on the taskbar indicating the timed randomization is still visible. After the time intervall is over, I get the second pic in centered style. The ~/.fehbg file has the line

                              feh –randomize /usr/share/wallpaper/<name-of-the-second-pic

                              At this point I would prefer to get all pics in tiled style, but what is noticable is the timer still running. Well, I think the behavior is okay.

                              Now I close all open windows and click the blue timer icon in the taskbar. The last pic is there in centered style. I choose in the menu –> alternative desktops –> Rox-Icewm and come to
                              Version 2 : Rox-Icewm
                              I got one of the pics as wallpaper in scaled style and the blue timer button in the taskbar and the line

                              feh –bg-center /usr/share/wallpaper/<name-of-the-current-pic>

                              in the ~/.fehbg file.
                              When I open the wallpaper menu in the ControlCenter, I see only ONE text lines with a hook

                              Static
                              with the options “Static”, “Random wallpaper”, “Random wallpaper timed”

                              and below the 3 buttons.
                              The line with the style options is missing. I click the blue button in the taskbar and get the current wallpaper in static and scaled style. If the conky window is on, the wallpaper fills only the background outside the conky window, which remains black. Now I open the wallpaper menu in the ControlCenter and choose “Random wallpaper timed”. I get the blue icon and a wallpaper pic in scaled style. The wallpaper fills the whole screen, including the transparent conky window (the conky infos are still visible). The wallerpaper pic changes after the timer interval and is shown in the same way as the previous pic. Now I click the blue button to stop the timer, open a terminal window and set the command

                              feh –randomize –no-fehbg –bg-tile /usr/share/wallpaper

                              I get a static and tiled wallpaper pic only in the conky window, a static scaled wallpaper in the rest of the screen, no blue botton and the line

                              feh –bg-scale /usr/share/wallpaper/<name-of-the-pic-in-the-no-conky-window>

                              At this point I stopped writing protocol and (finally) switched back to the plain Icewm.

                              There are two points I got during the tests but didn’t trace exactely :
                              the behavior may change if you do a reboot of the computer.
                              Once I removed one of the pics in the wallpaper directory. I’m noy quiet sure, but I think I got an error text somewhere when I started the Randomize Timer somehow.

                              Hope this description helps, but I would spend too much time on the wallpaper issue…..

                            Viewing 13 posts - 1 through 13 (of 13 total)
                            • You must be logged in to reply to this topic.