[SOLVED] Wallpaper tool not launching in “testing” 32-bit

Forum Forums New users New Users and General Questions [SOLVED] Wallpaper tool not launching in “testing” 32-bit

  • This topic has 17 replies, 4 voices, and was last updated May 9-10:55 pm by seaken64.
Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #57434
    Member
    Avatarseaken64

    I have been playing with my “testing”/Sid 32-bit antiX-19 this morning. I went to use the “Choose Wallpaper” tool on the Control Centre and it would not launch. I updated and upgraded, and chose the la.mxrepo.com repo since my usual repo at mirrors.rit.edu has been having issues. I tried it again after a session restart but it still won’t launch the wallpaper chooser.

    I found the file at ~/.desktop-session/wallpaper-list.conf and changed the image file for my chosen desktop session (space-icewm). Then I restarted the session again and it worked! I was able to change the wallpaper by directly editing this file.

    Is this the file that wallpaper.py changes through the “Choose Wallpaper” tool? I don’t think so. I think it uses ./fehbg to set the wall paper. Will it matter if I use the wallpaper-list.conf file to change the wallpaper? I’m assuming it won’t matter if I get the Choose Wallpaper button back since I can just choose the same image as I entered into the wallpaper-list.conf file. I’m also assuming the Control Centre will get an update eventually that will fix this.

    Sorry if this is a dumb question. I’m still trying to get my head around how antiX is setup and what files and configurations affect what other files, etc.

    seaken64

    • This topic was modified 1 month ago by seaken64.
    • This topic was modified 4 days, 5 hours ago by Brian Masinick. Reason: Marked [SOLVED]
    #57449
    Member
    Avatarskidoo

    The meaning of your in-quotation-marks “testing” is unclear.
    If you are using antiX19, and have enabled debian “testing” (aka soon-to-become-Bullseye) repositories… possibly your “testing” system is now treating python3 as the default python version.

    here’s how to check that detail, from commandline:
    python --version

    Tested on antiX19 + debian stable (Buster) repos, if I attempt to _force_ use of python3:
    python3 /usr/local/bin/wallpaper.py

    …the result is:

      File "/usr/local/bin/wallpaper.py", line 107
        print var.DESKTOP_CODE
                ^
    SyntaxError: Missing parentheses in call to 'print'. Did you mean print(var.DESKTOP_CODE)?

    When attempting to launch via menu or controlcenter, one would not have an opportunity to see that “why it failed” detail.

    If the above (v3 is now set as the default python version on the system) is indeed the issue… on your affected system, until a version of the wallpaper script intended for use with python3 is released, you can edit the script and explicitly specify python2.

    sudo sed -i 's/env python$/env python2/' /usr/local/bin/wallpaper.py

    #57450
    Member
    Avatarseaken64

    @skidoo, yes, a few months ago anti asked if some of us could set up an antiX-19 sid installation and report anything wonky. I’ve been running this testing (sid) version for awhile and it’s been no problem. But now maybe since we’re getting closer to it becoming Bullseye I’m seeing the changes to Python 3 starting to reveal a couple of issues.

    Here’s part of the inxi for this “testing” machine as I called it:

    System:
      Host: antix1932 Kernel: 4.9.212-antix.1-486-smp i686 bits: 32 
      compiler: gcc v: 9.2.1 Desktop: IceWM 2.3.1 
      Distro: antiX-19.2.1_386-base Hannie Schaft 29 March 2020 
      base: Debian GNU/Linux bullseye/sid
    Repos:
      Active apt repos in: /etc/apt/sources.list.d/antix.list 
      1: deb http://la.mxrepo.com/antix//testing testing main nonfree nosystemd
      No active apt repos in: /etc/apt/sources.list.d/buster-backports.list 
      No active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
      Active apt repos in: /etc/apt/sources.list.d/debian.list 
      1: deb http://ftp.us.debian.org/debian/ testing main contrib non-free
      2: deb http://security.debian.org testing-security main contrib non-free
      No active apt repos in: /etc/apt/sources.list.d/onion.list 
      No active apt repos in: /etc/apt/sources.list.d/various.list 
    Info:
      Processes: 141 Uptime: 7h 35m Memory: 999.2 MiB used: 315.5 MiB (31.6%) 
      Init: SysVinit runlevel: 5 Compilers: gcc: 10.2.1 Shell: bash v: 5.1.4 
      inxi: 3.0.36 

    Here’s the output of running wallpaper.py from the terminal:

    /usr/local/bin/wallpaper
    Traceback (most recent call last):
      File "/usr/local/bin/wallpaper", line 309, in get_icon
        pixbuf = GdkPixbuf.Pixbuf.new_from_file_at_size(icon, icon_size, icon_size)
    gi.repository.GLib.Error: g-file-error-quark: Failed to open file “gtk-missing-image”: No such file or directory (4)
    
    During handling of the above exception, another exception occurred:
    
    Traceback (most recent call last):
      File "/usr/local/bin/wallpaper", line 561, in <module>
        win = mainWindow()
      File "/usr/local/bin/wallpaper", line 459, in __init__
        menu_folder = self.build_button(1, "document-open-folder", 16, _("Default Folder"))
      File "/usr/local/bin/wallpaper", line 414, in build_button
        iconinfo = Build_Picture.get_icon(image, size, 0)
      File "/usr/local/bin/wallpaper", line 313, in get_icon
        icon = icon_info.get_filename()
    AttributeError: 'NoneType' object has no attribute 'get_filename'

    I think you’re probably right and it’s a python3 thing. I was not able to get anything from “python –version”.

    I am perfectly okay with waiting for the upgrades to catch up. After all it’s the “testing” repo. I’m learning from both ends. This Sid version on one end and my antiX-17 Stretch versions on the other. FWIW, my antiX-19 Buster versions have been trouble free.

    seaken64

    #57453
    Member
    Avatarseaken64

    I didn’t get anything from “python –version” but here’s what I get from apt show:

    sudo apt show python -a
    Package: python
    Version: 2.7.16-1
    Status: deinstall ok config-files
    Priority: optional
    Section: python
    Source: python-defaults
    Maintainer: Matthias Klose <doko@debian.org>
    Config-Version: 2.7.16-1
    Installed-Size: 69.6 kB
    Provides: python-ctypes, python-email, python-importlib, python-profiler, python-wsgiref
    Pre-Depends: python-minimal (= 2.7.16-1)
    Depends: python2.7 (>= 2.7.16-1~), libpython-stdlib (= 2.7.16-1), python2 (= 2.7.16-1)
    Suggests: python-doc (= 2.7.16-1), python-tk (>= 2.7.16-1~)
    Conflicts: python-central (<< 0.5.5)
    Breaks: update-manager-core (<< 0.200.5-2)
    Replaces: python-dev (<< 2.6.5-2)
    Homepage: https://www.python.org/
    Cnf-Extra-Commands: python
    Cnf-Priority-Bonus: 3
    Download-Size: unknown
    APT-Sources: /var/lib/dpkg/status
    Description: interactive high-level object-oriented language (Python2 version)
     Python2, the high-level, interactive object oriented language,
     includes an extensive class library with lots of goodies for
     network programming, system administration, sounds and graphics.
     .
     This package is a dependency package, which depends on Debian's Python2
     version (currently v2.7).
    

    I’m not sure if that’s what I have installed or not. Not sure what it means by
    Status: deinstall ok config-files

    #57454
    Member
    Avatarseaken64

    Seems I don’t have Python installed at the moment:

    sudo apt policy python
    python:
      Installed: (none)
      Candidate: (none)
      Version table:
         2.7.16-1 -1
            100 /var/lib/dpkg/status
    

    Nope, I think that only applies to Python2. Here’s what I get with Python3:

    sudo apt policy python3
    python3:
      Installed: 3.9.2-2
      Candidate: 3.9.2-2
      Version table:
     *** 3.9.2-2 500
            500 http://ftp.us.debian.org/debian testing/main i386 Packages
            100 /var/lib/dpkg/status
    
    • This reply was modified 1 month ago by seaken64.
    #57456
    Member
    Avatarskidoo

    I was not able to get anything from “python –version”

    Hmm, without ‘code’ tags, we wind up with longdash in place of minus minus… but in my post, I did use ‘code’ tags.

    The claim “python space minus minus version yielded nothing” seems preposterous.
    Wait for others to reply ~~ I’m backing outa this topic.

    #57461
    Member
    Avatarseaken64

    Sorry, yes I entered

    python --version

    I got command not found.

    I just checked it again. Then I decided to try:
    python3 --version

    and I got a return of:
    Python 3.9.2

    I guess Python only works with Python2 and we have to use python3 now.

    Anyway, I clearly have Python 3 installed. Probably have some issues with the script that will get sorted out by the time of the upcoming Bullseye.

    seaken64

    #57473
    Forum Admin
    DaveDave

    Yes; ~/.desktop-session/wallpaper-list.conf and ~/.desktop-session/wallpaper.conf are the files that are modified by the wallpaper app. Then a bash script runs to set the wallpaper at startup (/usr/local/bin/desktop-session-wallpaper). You can modify those configuration files by hand and run desktop-session-wallpaper and exclude using the gui if you wish.

    For the gui, you probably need to install the wallpaper version from the antiX testing repos as it is written for python3. The one in the stable/buster antix repo is using python2.
    http://repo.antixlinux.com/bullseye/pool/main/w/wallpaper-antix/wallpaper-antix_0.6.5_all.deb
    Beyond that try running in terminal
    wallpaper
    for the python 3 version or
    wallpaper.py
    for the python 2 version
    And try and post back whatever shows in terminal for the error.

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #57486
    Member
    Avatarseaken64

    Thanks Dave,

    please see above for the output of

    wallpaper
    from the terminal

    #post-57450

    Okay, thanks for clarifying. I was able to modify the wallpapers-list file and get my wallpaper to show up. This will then get re-written once we get “wallpaper” working.

    seaken64

    • This reply was modified 4 weeks, 1 day ago by seaken64.
    #57529
    Forum Admin
    DaveDave

    Ah ok I see a bug when there is not a valid image available from the configuration. (the missing image icon is not parsed to full path)

    Now that you have changed your wallpaper in wallpaper-list.conf and it sets the expected wallpaper, and assuming the file is still there, does the wallpaper app (command: wallpaper) now run?
    Does it display the same error?

    If it displays the same error could you tell me:
    – what icon set you are using.
    – what are the contents of ~/.desktop-session/wallpaper.conf ~/.desktop-session/wallpaper-list.conf ~/.desktop-session/desktop-code.0
    – In ~/.desktop-session/wallpaper.conf there is the line FOLDER=/some/path. If you take this path and the session wallpaper from ~/.desktop-session/wallpaper-list.conf does the file exist at that location?

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #57833
    Forum Admin
    DaveDave

    Another couple of things to check.
    DO you have installed…
    libgtk-3-0
    libgtk-3-common

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #58528
    Member
    Avatarseaken64

    I’ll get back to Dave a little later with his requested info.

    For now I just wanted to interject that I have been using the wrong term for the repos I am using on this test system.

    I am not using the Sid repos. I have the repos set to “Testing”. I have been using these terms interchangeably in this thread (and elsewhere) and I have since learned that this is incorrect. I just wanted to clarify the repos I am using on my test system since it may make a difference in troubleshooting.

    Just shows how, even after all these years, I still don’t know half of what I thought I did. Ha! But I think I got it now. I am on Testing.

    seaken64

    #58530
    Member
    Avatarseaken64

    @Dave

    “Now that you have changed your wallpaper in wallpaper-list.conf and it sets the expected wallpaper, and assuming the file is still there, does the wallpaper app (command: wallpaper) now run?
    Does it display the same error?”

    The wallpaper app still crashes after having changed the wallpaper, and it does display the same error message.

    “If it displays the same error could you tell me:
    – what icon set you are using.”

    In Control Centre}Desktop}Customize Look and Feel}Icon Theme the ‘Adwaita’ setting is highlighted. I think this means I am using the Adwaita icon set but I am not sure if I am looking the right spot.

    “– what are the contents of ~/.desktop-session/wallpaper.conf”

    #THIS IS THE CONFIGURATION FILE FOR THE ANTIX WALLPAPER APP.
    #ALL SETTINGS ARE CHANGED BY WALLPAPER.PY BUT YOU CAN CHANGE THEM
    #MANUALLY AND RUN LOGIN_BACKGROUND.SH IF YOU WOULD LIKE ;)

    #THIS IS THE DEFAULT WALLPAPER, IT WILL SHOW UP WHEN THE SAVED
    #WALLPAPER IS NOT FOUND, IN THE WALLPAPER.PY PREVIEW WHEN YOU
    #HAVE RANDOM WALLPAPER, RANDOM WALLPAPER TIMED, OR NO WALLPAPER
    #SET. IT IS SUGGESTED THAT YOU LEAVE IT AS IS, BUT YOU CAN CHANGE
    #IT IF YOU WOULD LIKE A MORE APPEALING PICTURE :D
    DEFAULT=/usr/share/wallpaper/metro-station.jpg

    #THIS IS THE HELP THE PATH SETTING TO THE HELP FILE, IT WILL SHOW UP
    #WHEN HELP IS PRESSED. YOU SHOULD NOT NEED TO CHANGE THIS UNLESS
    #YOU WOULD LIKE TO MAKE YOUR OWN HELP / QUICK REFERENCE FILE
    HELPFILE=/usr/share/desktop-session/wallpaper/help.txt

    #THIS IS WHERE YOU SET WHICH METHOD IS USED FOR SETTING THE
    #WALLPAPER
    #THE OPTIONS FOR THE TYPE ARE:
    #FOR ONE WALLPAPER
    #TYPE=static
    #FOR COLOR ONLY
    #TYPE=color
    #FOR A RANDOM WALLPAPER EVERY TIME YOU LOGIN
    #TYPE=random
    #FOR A RANDOM WALLPAPER EVERY 5 MINUTES
    #TYPE=random-time
    ###################################################################
    #TIP CHANGE THE LINE BELOW SO THAT YOU WILL RETAIN THE EXAMPLES :D#
    ###################################################################
    TYPE=static

    #THIS IS WHERE YOU SET WHAT COLOR YOU WOULD LIKE THE DESKTOP TO BE
    #NOTE THAT THIS WILL ONLY WORK IF THE TYPE IS SET TO COLOR
    COLOR=000000000000

    #THIS IS THE FOLDER THAT THE APPLICATION DEFAULTS TO WHEN THE OPEN
    #BUTTON IS PRESSED, IT IS ALSO THE WHERE THE RANDOM WALLPAPERS ARE
    #CHOSEN OUT OF WHEN THE TYPE IS SET TO RANDOM OR RANDOM-TIME
    FOLDER=/usr/share/wallpaper

    #THIS IS WHERE YOU SET IF YOU WOULD LIKE THE WALLPAPER SCALED,
    #CENTERED, OR FILLED
    #FOR SCALED
    #STYLE=scale
    #FOR CENTERED
    #STYLE=center
    #FOR FILLED
    #STYLE=fill
    ###################################################################
    #TIP CHANGE THE LINE BELOW SO THAT YOU WILL RETAIN THE EXAMPLES :D#
    ###################################################################
    STYLE=scale

    #THIS IS WHERE YOU SET THE TIME VALUE FOR THE WALLPAPER TO CYCLE
    #WHEN RANDOM WALLPAPER TIMED IS SELECTED.
    #VALUE IS IN SECCONDS
    DELAY=300

    “~/.desktop-session/wallpaper-list.conf”

    fluxbox=/usr/share/wallpaper/metro-station.jpg
    rox-fluxbox=/usr/share/wallpaper/metro-station.jpg
    space-fluxbox=/usr/share/wallpaper/metro-station.jpg
    icewm=/usr/share/wallpaper/metro-station.jpg
    rox-icewm=/home/sean/Wallpapers/New-York-City-Top-View-Wallpaper-600x337.jpg
    space-icewm=/home/sean/Wallpapers/Seattle_e3bMvtb.jpg
    jwm=/usr/share/wallpaper/metro-station.jpg
    rox-jwm=/usr/share/wallpaper/metro-station.jpg
    space-jwm=/usr/share/wallpaper/metro-station.jpg

    “~/.desktop-session/desktop-code.0”

    space-icewm

    “– In ~/.desktop-session/wallpaper.conf there is the line FOLDER=/some/path. If you take this path and the session wallpaper from ~/.desktop-session/wallpaper-list.conf does the file exist at that location?”

    The path in the ~/.desktop-session/wallpaper.conf file is at

    /usr/share/wallpaper

    The session wallpaper I set for space-icewm is in

    /home/sean/Wallpapers

    The same wallpaper file set for the space-icewm session is not in the default path location.

    “Another couple of things to check.
    DO you have installed…
    libgtk-3-0
    libgtk-3-common”

    sudo apt policy libgtk-3-common
    libgtk-3-common:
    Installed: 3.24.24-3
    Candidate: 3.24.24-3
    Version table:
    *** 3.24.24-3 500
    500 http://ftp.us.debian.org/debian testing/main i386 Packages
    100 /var/lib/dpkg/status

    $ sudo apt policy libgtk-3-0
    libgtk-3-0:
    Installed: 3.24.24-3
    Candidate: 3.24.24-3
    Version table:
    *** 3.24.24-3 500
    500 http://ftp.us.debian.org/debian testing/main i386 Packages
    100 /var/lib/dpkg/status

    #58638
    Forum Admin
    DaveDave

    Yes there seems to be a bug with wallpaper loading the Adwaita icon theme.
    Does it work if you use papirus or numis icon theme?

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #58880
    Member
    Avatarseaken64

    @Dave, Yes, it works if I change to “papirus-mini-antix”. I guess that confirms the bug with Adwaita.

    Thanks

    Seaken64

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.