Wifi Adapter problem

Forum Forums General Tips and Tricks Wifi Adapter problem

  • This topic has 27 replies, 5 voices, and was last updated Feb 8-9:57 pm by sisqonrw.
Viewing 13 posts - 16 through 28 (of 28 total)
  • Author
    Posts
  • #132448
    Member
    abc-nix

      modprobe: FATAL: Module rtl8188fu not found in directory /lib/modules/5.10.188-antix.1-amd64-smp

      It didn’t install properly then. Can you try installing again and share the terminal output¿ We may be able to find out what the issue is.

      #132452
      Member
      abc-nix

        I just installed on my system:

        $ sudo dkms install ./rtl8188fu
        The kernel is built without module signing facility, modules won't be signed
        Creating symlink /var/lib/dkms/rtl8188fu/1.0/source -> /usr/src/rtl8188fu-1.0
        Building module:
        Cleaning build area...
        'make' all KVER=6.1.60-antix.1-amd64-smp........................................
        Cleaning build area...
        rtl8188fu.ko:
        Running module version sanity check.
         - Original module
           - No original module exists within this kernel
         - Installation
           - Installing to /lib/modules/6.1.60-antix.1-amd64-smp/updates/dkms/
        depmod...

        And it loads properly

        $ sudo modprobe -v rtl8188fu
        insmod /lib/modules/6.1.60-antix.1-amd64-smp/updates/dkms/rtl8188fu.ko
        #132459
        Member
        sisqonrw

          modprobe: FATAL: Module rtl8188fu not found in directory /lib/modules/5.10.188-antix.1-amd64-smp

          It didn’t install properly then. Can you try installing again and share the terminal output¿ We may be able to find out what the issue is.

          sudo apt update && sudo apt upgrade
          OK:1 http://deb.debian.org/debian bookworm-backports InRelease
          OK:2 http://security.debian.org bookworm-security InRelease
          OK:3 http://ftp.de.debian.org/debian bookworm-updates InRelease
          OK:4 http://ftp.de.debian.org/debian bookworm InRelease
          OK:5 http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/bookworm bookworm InRelease
          Paketlisten werden gelesen… Fertig
          Abhängigkeitsbaum wird aufgebaut… Fertig
          Statusinformationen werden eingelesen… Fertig
          Alle Pakete sind aktuell.
          Paketlisten werden gelesen… Fertig
          Abhängigkeitsbaum wird aufgebaut… Fertig
          Statusinformationen werden eingelesen… Fertig
          Paketaktualisierung (Upgrade) wird berechnet… Fertig
          0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
          salsero@antix1:~
          $ sudo apt install build-essential git dkms
          Paketlisten werden gelesen… Fertig
          Abhängigkeitsbaum wird aufgebaut… Fertig
          Statusinformationen werden eingelesen… Fertig
          build-essential ist schon die neueste Version (12.9).
          git ist schon die neueste Version (1:2.39.2-1.1).
          dkms ist schon die neueste Version (3.0.10-8+deb12u1).
          0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
          salsero@antix1:~
          $ git clone https://github.com/kelebek333/rtl8188fu
          Schwerwiegend: Zielpfad ‘rtl8188fu’ existiert bereits und ist kein leeres Verzeichnis.
          salsero@antix1:~
          $ sudo dkms install ./rtl8188fu
          Sign command: /lib/modules/5.10.188-antix.1-amd64-smp/build/scripts/sign-file
          Signing key: /var/lib/dkms/mok.key
          Public certificate (MOK): /var/lib/dkms/mok.pub
          Creating symlink /var/lib/dkms/rtl8188fu/1.0/source -> /usr/src/rtl8188fu-1.0

          Building module:
          Cleaning build area…
          ‘make’ all KVER=5.10.188-antix.1-amd64-smp……………………………………………………………………………………………..
          Signing module /var/lib/dkms/rtl8188fu/1.0/build/rtl8188fu.ko
          Cleaning build area…

          rtl8188fu.ko:
          Running module version sanity check.
          – Original module
          – No original module exists within this kernel
          – Installation
          – Installing to /lib/modules/5.10.188-antix.1-amd64-smp/updates/dkms/
          depmod…..
          salsero@antix1:~
          $ sudo cp ./rtl8188fu/firmware/rtl8188fufw.bin /lib/firmware/rtlwifi/
          salsero@antix1:~

          #132462
          Member
          sisqonrw

            After restart now it works. Thanks for all! Antix and the community are great!

            • This reply was modified 2 months, 1 week ago by sisqonrw.
            #132465
            Member
            abc-nix

              EDIT. Great to know it now works. Thanks for your patience. Enjoy antiX.

              • This reply was modified 2 months, 1 week ago by abc-nix.
              #132469
              Member
              sisqonrw

                uname -r
                5.10.188-antix.1-amd64-smp

                #132474
                Member
                sisqonrw

                  it has worked. after restart not really.

                  We received a DBUS reply message indicating an error.

                  Error Name: net.connman.Error.InProgress

                  Error Message: In Bearbeitung

                  he do not connect automatically. manuell it does not work to. where can the problem be?

                  #132480
                  Member
                  abc-nix

                    he do not connect automatically. manuell it does not work to. where can the problem be?

                    It could be a connman timing issue. What edition of antiX did you install?
                    inxi -Saz

                    #132483
                    Member
                    sisqonrw

                      i have disconnect and connect. than this

                      inxi -Saz
                      System:
                      Kernel: 5.10.188-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc
                      v: 13.2.0 clocksource: tsc available: hpet,acpi_pm
                      parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.188-antix.1-amd64-smp
                      root=UUID=10ab98e3-6bba-458f-b5c1-9d2164b26980 ro quiet selinux=0
                      Desktop: IceWM v: 3.4.5 dm: slimski v: 1.5.0
                      Distro: antiX-23-runit_x64-base Arditi del Popolo 26 August 2023 base: Debian
                      GNU/Linux 12 (bookworm)

                      #132487
                      Member
                      abc-nix

                        Great. The runit edition has an easy way to enable connman faster. Please edit /etc/sv/slimski/run as root
                        sudo geany /etc/sv/slimski/run
                        and add under the line that starts with
                        # Start elogind first (optional) - Don't start
                        so it should look like this:

                        # Start elogind first (optional) - Don't start
                        sv start dbus && sv check dbus || true
                        sv start connman || true
                        # sv start elogind && sv check elogind || true

                        Save and reboot.

                        It is a small hack to have connman start faster. It usually isn’t necessary, but some computers start faster and load the graphical environment before the network is ready. This should fix it.

                        #132490
                        Member
                        sisqonrw

                          same error report. wlan work not. cant connect.

                          We received a DBUS reply message indicating an error.

                          Error Name: net.connman.Error.InProgress

                          Error Message: In Bearbeitung

                          #132493
                          Member
                          abc-nix

                            Is this a message that pops up as soon as the system starts? Go to $HOME/.desktop-session/startup and comment the line for network-check-antix so it looks like this:
                            # network-check-antix &

                            #132494
                            Member
                            sisqonrw

                              i dont know. its getting better. now it works.

                              network-check-antix &
                              [1] 2494
                              salsero@antix1:~
                              $ Network connection detected, no need to configure anything

                            Viewing 13 posts - 16 through 28 (of 28 total)
                            • You must be logged in to reply to this topic.