Wifi is soft blocked after each reboot SOLVED

Forum Forums General Software Wifi is soft blocked after each reboot SOLVED

  • This topic has 28 replies, 5 voices, and was last updated Jul 28-7:58 pm by Xecure.
Viewing 15 posts - 1 through 15 (of 29 total)
  • Author
    Posts
  • #50614
    Member
    SteveJJ

    I have just installed 19.3 antiX. (edited to correct version at user request)

    I got WiFi working with the following:
    1. sudo rfkill unblock all
    2. set up the wifi connection using Connman (just select my WiFi service and added the password)

    It works great… but after every reboot the connection is blocked in software, so I need to do “rfkill unblock all” every time. (I don’t need to run Connman – the settings are still there).

    How can I stop the software block after each reboot?

    • This topic was modified 8 months ago by ModdIt. Reason: User request
    #50617
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    Just so you know. From Announcements on the front page of this forum:

    antiX jessie based versions (antiX-15 and antiX-16.x) reached end of life at the end of June 2020.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #50621
    Member
    Xecure
    Helpful
    Up
    0

    Instead of doing rfkill unblock all, enable wifi from connman. As you don’t specify the antiX edition (base or full), I will give you the command to enable it independently of the connman gui used (FULL uses a different connman interface to BASE).
    connmanctl enable wifi
    Try rebooting and see if the change persists. It should.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #50622
    Moderator
    caprea
    Helpful
    Up
    0

    In cmst , the GUI for connman, is Wifi set to “on” under Status-tab > Technologies ?

    Edit: Or do the command from above, Xecure was faster

    • This reply was modified 8 months ago by caprea.
    #50625
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    Are you sure you are using 16.3? If you are, it did not ship with connman, but wicd and ceni.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #50630
    Member
    Xecure
    Helpful
    Up
    0

    I think Stevejj was using a numpad, and mis-typed 6 (which is just below the 9 key).

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #50710
    Member
    SteveJJ
    Helpful
    Up
    0

    There are two sections:
    – in the “Powered on” section, it is “On”
    – in the “Tethered” section it is not enabled (if I click that it asks for some SSID info)

    Anyhow it seems to be working now.

    #50711
    Member
    SteveJJ
    Helpful
    Up
    0

    Sorry, yes I meant 19.3

    #50712
    Member
    SteveJJ
    Helpful
    Up
    0

    I ran that command, but it reported an error, saying the wifi is already enabled.

    It seems to have fixed the problem anyway, because the wifi is now working after a reboot.

    #63453
    Member
    PFO
    Helpful
    Up
    0

    Hi antiX Group,

    Same problem, but I get the error:
    delete ‘/run/supplicant/wlan0

    I screwed up when the WIFI modem went down and tried to connect with Connman, which appears to have created another supplicant file that is soft-blocking the CENI supplicant file.

    All advice gladly taken.

    #63454
    Member
    Xecure
    Helpful
    Up
    0

    You can use the gui tool or the cli command
    antix-wifi-switch --cli ceni

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #63511
    Member
    PFO
    Helpful
    Up
    0

    Many thanx Xecure,

    I get:
    antix-wifi-switch – command not found

    Do I need to be in ‘root’ to execute system changing commands?

    Looking for ‘root’ command on WEB.

    PFO

    #63513
    Member
    PFO
    Helpful
    Up
    0

    Woops, I am in root, ran sudo yesterday.

    BUT still get above error message – and when I type any command it asks for sudo password and I get:

    Authentication failure

    OK, now what?

    #63514
    Member
    Xecure
    Helpful
    Up
    0

    This means your system hasn’t been updated since October. That tool was included in antix-goodies and should be on your system.

    Anyway, you could do the manual steps to disable connman, stop wpa_supplicant, restart networking and try again with ceni
    First, make sure wifi will never be soft-blocked again by connman, and disable connman from startup:

    sudo service connman restart
    connmanctl enable wifi
    sudo service connman stop
    sudo update-rc.d connman remove

    Now stop wpa_supplicant and restart networking

    sudo killall wpa_supplicant
    sudo service networking restart

    Now ceni should work again. Run
    sudo ceni
    and reconfigure your wifi.

    The tool I mentioned would do all this for you automatically, so for now you need to do this manually.

    Let us know if you can again reconnect to your wifi and browse webpages. If there is any issue we will try to help as best we can.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #63515
    Member
    PFO
    Helpful
    Up
    0

    OK, now out of root but ‘visudo’ and ‘su’ ccommands still yield an

    authentication failure or

    permission denied

    Let’s reboot and try again.

Viewing 15 posts - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.