Wifi Networks show up. I cannot connect.

Forum Forums General Hardware Wifi Networks show up. I cannot connect.

  • This topic has 2 replies, 2 voices, and was last updated May 24-4:31 am by BobC.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #107378
    Member
    Desert_Dweller

      Hello!

      I’m new to Antix but I run Debian 11 on my daily driver and have used Debian for about 4 years. I installed Debian 11 on the machine in question here but because of it’s lack of power I am trying Antix.

      The biggest problem I need to overcome is getting Wifi to work and I have the DREADED Broadcom wifi card.

      05:02.0 Nework controller [0280]: Broadcom Inc. and subsidiaries BCM 4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)

      The Broadcom interface did work in Debian on this machine after installing firmware using a method described here: http://askubuntu.com/questions/55868/installing-broadcom-wireless-drivers?r=SearchResults

      The hotspot on my phone and the hidden network that I use on my Debian machine were detected in Connman after the install of Antix however it did not connect. The ethernet interface does work consistently.

      I tried using the NetworkManager command to get information on the interface. It identifies the MAC address, the General MTU and says the general state is 10 (unmanaged).

      The latest trick I have is an error on boot up that states: “Unable to create an interface to conman on the system bus. CMST will not be able to communicate with conman.” Connman now shows no network interfaces now.

      In an effort to eliminate variables I plugged in a usb network interface. While this did show simultaneous detection of both of my wireless networks, Connman would not connect using this interface either. I does not show up in Connman either.

      I did follow the method listed at the URL above to make sure the correct driver was installed however this did not cause the Broadcom interface to work in Connman.

      The network assistant in Antix identifies the Broadcom interface exactly as listed above.

      Ceni also identifies the Broadcom and detects my wifi hotspot but doesn’t detect any DHCP offers.

      Thanks in advance for looking at this. I will NOT complain if I can offer further clarification. I assure all I have spent the entire day today looking for that nugget of knowledge that would allow me to figure this out on my own and I will continue to do so. However, I do have a job and school so I have to set this project aside for the remainder of the night and humbly ask for help from strangers.

      Cheers to all.

      Here is the output from inxi. I was forced to copy it from the screen because this system is hiding files somewhere. That is another issue for another day.

      System:
      Kernel: 4.9.0-326-antix.1-486-smp arch: i686 bits: 32 compiler: gcc v: 10.2.1 Console: pty pts/0
      DM: slimski v: 1.5.0 Distro: antiX-22_386-full Grup Yorum 18 October 2022 base: Debian
      GNU/Linux 11 (bullseye)
      Machine:
      Type: Laptop System: Hewlett-Packard product: HP Pavilion ze2000 (EC201UA#ABA) v: Rev 1
      serial: <filter> Chassis: Quanta type: 10 serial: N/A
      Mobo: Quanta model: 3096 v: 47.0D serial: N/A BIOS: Hewlett-Packard v: F.11 date: 08/04/2005
      Battery:
      ID-1: BAT1 charge: 157.7 Wh (100.0%) condition: 157.7/88.8 Wh (177.6%) volts: N/A min: 14.8
      model: Hewlett-Packard JM-6 type: Li-ion serial: <filter> status: full
      Memory:
      RAM: total: 1.84 GiB used: 289.3 MiB (15.3%)
      Array-1: capacity: 4 GiB slots: 2 EC: None max-module-size: 2 GiB note: est.
      Device-1: U5 type: DRAM detail: synchronous size: 1024 MiB speed: N/A volts: N/A width (bits):
      data: 32 total: 32 manufacturer: N/A part-no: N/A serial: N/A
      Device-2: U6 type: DRAM detail: synchronous size: 1024 MiB speed: N/A volts: N/A width (bits):
      data: 32 total: 32 manufacturer: N/A part-no: N/A serial: N/A
      CPU:
      Info: single core model: Mobile AMD Sempron 3000+ bits: 32 type: UP smt: <unsupported> arch: K8
      rev: 2 cache: L1: 128 KiB L2: 128 KiB
      Speed (MHz): 800 min/max: 800/1800 volts: 2.2 V ext-clock: 200 MHz core: 1: 800 bogomips: 1591
      Flags: 3dnow 3dnowext 3dnowprefetch apic clflush cmov cx8 de fpu fxsr fxsr_opt lahf_lm mca
      mce mmx mmxext msr mtrr nx pae pat pge pni pse pse36 rep_good sep sse sse2 syscall tsc vme
      vmmcall
      Graphics:
      Device-1: AMD RS480M [Mobility Radeon Xpress 200] vendor: Hewlett-Packard driver: radeon
      v: kernel arch: Rage-9 ports: active: LVDS-1 empty: SVIDEO-1,VGA-1 bus-ID: 01:05.0
      chip-ID: 1002:5955 class-ID: 0300
      Display: server: X.org v: 1.20.11 driver: X: loaded: radeon unloaded: fbdev,modesetting,vesa
      gpu: radeon tty: 112×38
      Monitor-1: LVDS-1 model: Chi Mei Opto N150X3-L08 res: 1024×768 dpi: 86
      size: 304x228mm (11.97×8.98″) diag: 380mm (15″) modes: max: 1024×768 min: 640×480
      API: OpenGL Message: GL data unavailable in console for root.
      Audio:
      Device-1: AMD IXP SB400 AC97 Audio vendor: Hewlett-Packard driver: snd_atiixp v: kernel
      bus-ID: 00:14.5 chip-ID: 1002:4370 class-ID: 0401
      Sound API: ALSA v: k4.9.0-326-antix.1-486-smp running: yes
      Network:
      Device-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter vendor: Hewlett-Packard
      driver: 8139too v: 0.9.28 port: a000 bus-ID: 05:00.0 chip-ID: 10ec:8139 class-ID: 0200
      IF: eth0 state: down mac: <filter>
      Device-2: Broadcom BCM4318 [AirForce One 54g] 802.11g Wireless LAN vendor: Hewlett-Packard
      driver: b43-pci-bridge v: N/A bus-ID: 05:02.0 chip-ID: 14e4:4318 class-ID: 0280
      IF-ID-1: wlan0 state: down mac: <filter>
      WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
      Bluetooth:
      Message: No bluetooth data found.
      Logical:
      Message: No logical block device data found.
      RAID:
      Message: No RAID data found.
      Drives:
      Local Storage: total: 238.47 GiB used: 3.64 GiB (1.5%)
      ID-1: /dev/sda vendor: Silicon Power model: SPCC M.2 SSD size: 238.47 GiB speed: <unknown>
      type: SSD serial: <filter> rev: 5A0 scheme: MBR
      Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD-RW GWA-4082N rev: CC15
      dev-links: cdrom,cdrw,dvd,dvdrw
      Features: speed: 24 multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r state: running
      Partition:
      ID-1: / size: 116.74 GiB used: 3.64 GiB (3.1%) fs: ext4 dev: /dev/sda1 label: rootantiX22
      uuid: f6d70902-01a8-4f24-9c13-4150c0f224a9
      ID-2: /home size: 116.74 GiB used: 2.3 MiB (0.0%) fs: ext4 dev: /dev/sda3 label: homeantiX
      uuid: 605fae0f-d5d2-45fc-bb4a-62ec250fe1c2
      Swap:
      ID-1: swap-1 type: partition size: 128 MiB used: 0 KiB (0.0%) priority: -1 dev: /dev/sda2
      label: swapantiX uuid: a0e184b6-23d1-4429-be6a-0942a3c10b99
      Unmounted:
      Message: No unmounted partitions found.
      USB:
      Hub-1: 1-0:1 info: Full speed or root hub ports: 8 rev: 2.0 speed: 480 Mb/s chip-ID: 1d6b:0002
      class-ID: 0900
      Hub-2: 2-0:1 info: Full speed or root hub ports: 4 rev: 1.1 speed: 12 Mb/s chip-ID: 1d6b:0001
      class-ID: 0900
      Hub-3: 3-0:1 info: Full speed or root hub ports: 4 rev: 1.1 speed: 12 Mb/s chip-ID: 1d6b:0001
      class-ID: 0900
      Sensors:
      System Temperatures: cpu: 55.0 C mobo: N/A
      Fan Speeds (RPM): N/A
      Info:
      Processes: 143 Uptime: 37m wakeups: 2 Init: SysVinit v: 2.96 runlevel: 5 default: 5 Compilers:
      gcc: 10.2.1 alt: 10 Packages: pm: dpkg pkgs: 1549 Shell: Bash (su) v: 5.1.4
      running-in: pty pts/0 inxi: 3.3.25

      #107384
      Moderator
      BobC

        I assume you have the switch on

        Read this thread.
        https://www.antixforum.com/forums/topic/w-lan-problem-antix-21-i386/

        I found it with google search
        BCM4318 site:antixforum.com rfkill

        The last post…
        It works! That was the solution. Super thank you! I needed days and several complete new installations.

        1. sudo rfkill unblock -all (invalid command => I used rfkill then rfkill unblock 0)
        2. sudo apt purge firmware-b43-installer
        3. sudo apt update
        4. sudo apt install –reinstall firmware-b43-installer
        5. sudo modprobe -r b43
        6. sudo modprobe b43

        The problem is solved and the request can be closed.

        #107542
        Moderator
        BobC

          Desert_Dweller, did you give it a try? It was a while ago, but the op in that thread also had a BCM4318.

          I looked at the syntax for the first command.

          Try:

          $sudo rfkill list
          1: phy0: Wireless LAN
          	Soft blocked: no
          	Hard blocked: no
          2: dell-wifi: Wireless LAN
          	Soft blocked: no
          	Hard blocked: no
          3: dell-bluetooth: Bluetooth
          	Soft blocked: no
          	Hard blocked: no
          6: hci0: Bluetooth
          	Soft blocked: no
          	Hard blocked: no
          

          Choose your system’s wifi adapter(s identifier. In my case it looks like phy0 and dell-wifi. I can see neither of mine are blocked. So I switched my wifi off and tried again.

          $ sudo rfkill list
          1: phy0: Wireless LAN
          	Soft blocked: no
          	Hard blocked: yes
          2: dell-wifi: Wireless LAN
          	Soft blocked: no
          	Hard blocked: yes
          3: dell-bluetooth: Bluetooth
          	Soft blocked: no
          	Hard blocked: yes
          

          Now some are Hard blocked. Flipping the switch on will unblock those, but if phy0 was soft blocked the command to unblock it would have been
          sudo rfkill unblock 1

          The rest of his commands look good for antiX.

          Hope this worked out for you 🙂

        Viewing 3 posts - 1 through 3 (of 3 total)
        • You must be logged in to reply to this topic.