Wifi not working (antiX 19.1 Full 32-bit)

Forum Forums General Software Wifi not working (antiX 19.1 Full 32-bit)

  • This topic has 14 replies, 8 voices, and was last updated Jan 26-5:21 am by gf.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #31988
    Member
    Avatargf

    Creating a new topic per instructions from anticapitalista (24 Jan 2020 in “Connman wireless not…” thread, page 6)

    Summary of the problem: Unable to get Connman wifi working on antiX 19.1 Full 32-bit.
    Errors I get are:
    “Connman returned the following error: connect-failed. Would you like to retry?”
    “The agent request failed before a reply was returned.”

    Connman seems to operate the hardwire to my modem just fine. With the hardwire in I am able to do update/upgrade.

    Workaround for wifi is to use wicd instead of connman. Instructions posted under separate thread: “Workaround for wifi connection problem (for antiX19.1 i386 Full)”

    In antiX 17, wifi worked just fine. I have recently reinstalled antiX 17.3.1 and the wireless works fine again. So, the wireless hardware works.

    My notebook is 32-bit, non-pae since I have a Pentium M processor, 2GB of ram.

    Wireless card is:
    $ inxi -F
    portion of output:
    Network:
    Device-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
    driver: 8139too
    IF: eth0 state: down mac: 00:03:25:10:6a:9a
    Device-2: Intel PRO/Wireless 2200BG [Calexico2] Network driver: ipw2200
    IF: eth1 state: down mac: 00:0e:35:28:05:5d

    Here is iwconfig from antiX 17.3.1 installed on harddrive, with wireless working:
    $ iwconfig
    eth1 IEEE 802.11 ESSID:”MYWIFI”
    Mode:Managed Frequency:2.457 GHz Access Point: 00:C0:49:F0:76:32
    Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
    Retry limit:7 RTS thr:off Fragment thr:off
    Power Management:off
    Link Quality=78/100 Signal level=-25 dBm Noise level=-84 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:7
    eth0 no wireless extensions.
    lo no wireless extensions.

    Here are the persistent net rules for my install of antix 17.3.1:
    $ cat 70-persistent-net.rules
    –snip–
    # PCI device 0x10ec:0x8139 (8139too)
    SUBSYSTEM==”net”, ACTION==”add”, DRIVERS==”?*”, ATTR{address}==”00:03:25:10:6a:9a”, ATTR{dev_id}==”0x0″, ATTR{type}==”1″, KERNEL==”eth*”, NAME=”eth0″
    # PCI device 0x8086:0x4220 (ipw2200)
    SUBSYSTEM==”net”, ACTION==”add”, DRIVERS==”?*”, ATTR{address}==”00:0e:35:28:05:5d”, ATTR{dev_id}==”0x0″, ATTR{type}==”1″, KERNEL==”eth*”, NAME=”eth1″

    Attached is the persistent.netrules and iwconfig from running antiX19.1 live DVD.

    I am a newbie but I am happy to reinstall whatever versions of antiX, as often as needed to help get this fixed.
    I really like antiX – I think it’s a great distro.
    Please let me know what other info I need to post that would help.
    Thanks
    G

    #32009
    Member
    Avatarskidoo

    no idea how to solve, just mentioning what seems to be a significant detail:

    Missed beacon:7

    #32017
    Member
    Avatargf

    This afternoon, I tried connecting to this same network with a 64bit notebook, with antiX 19.1 full 64-bit, running live from a USB.
    Connman worked just fine and connected to this network with no problems.
    It seems to be just the connman in the 32-bit antiX 19 and 19.1 iso that has errors connecting.

    skidoo: the output in the first message is from antiX17.3.1 – that version of antiX is fine.
    It’s the output in the attached document that is for antiX 19.1, in which connman is having problems connecting to wifi.

    Thanks
    G

    • This reply was modified 1 month ago by gf.
    #32023
    Member
    capreacaprea

    It seems to be just the connman in the 32-bit antiX 19

    I prefer to assume it is your 32bit notebook which does not want to work with connman.
    Have you already tried to run your 64bit-notebook with a 32bit usb-live-stick ?

    #32028
    Forum Admin
    anticapitalistaanticapitalista

    Maybe running via a live dvd is too slow for connman?
    Did you install to that 32 bit laptop and then try setting up connman after installation?

    • This reply was modified 1 month ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #32033
    Moderator
    fatmacfatmac

    It took me a few attempts to get connman to connect when I first tried it on an old laptop, it can be very slow at recognizing wifi, but once found & connected, it seems to run OK, (still prefer ceni though 😉 ).

    Linux (& BSD) since 1999

    #32034
    Member
    Avatargf

    Hi anticapitalista,
    I just did a fresh install of AntiX 19.1 on the 32bit notebook. Then I tried setting up wifi with connman. I tried multiple times. Same errors.
    Thanks for the idea.
    G

    #32036
    Forum Admin
    anticapitalistaanticapitalista

    @gf – oh well, thanks for trying.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #32037
    Member
    Avatargf

    Hi Caprea,
    As you suggested, I tried my antiX 19.1 32-bit full dvd in my 64-bit notebook just now. Connman connects to wifi just fine.
    That was a good idea to try.
    Thanks
    G

    #32038
    Moderator
    masinickmasinick

    I have been successful in using Connman so I know that it works. I have used it for live and installed instances. I have a Dell Inspiron 5558 laptop, which is very hospitable to most distributions.

    I’m speculating that Connman is not detecting certain network equipment.

    I think that most people have been able to get either Ceni or wicd working.

    I’ve tried all three of them and they all work on the hardware I am using.

    Brian Masinick

    #32039
    Member
    malemale

    Right, Brian.

    It has nothing to do with 32bit or 64bit.
    It is a user error with connman.
    Here I have already demonstrated this with the same device (Intel PRO/Wireless 2200BG [Calexico2] Network driver: ipw2200)

    Connman wireless not working in antiX 19.1 Full 32-bit

    • This reply was modified 1 month ago by male.

    Male is the capital of the Maldives and its wonderful people.

    #32041
    Moderator
    masinickmasinick

    I must have missed that point earlier. I used to have a Dell D600 that used the IPW2200 series network card and I also used to have a Gateway 2000 which used to have a Broadcom 4311 interface. Though there are many other network cards out there, if those two are supported we cover a large number of older systems (and I believe that we do).

    As hard as we all try, I hope that we can generate even better documentation to assist people who encounter issues. I have a feeling that the work that Dolphin Oracle has done may very well cover a lot of this.

    Anyway I genuinely appreciate everyone’s effort and I also hope that we can help those who continue to experience difficulty. Sometimes I think that differences in experience, language barriers and other communication difficulty, including the confusing exchanges recently shared, contribute to misunderstanding. Nevertheless I hope that kindness, patience and our best efforts will continue to show the excellence of this community.

    Thanks for your efforts in this regard. I definitely appreciate it 😊

    Brian Masinick

    #32042
    Member
    Avatargf

    Hi,
    There is one thing I noticed while in the connman interface, wireless tab.
    I kept having to click on my network several times before I was able to click on the “connect” button.
    click on my network
    Click connect
    It would reply with a message, you have to selwct a wifi network before clicking connect” – something like that.
    It was very tricky to click the network fast and then click the connect button.

    It’s like the scanning kept overwriting the list of available networks ( removing my selection). It’s like scanning didn’t stop.

    Finally I’d click them fast enough to get to the wifi setup screen and put in my password and get the errors reported above.

    I noticed that I did not have this hesitation-delay when I used the 32-bit dvd on my 64 bit notebook. That was smooth as silk.

    My 32bit notebook has 2GB of memory. I thought that’s plenty for antiX. I had tried antiX core and ceni connected to wifi just fine.

    Also connman controls the hardwire networking just fine in AntiX 19.1.
    It’s just the wifi that I am having trouble with.

    Is it possible that some part of the memory module or hardrive is failing?
    Can you tell me commands to check this? If only to eliminate the possibility.
    Thanks
    G

    #32059
    Member
    AvatarModdIt

    gf writes: among his ever stranger claims.

    Is it possible that some part of the memory module or hardrive is failing?
    Can you tell me commands to check this? If only to eliminate the possibility.
    Thanks.

    I think this person is at least now, playing games and wasting other peoples time.
    He gets more and more absurd.

    Last post anyone from our group will make where he is involved. Now agree with male

    #32067
    Member
    Avatargf

    Hi anticapitalista,
    Have I provided what you requested and could there be a defect?
    Thanks
    G

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.