WiFi soft blocked thetering usb not work

Forum Forums General Hardware WiFi soft blocked thetering usb not work

  • This topic has 9 replies, 2 voices, and was last updated Aug 2-9:05 am by maary79.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #63839
    Member
    maary79

    Hi.
    I just installed the antix base in a 2008 mini pc.
    rfkill list says that wifi is soft blocked.
    rfkill unblock all unblocks wifi but does not connect.
    Thetering usb does not make me connect via cable with the smartphone.
    When I restart the Wifi it is always soft blocked.

    Ethernet controller: Realtek Semiconductor RTL8101/2/6E
    Ethernet controller: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter



    #63840
    Member
    Xecure
    Helpful
    Up
    0

    Control Centre > Network > antiX-wifi-switch > ceni.

    Are you running antiX 19.4 base or a previous antiX base release? The new version automatically unlocks wifi on the first boot and gives you options to select your Wireless access point.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #63906
    Member
    maary79
    Helpful
    Up
    0

    No, I have installed 19.3, I have now seen that the Italian mirror does not yet have 19.4, while others already have the new version.
    I connected with ethernet cable, the system is now updated, but it does not connect with wifi.
    Is there any way to unblock wifi?
    Why is thetering usb (smartphone) not working?

    • This reply was modified 2 months, 2 weeks ago by maary79.
    #63908
    Member
    Xecure
    Helpful
    Up
    0

    Is there any way to unblock wifi?

    A video you may find useful: https://www.youtube.com/watch?v=b5Ryp4gM2Eg
    There is a way to make to unblock it permanently if you cannot use the option in the system tray:
    connmanctl enable wifi

    Why is thetering usb (smartphone) not working?

    It should work as soon as you connect your phone to the computer, but it depends on the android version running on your smartphone.
    Connman (if running) will automatically use USB tethering (if configured on the phone) if the linux kernel supports it. If the smartphone is from 2018 or newer, you may need to install the antiX 4.19 kernel or the 5.10 kernel (depending on how new the phone is).

    A small note. After you update (you may need to use repo-manager and choose a different mirror), please try the antix-wifi-switch app to switch to connman, as it has better support for USB tethering compared to ceni.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #63909
    Member
    maary79
    Helpful
    Up
    0

    There is a way to make to unblock it permanently if you cannot use the option in the system tray:
    connmanctl enable wifi

    It says it’s already unlocked. But connman says there is no network available.
    If I use ceni gives me the error of the second image posted, in the first post.

    #63910
    Member
    maary79
    Helpful
    Up
    0

    It should work as soon as you connect your phone to the computer, but it depends on the android version running on your smartphone.
    Connman (if running) will automatically use USB tethering (if configured on the phone) if the linux kernel supports it. If the smartphone is from 2018 or newer, you may need to install the antiX 4.19 kernel or the 5.10 kernel (depending on how new the phone is).

    A small note. After you update (you may need to use repo-manager and choose a different mirror), please try the antix-wifi-switch app to switch to connman, as it has better support for USB tethering compared to ceni.

    Ok, I have a smartphone with Android 10.
    It is not even seen as memory.
    The mini pc belongs to a friend of mine with Iphone … even worse!
    We try to make the wifi connection work.

    #63911
    Member
    Xecure
    Helpful
    Up
    0

    That is because the wireless connection is already configured in connman.
    Please, try to see if this command can run in the terminal
    antix-wifi-switch --gui ceni

    It will configure everything so that wifi works with ceni.

    If the command doesn’t work, please follow these instructions:

    1. Stop connman
    sudo service connman stop

    2. stop any residual wpa_supplicant processes running
    sudo killall wpa_supplicant

    3. connect using ceni
    sudo ceni

    You will now be able to connect to the wireless access point, but you will not be able to connect to the internet yet.
    You will need to reconfigure the configuration to properly connect to the internet

    sudo rm /etc/resolv.conf
    sudo ln -s /run/resolvconf/resolv.conf /etc/resolv.conf

    Now you should be able to connect to the internet. Please, check if you can update the system (if there is a EXPRESSIG error, please follow these instructions to fix it)

    After you update the system, please run the first command for antix-wifi-switch, so that CENI is the default and connman doesn’t start anymore at boot time.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #63912
    Member
    Xecure
    Helpful
    Up
    0

    Ok, I have a smartphone with Android 10.

    First try kernel 4.19 (install after updating the system using the package installer, the first option in the Kernel category) and reboot to see if USB tethering works. If it doesn’t, install the second kernel option (5.10) and reboot again.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #64140
    Member
    maary79
    Helpful
    Up
    0

    Hi, After this command, with ceni it works.
    Thank you!

    $ antix-wifi-switch –gui ceni

    #64141
    Member
    maary79
    Helpful
    Up
    0

    Ok, I have a smartphone with Android 10.

    First try kernel 4.19 (install after updating the system using the package installer, the first option in the Kernel category) and reboot to see if USB tethering works. If it doesn’t, install the second kernel option (5.10) and reboot again.

    Ok, at the moment I leave it like this, the pc is more convenient to connect it via wifi.
    Thank you.

    Solved.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.