Wifi with connman – antiX 19.2

Forum Forums General Tips and Tricks Wifi with connman – antiX 19.2

Tagged: 

  • This topic has 110 replies, 30 voices, and was last updated Apr 22-8:16 am by antique23.
Viewing 15 posts - 91 through 105 (of 111 total)
  • Author
    Posts
  • #69243
    Member
    fishmanloveslinux

      I am having the reverse issue. My ethernet will not connect. Cable works fine on other machines. I am not good with some of these network managers. I hope I am not posting in the wrong place.
      Machine is a Lenovo Thinkpad R61.

      #69245
      Moderator
      Brian Masinick

        I don’t know why Connman isn’t working for you.

        Try using ceni;. I have used it with multiple systems for many years.

        Let us know if that solves the problem or not.

        --
        Brian Masinick

        #69248
        Member
        antixjim

          When I connected my computer to my router, I ;used a LAN cable. I did not connect it using a USB cable. Using the LAN cable I had no problems. The only thing to be sure of is that the LAN is turned on in the Connman window. I did find my WiFi connection worked better after I turned the LAN connection OFF in Connman.

          #69262
          Member
          Xecure

            I am having the reverse issue. My ethernet will not connect. Cable works fine on other machines. I am not good with some of these network managers. I hope I am not posting in the wrong place.
            Machine is a Lenovo Thinkpad R61.

            We require a bit more info on this.

            What version and edition of antiX?

            If base/full, when you launch connman from the Control Centre, can you see the Ethernet (Wired) interface? Is it ON? Can you switch it off and then ON to see if it reconnects? If the Network is ON, what are the symptoms? What does the Control Centre > Maintenance > Netwrok assistant report? Any of the tests work?

            If on net/core, we will need more details on how you try to connect.

            antiX Live system enthusiast.
            General Live Boot Parameters for antiX.

            #70319
            Member
            ke1th

              I’m posting this here in case it helps another newbie to get a new wifi adapter working on antiX. I searched around the forums but couldn’t find any specific help. I was looking for help along the lines of “installing new wifi adapter” or “wifi problems” and tried the essential how-to list with no joy.

              I originally installed antiX-19.4 on an Acer mobo with no wifi adapter available, and all seemed OK via Ethernet. When I got hold of a cheap anonymous USB wifi adapter dongle, I plugged it into the USB port and rebooted expecting it to show up automatically. I tried ifconfig and then connman and updated the system. Probably totally naive, but there you go. Nothing, nada, zilch.

              I then opened a terminal window and used the command lsusb to see if the device was even recognised, and it returned “Bus 001 Device 002: ID 0bda:b812 Realtek Semiconductor Corp.” A bit of websearching revealed that it is a Realtek rtl88x2bu device, and various updated drivers are available on Github. I used the driver from http://github.com/cilynx/rtl88x2bu as follows:

              sudo apt update
               sudo apt upgrade
               git clone http://github.com/cilynx/rtl88x2bu
               cd rtl88x2bu
               sudo ./deploy.sh
              

              after which the adapter showed up as wlan0 when I ran ifconfig, and the local wifi networks scanned and showed up and I was able to configure access as normal.

              I’d just like to add that this approach worked for me, but if it’s the ‘wrong’ approach in some way or I missed the obvious then please feel free to put me straight.

              #70321
              Moderator
              christophe

                Hello ke1th,

                I’d just like to add that this approach worked for me

                Anything that works is welcome here. Thanks for walking us through what you found for your hardware.

                My Realtek Semiconductor Corp wifi adapters have always work in antiX “out-of-the-box,” but when someone finds something “ain’t quite working,” this just might be the ticket. And we appreciate it.

                in case it helps another newbie to get a new wifi adapter working on antiX.

                😉

                confirmed antiX frugaler, since 2019

                #70935
                Member
                roland

                  There is definitely something strange going on with Connman. From its first appearance I have tried it on every fresh install, never with success. I could see the Connman network screen on Grup Yorum 19, and go through the connect motions as far as pressing the button to connect but it never connected. On other previous installs of 16 and 17 it would quite simply fail to load or fail to begin execution.

                  But my latest fresh install of Grup Yorum 21 showed Connman to already be up and running at the first live boot, simply waiting for me to enter the passphrase. In a way I am disappointed as several years use of back-stop Ceni now appear to be over. But I will always keep Ceni in the background, just in case!

                  #70940
                  Moderator
                  Brian Masinick

                    @roland: no need to stop using Ceni if that is what you prefer.

                    I’ve been using Connman; both work for me, but I admit that I forgot the tricks I used to set up the connection automatically with Ceni and Connman is automatically loaded and initializing so I stick with it and it is very reliable.

                    • This reply was modified 2 years, 5 months ago by Brian Masinick.

                    --
                    Brian Masinick

                    #72036
                    Member
                    seriousness

                      Every 5 minutes connmand throws this error:

                      connmand[1527]: Failed to find URL:http://ipv6.connman.net/online/status.html

                      Is this necessary? How can I get rid of that?

                      #72047
                      Member
                      seriousness

                        According to /etc/connman/main.conf , connman checks two URLs for connectivity:
                        http://ipv4.connman.net/online/status.html and http://ipv6.connman.net/online/status.html .

                        If I enter the first URL in my web browser, it leads to an empty page. The second URL gives an

                        502 Bad Gateway
                        nginx

                        error.

                        #72052
                        Member
                        Xecure

                          It is a problem in connman’s page. As you have confirmed, the ipv6 subdomain doesn’t exist anymore.

                          It is related to how connman decides when a connection status is “Online”. It checks if the ipv4 or ipv6 connection was enabled and it can connect to the internet (and not only to the router). When it connects to the router, it changes the connection state to “Ready”. When it confirms that it has internet access, it changes the connection state to “Online”.

                          SOLUTIONS:
                          You can either (only ONE of the methods):

                          A) Disable the online check.
                          sudo sed -i 's!# EnableOnlineCheck = .*!EnableOnlineCheck = false!' /etc/connman/main.conf
                          This will disable the online check for future connections. The connection will always appear as READY instead of ONLINE (that is the only drawback)

                          B) Change the ipv6 URL check
                          sudo sed -i 's!# OnlineCheckIPv6URL= .*!OnlineCheckIPv6URL= http://connman.net/online/status.html!' /etc/connman/main.conf
                          This will change the URL for the ipv6 url to a different URL that I think works (but cannot confirm if it is IPV6 or not).

                          Probably this needs a connman patch in the future. I will have a look and see if I can ask the kernel group to change this commit. I will see how reporting bugs works there (I have never done so myself).

                          antiX Live system enthusiast.
                          General Live Boot Parameters for antiX.

                          #72053
                          Moderator
                          Brian Masinick

                            According to /etc/connman/main.conf , connman checks two URLs for connectivity:
                            http://ipv4.connman.net/online/status.html and http://ipv6.connman.net/online/status.html .

                            If I enter the first URL in my web browser, it leads to an empty page. The second URL gives an

                            502 Bad Gateway
                            nginx

                            error.

                            I don’t personally know the significance of these two pages, but it seems that the configuration is being used to check whether an IPV4 or an IPV6 network is present. That’s a questionable way to do this, and I wonder if there is any consequence to simply commenting out or removing these entries from the configuration file?

                            One possibility: copy the original file to a safe (alternate) location, such as a test directory beneath your home directory, then remove the two entries from the configuration file. If Connman still works, it’ll get rid of the extra connections attempts and errors. If it causes Connman to fail, you can copy back the saved file, making sure to keep the same file permissions and ownership. Try it out and see what you learn and share your findings.

                            EDIT: Xecure was writing at the same time; his suggestions are arguably better; you can try his, or try both; your choice.

                            • This reply was modified 2 years, 4 months ago by Brian Masinick.

                            --
                            Brian Masinick

                            #72056
                            Member
                            ModdIt

                              Long recent discussion on this subject here, for wired connection I have moved to CENI.
                              Will probably move laptop to that too. Connman purged..

                              http://forum.artixlinux.org/index.php/topic,2979.30.html
                              below post is perhaps of main interest.

                              Reply #32 – 30 August 2021, 18:35:19
                              This patch adds configuration options OnlineCheckIPv4URL and OnlineCheckIPv6URL to connman, so users can
                              configure their own URLs for the online check:
                              http://git.kernel.org/pub/scm/network/connman/connman.git/commit/?id=9d7e55f40e807ea7d28a34b20e50af1b06ea2fda

                              This patch organizes the online check code into a single function:
                              http://git.kernel.org/pub/scm/network/connman/connman.git/commit/?id=a84f03f6f6c5d69cbb2e2c32326f9af603b0f8a7

                              This patch makes the setting EnableOnlineCheck globally respected. If it is set to false, no server pinging will be done by connman:
                              http://git.kernel.org/pub/scm/network/connman/connman.git/commit/?id=85d04c03dd0f9f35394d84ba2fcc6ccfc17af293

                              Note: For anyone who values simplicity in software, running connman (as a daemon) is an overkill, so even in the scenario when user is on a laptop, frequently changing networks (for example, using wifi in cafes or hotels), using setnet as a quick and easy one-shot configuration generator for wpa_supplicant should be preferable. Otherwise, one can use wpa_cli, which is simpler, but requires some learning.

                              • This reply was modified 2 years, 4 months ago by ModdIt.
                              • This reply was modified 2 years, 4 months ago by ModdIt.
                              #72374
                              Member
                              Gabd

                                I’m running antiX-21_x64. Connman`s GUI shows my WEP-secured access point as WPA-PSK-secured.
                                Can`t connect to AP.
                                How I can change the security type of wifi connection?
                                Thanks.

                                • This reply was modified 2 years, 4 months ago by Gabd.
                                #76906
                                Member
                                madibi

                                  @Gabd I had a very old router wifi from USRobotics. It aired it’s signal in both wep and WPA-PSK, with 2 different password (the psk pw was obligatory lon 64 characters. Can you verify if this is the case of your router (or AP)? In this case you should change settings there

                                Viewing 15 posts - 91 through 105 (of 111 total)
                                • You must be logged in to reply to this topic.