won't boot after fresh install

Forum Forums New users New Users and General Questions won't boot after fresh install

This topic contains 11 replies, has 4 voices, and was last updated by JoeR Mar 14-12:43 pm.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #7690
    Member
    Avatar
    JoeR

    I got hold of some updated hardware (64bit i7) and did a fresh install of the newest antiX. Everything went well and installed normally, I then tried to boot up without the install usb drive, and it would’t boot to the hdd, Error was no boot drive found or disk error. I was able to use “Super Grub2 Disk” which did a search for the antiX boot partition then selected it and booted normally into antiX, and everything ran fine. Just can’t boot without the grub2 usb drive.

    I have no idea where to start to try to solve this one. Any help is much appreciated.
    Joe

    Super GRUB2 Disk helps you to boot into most any Operating System (OS) even if you cannot boot into it by normal means.

    Partition: ID-1: / size: 584G used: 3.7G (1%) fs: ext4 dev: /dev/sda2
    label: rootantiX uuid: d7cab72d-931a-4cb4-be24-31afe0386c27
    ID-2: /boot/efi size: 253M used: 121K (1%) fs: vfat dev: /dev/sda1 label: N/A uuid: EA51-9F8F
    ID-3: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
    label: antiXswap uuid: 7c52137b-7b68-4dc2-8694-3c68d2534b0d

    #7691
    Member
    Avatar
    skidoo

    “ControlCenter —}Maintenance —} Boot Repair” might provide a fix

    #7692
    Member
    linuxdaddy
    linuxdaddy

    Hi Joe,

    Is the partition “/dev/sda1” marked as bootable by using gparted and
    setting the flag using the live cd/usb.
    It’s under system menu-gparted. then highlight the partition with grub and
    under the partition menu is manage flags.
    Also check in the bios and make sure it’s set to boot efi not legacy, and
    you might have to disable the secure boot and boot keys if any.

    Normal == 🙂
    depends on the surrounding crowd ?!

    #7693
    Member
    Avatar
    JoeR

    Thank you, it appears that the flags are set properly. Because this computer has been re-purposed to me and delivered without a hdd my next step is to root around the bios as “linuxdaddy” suggested. I will report back. Joe

    Attachments:
    #7696
    Member
    linuxdaddy
    linuxdaddy

    you’re welcome,
    One more thing to mention in bios is that under boot devices make sure hdd is listed as
    the first one.

    Normal == 🙂
    depends on the surrounding crowd ?!

    #7712
    Member
    caprea
    caprea

    Nice How to for Uefi from mx comunity
    https://mxlinux.org/wiki/system/uefi
    You also have to disable fast boot.
    I assume the picture from gparted is not from a fresh install, bc it’s 17,34gb.

    #7715
    Member
    linuxdaddy
    linuxdaddy

    Nice link caprea, that’ll help people with bios and bootloader problems
    on newer machines. It explains the mbr and dual boot setup too.

    Normal == 🙂
    depends on the surrounding crowd ?!

    #7736
    Member
    Avatar
    JoeR

    After some serious research i can’t find the efi / legacy setting in the bios. I looked into flashing the bios but it requires a windows or dos install which i don’t have I guess I am stuck on this one.

    Is there a fully supported hardware thread for antiX? Maybe I could update the MB but keep the cpu?

    my motherboard is an ECS
    H61H2-M3 (1.0)
    http://www.ecs.com.tw/extra/windows_8_support/intel_win8_biosupgrade.html

    #7738
    Member
    Avatar
    skidoo

    H61H2-M3 ecs youtube
    ^—- several videos available dealing with setting boot order, bios howto, etc

    #7739
    Member
    linuxdaddy
    linuxdaddy

    hi skidoo and joeR,
    here is a link to the manual for your mobo
    https://www.manualslib.com/manual/1006281/Ecs-H61h2-M3.html
    I didn’t see legacy mode I only mentioned that because it’s the
    setting my asus mobo has…yours is new enough it might be efi only.

    Normal == 🙂
    depends on the surrounding crowd ?!

    #7793
    Member
    caprea
    caprea

    You can boot antix in Uefi-mode.
    The main part is to disable secure-boot.
    In the manual from linuxdaddy it’s described
    https://www.manualslib.com/manual/1133955/Ecs-H61h2-M3.html?page=58

    #7796
    Member
    Avatar
    JoeR

    Thank you all for your generous support and time. I am still using the grub disk to get into antiX but learning lots while trying to solve the problem. I am trying a two pronged approach.

    approach 1.
    try to repair the situation using antiX’s “boot repair”. Using the antiX live usb I boot up and then run boot repair on /dev/sda1, everything seems to go properly and it reports success but still doesn’t boot.

    approach 2.
    flash the old motherboard bios to the newest version. Because the machine is not windows or dos i use rufus 2.18 for windows to make a freedos bootable usb. USB creation happens without errors but once I try to boot into dos i get the same old error “no boot drive found or disk error” and that is while trying to boot into the freedos usb.

    I also believe I have found a competent computer shop in Westlock Alberta, Canada to take it into, but part of the fun is solving issues on my own, I may get frustrated and throw in the towel 🙂
    Joe

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.