X can't see my keyboard if I start it by hand

Forum Forums New users New Users and General Questions X can't see my keyboard if I start it by hand

Tagged: ,

  • This topic has 3 replies, 3 voices, and was last updated Feb 12-8:55 am by Anonymous.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6468
    Anonymous

      I need to figure out what slim (slim starts X, yes?) is doing that makes X able to see my keyboard and touchpad, so that I can replicate it with startx.

      I’m coming to AntiX from Arch, because they dropped 32-bit support and I was sick of systemd. In Arch, I had things set up to my preferences: boot to a non-X CLI environment, and let me start X myself with my own .xinitrc. It worked fine. I’ve tried both antiX-core and antiX-base, and antiX-base if allowed to boot up to runlevel 5 has no problem with my EeePC 901’s keyboard or touchpad. They work fine. But both booting to runlevel 3 in antiX-base and then typing startx, or installing Xorg in antiX-core and then typing startx, leave the system unresponsive to keyboard or touchpad input.

      Googling for information on configuring Xorg turns up a lot of claims that X no longer needs configuration files because it’s become “smart” enough to do the right thing. Why would it be doing different things depending on whether I let runlevel 5 start it or try to start it myself? Where should I start in troubleshooting this?

      #6477
      Forum Admin
      anticapitalista

        Welcome!

        Try this

        startx not working in Stretch (with sysvinit-core)

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #6478
        Forum Admin
        Dave

          I do not remember exactly but I think it is because the permissions to the input devices was removed from the regular user and granted upon login through the consolekit? Interface. It might be something other than consolekit… Maybe serverauth.

          Anyway for security issues (what they are I do not know) it has been done but IIRC you can get around it but making the user part of the “input” group (maybe the video group as well) . It would be interesting if you find out what the “proper” way is though.

          Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

          #6484
          Anonymous

            Thank you! I added needs_root_rights = yes to /etc/X11/Xwrapper.config in accordance with the first link above, and that fixed it!

            And thank you for providing a 32-bit systemd-free distro. The Arch community so far seems only to offer one or the other.

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.