Xmms’s menu name doesn’t display correctly relating to IceWM

Forum Forums New users New Users and General Questions Xmms’s menu name doesn’t display correctly relating to IceWM

  • This topic has 7 replies, 5 voices, and was last updated Jul 21-10:50 am by Xecure.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #63323
    Member
    ren1268

    Hi! I am new to antiX. Using locale zh_CN (Simplified Chinese Language) in 19.4, 64 bits live mode, Xmms’s menu name is not displayed correctly such as invoke Ctrl + P for Preference menu. The Chinese phrase of menu name does not display. It is showed “$(A)JWQ!On”. This does not happens when using antiX 19.2, 32 bits. Any ideas? Thanks in advance.

    #63327
    Member
    PPC
    Helpful
    Up
    0

    There’s probably a bug in xmmss’s .desktop file of that particular version of antiX. Can you copy that file over for the antiX 19.2 32 bits version?
    The .desktop files are over at /usr/share/applications
    You can copy from that folder without any problems, but you need root privileges to copy to it, so, to do that you have to run your file manager in root mode- be careful with that!

    On the other hand, the fact that xmms’s title appears the way it does on it’s window may indicate that there’s also some problem with the application itself.

    Non related advice: you can try using the Package installer to install “deadbeef”- despite it’s horribale name, it’s a very good and light music player, way more recent than xmms, and it may run better on your computer.

    P.

    • This reply was modified 5 days, 4 hours ago by PPC.
    #63336
    Member
    Xecure
    Helpful
    Up
    0

    Are you using the same icewm theme? If not, can you see if the theme config uses a different font? Some fonts support non-latin characters, but some only latin characters.
    The program seems to be OK, but the titlebar is rendered by the window manager. Try switching between different icewm theme or to fluxbox.

    #63364
    Moderator
    BobC
    Helpful
    Up
    0

    If you find only certain fonts work correctly, let me know in case it would affect the usability on the themes I created.

    #63375
    Member
    ren1268
    Helpful
    Up
    0

    Hi PPC,

    Here is the xmms.desktop file from antiX-19.2.1_386-base Hannie Schaft 29 March 2020 version.

    Hi Xecure,

    I am using the same icewm default theme, blueday-medium for 19.2 and 19.4 antiX. All icewm theme is facing same issue.

    However, when antiX is switched to fluxbox or jwm, it is displayed the correct Chinese phrase. Suspect IceWM 2.3.4 version cannot rendered Chinese phrase compared to version 1.6.5. Inside ~/.icewm folder, there is a ‘preferences’ file in regard to font and cannot see what goes wrong. As for fluxbox and jwm, font cannot be identified but they are translated perfectly.

    Hi BobC,

    I only touched font for gtk1 – xmms player to get it worked but no luck sometimes. Almost all Chinese Language font is worked correctly.

    Thank you.

    #63376
    Member
    ren1268
    Helpful
    Up
    0

    Hi PPC,

    Here is the xmms.desktop file from antiX-19.2.1_386-base Hannie Schaft.

    [Desktop Entry]
    X-Desktop-File-Install-Version=0.11
    Name=XMMS
    Name[el]=xmms
    Comment=Multimedia Player
    Comment[el]=Media player
    Comment[ru]=Медиа-проигрыватель
    Comment[uk]=Медіа-програвач
    Comment[cs]=Přehrávač hudby založený
    Comment[tr]=Çokluortam Oynatıcı
    Comment[de]=Audio-Player
    Comment[zh_CN]=基于Qt4的多媒体播放器
    Comment[zh_TW]=基于Qt4的多媒體播放器
    GenericName=Audio player
    GenericName[cs]=Přehrávač hudby
    GenericName[de]=Audio-Player
    GenericName[ru]=Аудио-проигрыватель
    GenericName[uk]=Медіа-програвач
    GenericName[tr]=Ses Oynatıcı
    GenericName[zh_CN]=音乐播放器
    GenericName[zh_TW]=音樂播放器
    Exec=xmms
    Icon=xmms
    Terminal=false
    Type=Application
    Categories=AudioVideo;Player;Audio;

    Hi Xecure,

    I am using the same icewm default theme, blueday-medium for 19.2 and 19.4 antiX. All icewm theme is facing same issue.

    However, when antiX is switched to fluxbox or jwm, it is displayed the correct Chinese phrase. Suspect IceWM 2.3.4 version cannot rendered Chinese phrase compared to version 1.6.5. Inside ~/.icewm folder, there is a ‘preferences’ file in regard to font and cannot see what goes wrong. As for fluxbox and jwm, font cannot be identified but they are translated perfectly.

    Hi BobC,

    I only touched font for gtk1 – xmms player to get it worked but no luck sometimes. Almost all Chinese Language font is worked correctly.

    Thank you.

    #63378
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    Try updating to latest IceWM version in our repos (v. 2.6.0)

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #63381
    Member
    Xecure
    Helpful
    Up
    0

    It seems to be only xmms + icewm. Other applications in icewm do display the Chinese characters correctly on the title bar.

    • This reply was modified 4 days, 8 hours ago by Xecure.
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.